Solved

Outlook 2010 Client having autodiscover issues

Posted on 2011-02-17
10
766 Views
Last Modified: 2012-05-11
Hi Guys,

I am having an issues where one outlook 2010 client on our network is having a problem with their autodiscover.

It all started then they were getting a certificate error to say that the name on the site didnt match that on the certifiate. at the top of the certificate the url was autodiscover.domain.co.uk

Now our autodiscover IIS directory is set to its default, so it listens on the autodiscover.domain.local url and we have a SAN SSL certificate with both the external and internal autodiscover domain in it, along with a few others.

I have checked this is still being used in exchange for IIS, and that it is still in the certificate stre with its private key. All other clients work fine except this one, which seems to want to talk to the exchange server using the autodiscover.domain.co.uk domain rather than the autodiscover.domain.local domain it should, therefore a mismatch error.

Also note the client when creating a new outlook profile, cannot autodiscover their account either. I have repaired office 2010 on the client but no results from that.

Any ideas?
0
Comment
Question by:sparky2156
  • 4
  • 3
  • 3
10 Comments
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34919457
What version of exchange is this?

Is the machine with the problem domain joined? Check it's DNS settings and make sure that when you ping the autodiscover names on your certificate that they resolve to the internal IP address of your CAS server
0
 
LVL 3

Author Comment

by:sparky2156
ID: 34919505
Exchange 2010. client is just standard DHCP client.

As for the domain, thats a good one. we havnt setup the autodiscover.domain.local in the DNS internally. And the external domain autodiscover.domain.co.uk doesnt even exist, as it isnt actually needed . . .

But if it were a DNS issue, surely it would be systemwide for all users, not just one?
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34920087
Are you using SRV records in DNS?
0
Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
LVL 43

Expert Comment

by:Amit
ID: 34920265
0
 
LVL 43

Expert Comment

by:Amit
ID: 34920284
Check this too

http://www.theemailadmin.com/2010/02/outlook-and-autodiscover-errors/

It refers to some registry issue at client end
0
 
LVL 3

Author Comment

by:sparky2156
ID: 34941743
I am using SRV records in out own DNS for our autodiscover.domain.local domain.

Thanks for the links - i read through them but they still dont explain why the clients are talking to the external DNS recod autodiscover.domain.co.uk

I checked the certificate message again and noticed that the client machine being affected by this is being issued the default self-signed certificate from exchange, and not the one we purchased. I checked the EMC and the purchased certificate is assigned the IIS, SMTP, POP and IMAP services. The only other certificate assigned to anything the the self signed Microsoft Exchange certificate and it has been assigned SMTP, which i cannot remove, although my officially signed certificate is assigned the SMTP role as well.

Why would a client machine be getting the wrong certificate when it is set correclty in exchange?
0
 
LVL 43

Expert Comment

by:Amit
ID: 34941773
0
 
LVL 31

Expert Comment

by:MegaNuk3
ID: 34945261
Have a look in IE at the certificates on your problem machine and see if the self signed one exists there or not, if it does then delete it and clear the SSL cache. Also ensure IE is set to bypass proxy for local addresses.

Also ping the autodiscover names from that PC and confirm it is getting the same IP address reply as a working PC, there may be an invalid HOSTS entry on the PC.
0
 
LVL 3

Accepted Solution

by:
sparky2156 earned 0 total points
ID: 35093666
Issue resolved.

Problem was with a single client not being able to resolve the autodiscover domain, even after re-installing outlook. It wante dto use the external autodiscover URL and neglected the provided internal one.

The external atodiscover url was actually part of the ssl certificate already (as well as the internal one) so I created the external autodiscover subdomain and this resolved the issue.

Thanks.
0
 
LVL 3

Author Closing Comment

by:sparky2156
ID: 35135770
Resolved Issue myself
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Is your Office 365 signature not working the way you want it to? Are signature updates taking up too much of your time? Let's run through the most common problems that an IT administrator can encounter when dealing with Office 365 email signatures.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question