Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1092
  • Last Modified:

Exchange and Outlook Autodiscover service

Hi,

I noticed that some of our Outlook clients are having autodiscover issues like Out of Office not working, global address book is not syncing when the other half of the outlook users are fine.

This is what I noticed that when you go to Outlook 2007, in FILE then INFO....the ones that are able to use OOF and GAL without issues are able to see the external URL which is associated with an SSL ceritifcate.  (See attached).

I need help in troubleshooting and solving to why the problematic Outlook clients are not seeing the url REMOTE.DOMAIN.COM that's associated with the SSL certificate and some do.  Please be detailed with your answer.

Thank you
OUTLOOK-SCREENSHOTS.docx
0
Wayne88
Asked:
Wayne88
  • 6
  • 3
  • 3
2 Solutions
 
MegaNuk3Commented:
Firstly, if this is SBS2008, then ensure you are on E2k7 SP3

Are you running outlook 2007 with the latest updates? Have you compared the Outlook versions of working ones vs. Non working?

Are all the machines domain joined?
0
 
Wayne88Author Commented:
Hi MegaNuk3,

Yes, the Exchange server was patched with SP3 and all Outlook 2007 are running the latest updates.  Also yes that all Outlook are running the same version joined to the domain.

Thanks,

Wayne
0
 
brotaCommented:
are they internal or external?
is your autodiscoveruri configured correctly

have you tried the outlook test email autoconfiguration to see what url the users are looking for to retrieve the info?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
Wayne88Author Commented:
Hi Brota,

Attaced is the result from the failed Outlook test.
outlook-test.jpg
0
 
brotaCommented:
can you resolve remote.company.com internally without any ssl errors?
It appears it is using that from the scp setting in Active Directory
0
 
Wayne88Author Commented:
Hi Brota,

When I ping remote.company.com internally I get the server reply with the server's IP address so yes I can.

Thanks.
0
 
Wayne88Author Commented:
Also, I can connect to https://remote.company.com which will direct me to https://remote.company.com/remote internally.  I know it is internally because the SSL ports are blocked by the firewall from outside.
0
 
brotaCommented:
I would check and make sure EWS and OAB urls are set correctly
http://www.msexchange.org/articles_tutorials/exchange-server-2007/management-administration/configuring-exchange-server-2007-web-services-urls.html

Also if you are doing some sort of redirection in IIS with the /remote make sure it is not redirecting the autodiscover to /remote too
0
 
MegaNuk3Commented:
The error you are getting is probably due to your IIS SSL config.
Ensure 'clientcertificates' = ignore
0
 
MegaNuk3Commented:
Check for that on the properties of the web site and the autodiscover VIrtual directory
0
 
Wayne88Author Commented:
Thanks for your help Brota and MegaNuk3!

MegaNuk3, you solved it! Thanks again for your help!
0
 
Wayne88Author Commented:
I had the SSL set to IGNORE because during the rollout I didn't have SSL and thus the Outlook clients were prompted for logon each time it was started.

Once it's set back to ACCEPT as instructed and ran the Outlook test was successful.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 6
  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now