How do stop System Volume Information from growing

Running W2K3.  My System Volume Information folder continues to grow.  It's currently taking up 160+ GB of a 250 GB drive (Raid 5).  I've read in EE about possible causes and solutions.  None seem to apply to this situation.  The indexing service is using this directory.  Volume Shadow Copy is set to start manually, but does start at Windows startup.  I need to prevent this from growing any further.
Who is Participating?
GeorgeMartin601Connect With a Mentor Author Commented:
Just determined that my backup agent is starting/using VSS.  BIG SURPRISE TO ME!  By the way, I use and online, offsite, continuous backup solution.  thanks
According to the research, if we enable Volume Shadow Copy on the problematic disk and set no limit on the shadow copies, the System Volume Information folder will keep growing unexpectedly. If you want to remove the files inside the folder, if possible you can disable the Volume Shadow Copies on the problematic disk. If you want keep the VSS, you may set the limit the volume shadow copy in size.


My computer-> Go to disk properties -> Switch to Shadow Copies tab -> Select the disk which hold the big System volume information -> Click "Setting" -> Check the maximum size limit -> Specify the size

Do vssadmin /? to see the options. With this you can also
limit the size allocated for Shadow copies using
vssadmin resize shadowstorage

For example to limit the size to 7GB on the D: volume the command would be:
vssadmin resize shadowstorage /on=D: /for=D: /maxsize=7GB
The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

GeorgeMartin601Author Commented:
Shadow Copies is "disabled" in the disk properties.  However, it is set to no limit, but is disabled.

Just rebooted the server to test the manual start, it does indeed start.  Not sure what's starting it.  It has no dependencies and is dependent on only RPC.  
No problem.
GeorgeMartin601Author Commented:
I determined my backup agent was utilizing VSS and that setting the max size to 10% of the drive size was the fix, in lieu of keeping it at "no limit"
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.