• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3228
  • Last Modified:

EXCH 2010 Autodiscover keeps enabling (outlook Anywhere) Connect to MS Exchange using HTTP Proxies in Outlook

Our Exchange 2010 install seems to be totally healthy but Autodiscover keeps enabling Exchange Proxy in Outlook. I will reconfigure the account and after awhile I will see username/pass prompt as Outlook is attempting to use Outlook Anywhere functions! IM GOING MAD! Someone please help!
0
TheITGroup
Asked:
TheITGroup
1 Solution
 
ThorinOCommented:
Do you have an autodiscover A record internally that matches our Outlook Anywhere settings in Exchange?

This is happening with an internal only user right, not a laptop.
0
 
TheITGroupAuthor Commented:
yes - I have all of the necessary A records for autodiscover - It is automatically configuring Exchange proxies for all users - Even workstations within our AD perimeter at this facility. I wouldnt mind if the settings would stay after I uncheck the box to use outlook anywhere on local Outlook clients but exchange 2010 is persistently reconfiguring proxy settings.
0
 
Dan ArseneauCommented:
Get-ExchangeCertificate -server [CAS server] | ft Subject

The value after CN= is your common name.  ie.  mail.domain.com

Get-OutlookAnywhere | ft name, externalHostName

The ExternalHostName should be the common name on your certificate. ie. mail.domain.com

Get-OutlookAnywhere | Set-OutlookAnywhere -ExternalHostname mail.domain.com

Now in Outlook settings for OA, the proxy value should auto-populate with msstd:mail.domain.com
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Dan ArseneauCommented:
Another thing to note is that Outlook Providers override this setting so make sure they are NULL.

Get-OutlookProvider | ft Name, Server

You'll get 3 entries:  EXCH, EXPR, WEB.  These should return nothing for Server

If they don't,

Get-OutlookProvider | Set-OutlookProvider -Server $null
0
 
TheITGroupAuthor Commented:
yes i realize the certificate configuration and everything would be totally perfect if I was *wanting* to use outlook anywhere on these workstations but they are currently residing in the domain level environment and the same physical LAN as the exchange server and I need them to use normal RPC functions but Autodiscover keeps overriding the manual settings I specify on OUTLOOK clients. - Although, I had manually set all three outlookproviders - maybe this is overriding my manual settings on the client side. I will set definitions for all outlookproviders to null and test in the morning.
0
 
tamaneriCommented:
Hopefully you find a resolution for this and can pass it along :) i'm stuck.
0
 
TheITGroupAuthor Commented:
Well guys I found what the issue is:

Someone installed a switch at the exchange servers IP and there was an IP conflict. It was a misleading issue because the outlook clients would periodically lose connection to exchange, during traffic collisions, and the clients were freaking out and attempting to reconfigure themselves using autodiscover as a last-ditch effort.
0
 
TheITGroupAuthor Commented:
I fixed the issue
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now