Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

The action cannot be completed. The Connection to Microsoft Exchange is unavailable. outlook must be online or connected to complete this action

Posted on 2011-02-17
10
Medium Priority
?
3,745 Views
Last Modified: 2012-05-11
I've been struggling with this for days. I have Exchange 2010 SP1 with roll up 2 on a server 2008 R2. The server is in a data center and I cannot get Outlook Anywhere to work with Outlook 2010. I am putting mail.mydomain.com, select connect using http on fast and slow networks, and basic authentication. I have entered the registry key to disable IPv6 and removed the thing from the hosts file. This is driving me absolutely insane but I can't tell my boss that he can't use Outlook from his house...

Everything passes on testexchangeconnectivity except 1 warning:

ExRCA can only validate the certificate chain using the Root Certificate Update functionality from Windows Update. Your certificate may not be trusted on Windows if the "Update Root Certificates" feature isn't enabled

This is a new server. The OS is Windows Server 2008 R2. The server is the domain controller and is the only server in the domain. It has Exchange 2010 SP1. All updates have been installed including update roll up 2. My certificate is from godaddy and is the one that allows 5 domain names. I have read through every article I can find and there is no answer to my problem. Do I need to call MS support?

0
Comment
Question by:jakubus
  • 6
  • 2
  • 2
10 Comments
 
LVL 6

Expert Comment

by:craig_j_Lawrence
ID: 34922103
From the workstation you are having issues with, connect to the OA URL with a web browser. do you get a certificate error?
usually, if everything else is configured correctly, it comes down to the certificate not being trusted. Make sure that you have downloaded the latest root certificate update on every machine.
0
 

Author Comment

by:jakubus
ID: 34922129
I can connect to OWA just fine with no certificate errors. Also, my phone connected just fine with autodiscover and the autodiscover website is fine, no certificate errors there either.
0
 
LVL 9

Expert Comment

by:Dan Arseneau
ID: 34922586
In Outlook settings for Autodiscover, do you have the "Only connect to proxy servers that have this principal name in their certificate" selected?  If you remove the checkbox, can you connect?
0
NEW Veeam Backup for Microsoft Office 365 1.5

With Office 365, it’s your data and your responsibility to protect it. NEW Veeam Backup for Microsoft Office 365 eliminates the risk of losing access to your Office 365 data.

 

Author Comment

by:jakubus
ID: 34922667
I have tried with and without the "Only connect to proxy servers that have this principal name in their certificate". It won't connect either way.
0
 
LVL 9

Accepted Solution

by:
Dan Arseneau earned 750 total points
ID: 34922713
The Common Name of the certificate should match the msstd:mail.domain.com setting in Outlook. Does the GoDaddy cert have the common name set to what the ExternalURL of the CAS server is?

Get-ExchangeCertificate -Server aprdcasvm001 | ft Subject

The URL after CN= is your Common Name.

EMC - Microsoft Exchange On-Premises - Server Configuration - CAS SERVER properties - Outlook Anywhere tab - External host name.
0
 

Author Comment

by:jakubus
ID: 34923592
You were correct that the External host name was not the same as the Common Name. I fixed that and restarted the server. The CN and External host are now the same. However, the problem is still the same.
0
 

Author Comment

by:jakubus
ID: 34934886
Can anyone else help? I'm really close to just calling MLS support. I don't know what else to do. Thanks!
0
 

Author Comment

by:jakubus
ID: 34962133
Anyone? Help?
0
 
LVL 6

Assisted Solution

by:craig_j_Lawrence
craig_j_Lawrence earned 750 total points
ID: 34975462
hi jakubus

are you trying to use OA internally or externally? have you configured  / published the /rpc directory to the internet?

please review the following article. It provides a video walkthrough of the process to configure OA on Exchange 2010
http://www.netometer.com/video/tutorials/how-to-configure-outlook-anywhere-in-exchange-server-2010/

Thanks
Craig
0
 

Author Closing Comment

by:jakubus
ID: 34983902
Turns out that outlook autodiscover works but not manually. Thank you!
0

Featured Post

Restore individual SQL databases with ease

Veeam Explorer for Microsoft SQL Server delivers an easy-to-use, wizard-driven interface for restoring your databases from a backup. No expert SQL background required. Web interface provides a complete view of all available SQL databases to simplify the recovery of lost database

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

You finally migrated Public Folders to Office 365, decommissioned the Public Folder mailbox database and since then, when you send an email from on-premise to mail-enabled Public Folders, you get the following error: "Misconfigured public folder mai…
Upgrading from older Exchange server to the latest Exchange server can be tiresome, error-prone and risky, without being a seasoned exchange server administrators. It can become even problematic if you're an organization that runs on tight timeline…
This Experts Exchange video Micro Tutorial shows how to tell Microsoft Office that a word is NOT spelled correctly. Microsoft Office has a built-in, main dictionary that is shared by Office apps, including Excel, Outlook, PowerPoint, and Word. When …
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Suggested Courses
Course of the Month15 days, 19 hours left to enroll

580 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question