• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 579
  • Last Modified:

userinit.exe, explorer.exe failed

I have an XP computer that after I logon I get "userinit.exe failed to load"  I get the same thing if I try the task manager tskmgr.exe failed to load.  I tried reinstalling Window over it's self but I get the same error.  I also corrected the userinit error and then got an explorer.exe error.  Does anyone have any suggestions?  

PS:  Reloading is not an option


-Thanks
0
DCS12
Asked:
DCS12
  • 3
  • 2
2 Solutions
 
Bozos22Commented:
Try to boot into safe mode and see if you get the same error message.
If so, you may be infected with a virus or some adware.

Download Combofix which is a freeware utility to remove adware and run it...
http://download.bleepingcomputer.com/sUBs/ComboFix.exe
During the scan process, if you receive a message mentioning root kit activity, you may need to overwrite the Master Boot Record which may be infected.

Try Combofix first to see if it fixes you problem.
0
 
DCS12Author Commented:
Forgot to say that Safemode works fine.  I will try combofix.  
0
 
DCS12Author Commented:
Okay I ran ComboFix and I was able to log on and see the desktop, but most of the icons were white.  When I tried to open or run anything I got "Not enough quota is available to process this command."  The ComboFix log looked like everything was okay and no files were quarantined.  I attached the log maybe you can see something I'm not.

So I ran a memory test with a [Admin Edit] and it checked out okay.  Then I realized this computer only had 256MB of ram, so I replaced it with 2 x 512MB and now the computer seems fine.

This is computer works as a fax/email server (outbound only) and other than that nobody uses it as a workstation.  So could a virus or malware just jump onto the computer without someone installing it?

Thanks for your options.
ComboFix.txt
0
 
Bozos22Commented:
I looked at the ComboFix.txt file and it appears fine.
If your getting the "Not enough quota is available to process this command", its usually a virtual memory issue.  Now that you have added memory, you can allow the Operating System to manage the page file.

Go to the Start Menu, Control Panel, and select System.
Next click on the Advanced Tab and under the Performance section, press the Settings button.
Next click on the Advanced Tab for the box that just popped up and at the bottom in the Virtual Memory area, press the Change button.
Select System Managed Size and press the Set button.
Once you do that, press the Ok buttons until you exit the System Properties Dialog box.
After the change, you may need to reboot.  See if that helps.
0
 
DCS12Author Commented:
Thanks for looking at the log.  The system was already managing the page file.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Network Scalability - Handle Complex Environments

Monitor your entire network from a single platform. Free 30 Day Trial Now!

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now