Solved

Unable to access Internet

Posted on 2011-02-17
4
457 Views
Last Modified: 2012-05-11
Hello all,
I am new to the whole ASA thing, so sorry for the newbe questions.
We have a remote site that is connected via VPN tunnel. The site have an IP change and I have to change the ASA.
I was able to reconnect the sites and seems to be working well. However no one at the remote site can access the internet.
I am useing ASDM to manage the ASA. here is a copy of my running config.
Thank you for any help.

ASA Version 8.2(2)
!
hostname HQ-xxxxx
enable password is --- encrypted
passwd --- encrypted
names
!
interface Vlan1
 description Outside
 nameif outside
 security-level 0
 ip address 38.98.68.162 255.255.255.252
!
interface Vlan2
 nameif inside
 security-level 100
 ip address 172.50.1.1 255.255.255.0
!
interface Ethernet0/0
!
interface Ethernet0/1
 switchport access vlan 2
!
interface Ethernet0/2
 switchport access vlan 2
!
interface Ethernet0/3
 switchport access vlan 2
!
interface Ethernet0/4
 switchport access vlan 2
!
interface Ethernet0/5
 switchport access vlan 2
!
interface Ethernet0/6
 switchport access vlan 2
!
interface Ethernet0/7
 switchport access vlan 2
!
boot system disk0:/asa822-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
same-security-traffic permit intra-interface
object-group network DM_INLINE_NETWORK_1
 network-object 172.20.0.0 255.255.240.0
 network-object 172.21.0.0 255.255.240.0
object-group network DM_INLINE_NETWORK_2
 network-object 172.20.0.0 255.255.240.0
 network-object 172.21.0.0 255.255.240.0
object-group network DM_INLINE_NETWORK_7
 network-object 172.20.0.0 255.255.240.0
 network-object 172.21.0.0 255.255.240.0
object-group network DM_INLINE_NETWORK_3
 network-object 172.20.0.0 255.255.240.0
 network-object 172.21.0.0 255.255.240.0
access-list no-nat-acl extended permit ip 172.20.0.0 255.255.240.0 172.50.1.0 255.255.255.0
access-list no-nat-acl extended permit ip 172.28.1.0 255.255.255.248 172.50.1.0 255.255.255.0
access-list no-nat-acl extended permit ip 172.50.1.0 255.255.255.0 172.28.1.0 255.255.255.248
access-list no-nat-acl extended permit ip 172.50.1.0 255.255.255.0 172.20.0.0 255.255.240.0
access-list no-nat-acl extended permit ip 172.50.1.0 255.255.255.0 172.21.0.0 255.255.240.0
access-list no-nat-acl extended permit ip 172.50.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_1
access-list no-nat-acl extended permit ip 172.50.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_2
access-list no-nat-acl extended permit ip 172.21.0.0 255.255.240.0 172.50.1.0 255.255.255.0
access-list no-nat-acl extended permit ip 172.50.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_3
access-list outside_1_cryptomap extended permit ip 172.50.1.0 255.255.255.0 object-group DM_INLINE_NETWORK_3
access-list outside_access_in extended permit ip object-group DM_INLINE_NETWORK_7 any
access-list inside_access_in extended permit ip any any
pager lines 24
logging enable
logging list test level debugging
mtu outside 1500
mtu inside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-631.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (outside) 1 0.0.0.0 0.0.0.0
nat (inside) 0 access-list no-nat-acl
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 38.98.68.161 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
aaa authentication telnet console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 172.20.0.0 255.255.248.0 inside
http 172.50.1.0 255.255.255.0 inside
http 69.178.155.226 255.255.255.255 outside
http 65.46.16.234 255.255.255.255 outside
http 66.104.77.0 255.255.255.0 outside
snmp-server
snmp-server
snmp-server
snmp-server
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer 65.46.16.234
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 5
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp policy 10
 authentication pre-share
 encryption des
 hash sha
 group 2
 lifetime 86400
telnet timeout 60

ssh timeout 60
console timeout 0
management-access inside
dhcpd address 172.50.1.25-172.50.1.40 inside
dhcpd dns 172.20.5.99 172.20.5.100 interface inside
dhcpd wins 172.20.5.99 172.20.5.100 interface inside
dhcpd lease 28800 interface inside
dhcpd domain ----- interface inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn

tunnel-group 65.46.16.234 type ipsec-l2l
tunnel-group 65.46.16.234 ipsec-attributes
 pre-shared-key *****
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect netbios
  inspect rsh
  inspect rtsp
  inspect skinny  
  inspect esmtp
  inspect sqlnet
  inspect sunrpc
  inspect tftp
  inspect sip  
  inspect xdmcp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
call-home
 profile CiscoTAC-1
  no active
  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService
  destination address email callhome@cisco.com
  destination transport-method http
  subscribe-to-alert-group diagnostic
  subscribe-to-alert-group environment
  subscribe-to-alert-group inventory periodic monthly
  subscribe-to-alert-group configuration periodic monthly
  subscribe-to-alert-group telemetry periodic daily
Cryptochecksum:645751b826d2a773baf07c980b8e6b9f
: end
asdm image disk0:/asdm-631.bin
no asdm history enable
0
Comment
Question by:KingCasull
4 Comments
 
LVL 33

Expert Comment

by:MikeKane
Comment Utility
What IP change did the original site have done?   Was it the public IP or the internal subnet?  

If the tunnel builds, but there's no traffic, that kind of tells me there is probably an issue with the Nonat or crypto access lists....    
0
 
LVL 45

Expert Comment

by:Craig Beck
Comment Utility
You need to create a NAT and Security policy for access to the internet from hosts on in inside interface.

http://www.cisco.com/en/US/docs/security/asa/asa80/configuration/guide/cfgnat.html
0
 
LVL 3

Accepted Solution

by:
Rick_at_ptscinti earned 500 total points
Comment Utility
This line is wrong:
nat (outside) 1 0.0.0.0 0.0.0.0

Should be:
nat (inside) 1 0.0.0.0 0.0.0.0

to change it from the command line:

conf t
no nat (outside) 1 0.0.0.0 0.0.0.0
nat (inside) 1 0.0.0.0 0.0.0.0
wr
exit



0
 

Author Closing Comment

by:KingCasull
Comment Utility
All, thank you very much for the help.
This issue was that i did not have the NAT (inside) set. Once I put that in, all came up just fine.
Again thank you. The help provided through this site was greate
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Suggested Solutions

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now