Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Can't see my external USB harddrive

Posted on 2011-02-18
10
1,363 Views
Last Modified: 2016-06-26
I use several external USB harddrivs to backup my data. By copying my data to E:  (drive letter for external USB harddrive) every Friday. The computer is running Windows 7 professional.

But I recently bought a new external USB hardrive (same brand, size, western digital elements portable 500GB USB 2.0 ) and this new drive doesn't appear in the windows explorer window as the other disks do. I can see the disk in Disk Management and it hasn't got a driver letter assigned to it self.

I don't want to assign a driver letter to the disk. I want Windows to do this for me. As it does for
my other disks.

Thanks.
0
Comment
Question by:JasonMewes
10 Comments
 
LVL 4

Expert Comment

by:andreizz
ID: 34924003
In Disk Management right click the external drive, and make a partition/assign it a letter/format it as these are the propable causes.
0
 
LVL 5

Expert Comment

by:jarrod_williams
ID: 34924041
how long is the cable?  try a shorter USB 2.0 cable. It has to do with voltage drop recived to and from the port.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34924049
If windows doesn't do it, you have to do it yourself as andreizz said. You only have to do that once. After that windows will remember the drive assignement.
0
 
LVL 1

Expert Comment

by:sisesise
ID: 34924357
Yes, you need to do this yourself, I don't exactly know why, but for some devices windows will not asign automaticly a drive letter (and I don't think that the length of the cable has anything to do with it) . As Wizard said, you only need to do it once, after that, the drive letter will be assigned automaticly every time (or until you will reinstal the operating system).
0
 
LVL 30

Expert Comment

by:ded9
ID: 34924449
Right click on command prompt- select run as administrator-In command prompt type  diskpart and hit enter.

Then type the command -> automount enable       --and then hit enter.


Ref:-
http://technet.microsoft.com/en-us/library/cc753703%28WS.10%29.aspx


Ded9
0
 
LVL 2

Expert Comment

by:krylosz
ID: 34924654
Windows XP sometimes has problems assigning drive letters to USB disks. You could and should try this tool, it should fix your problems.

http://www.uwe-sieber.de/usbdlm_e.html

0
 
LVL 6

Expert Comment

by:RootsMan
ID: 34933232
In Disk Management what is the partition type that's listed for that drive?
If the drive isn't partitioned or formatted Windows won't give it a drive letter.
Since it is a new drive, I suggest you format and partition the drive.
0
 

Author Comment

by:JasonMewes
ID: 34941763
ok, I have tried this
1. assign the disk a letter
2. formate it
3. i can see and access the disk
4. unpluged the disk
5. pluged in one of my old disks (that used to work fine)
6. can't see the old disk now
7. unpluged the old disk
8. pluged in one of my other old disks (that used to work fine)
9. can't see the old disk now
10. assigned the old disk a driver letter
11. i can see and access the old disk
12. unpluged the old disk
13. pluged in one of my new disk
14. can't see the new disk now


the usb cable is about 10 inch and is connected direktly to the computer (no usb hub)
0
 
LVL 4

Expert Comment

by:andreizz
ID: 34941890
Try to reinstall your chipset/motherboad latest drivers, maybe the usb drivers are a bit "dumb" and don't know how to controll you usb devices properly..

Also if you can try and use another rack with your hdd's.
0
 
LVL 2

Accepted Solution

by:
krylosz earned 500 total points
ID: 34942022
Well Windows does is pretty stupid when it comes to handling USB drive letters. If you have one USB disk set as E:, unplug it, put in another USB device, assign it to E: and plug in the other disk, it will not assign it a new drive letter. That's what the tool I posted above does. Try it.
0
Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

A quick guide on how to use Group Policy to create a custom power plan and set it active on Windows 7.
On some Windows 7 (SP1) computers, Windows Update becomes super slow even the computer is reasonably fast.  There's one solution that seemed to have worked well for me (after trying a few other suggested solutions).
This tutorial will walk an individual through the steps necessary to install and configure the Windows Server Backup Utility. Directly connect an external storage device such as a USB drive, or CD\DVD burner: If the device is a USB drive, ensure i…
This Micro Tutorial will give you basic overview of the control panel section on Windows 7. It will depth in Network and Internet, Hardware and Sound, etc. This will be demonstrated using Windows 7 operating system.

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question