Solved

loop problem at serial interfaces of cisco 2610 & 2620 routers

Posted on 2011-02-18
42
703 Views
Last Modified: 2012-05-11
I am getting loop problem at serial interfaces of 2 routers in my home lab (for preparation of CCNA & CCNP). I have connected 3 routers in a multi drop network. Router A is 2620 with a 2T module while routers B & C are 2610 with 1t module each. See diagram for details. The problem I am getting is that when I configure clock rate at the DCE ends of routers the serial interfaces of router A & B show the following state

Serial 0 is up line protocol is up (looped)

The encapsulation at both ends is default HDLC & keep alive are 10 sec. I have also ensured that loop back is not set at any router but still I am unable to resolve this problem. The only possible solution I have got is to erase the NVRAM of all routers & then I have to re configure the routers again but when I switch off the routers & boot up next time the same loop problem comes up.
Can anyone help me to troubleshoot this problem that whether this is a software issue or some kind of hardware problem in terms of cables or router itself??

link lights are showing normal up state & the other links i.e int serial 0/1 of Router A & int serial 0 of router C are normal & never shows loop. Below are the outputs of Show interface commands at serial 0 interfaces of router A & B also running config of both routers is given below
Router B
BB#sh int s0/0
Serial0/0 is up, line protocol is up (looped)
  Hardware is PowerQUICC Serial
  Description: connected to AA 1.1.1.1 via S0
  Internet address is 1.1.1.2/8
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 01:22:10
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     576 packets input, 35304 bytes, 0 no buffer
     Received 572 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     580 packets output, 35918 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions




Router A
Serial0/0 is up, line protocol is up (looped)
  Hardware is PowerQUICC Serial
  Description: connected to BB 1.1.1.2 via S0
  Internet address is 1.1.1.1/8
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 01:26:42
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     611 packets input, 38429 bytes, 0 no buffer
     Received 611 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     611 packets output, 38429 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     24 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Current configuration : 838 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

!
hostname AA
!
logging rate-limit console 10 except errors
enable password 123
!
ip subnet-zero
!
!
no ip finger
!
no ip dhcp-client network-discovery
call rsvp-sync
!
!
interface FastEthernet0/0
 ip address 200.100.50.100 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 description connected to BB 1.1.1.2 via S0
 ip address 1.1.1.1 255.0.0.0
 fair-queue
 clockrate 64000
!
interface Serial0/1
 description connected to CC 2.1.1.2 via serial 1
 ip address 2.1.1.1 255.0.0.0
!
ip classless
ip http server
!
!
dial-peer cor custom
!
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password 123
 login
line vty 5 15
 login
!
no scheduler allocate
end


Current configuration : 482 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BB
!
enable password 123
!
!
!
ip subnet-zero
!
!
interface Ethernet0/0
 ip address 200.100.50.150 255.255.255.0
!
interface Serial0/0
 description connected to AA 1.1.1.1 via S0
 ip address 1.1.1.2 255.0.0.0
 fair-queue
!
ip classless
ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password 123
 login
!
end


Image-for-query-at-experts-excha.bmp
0
Comment
Question by:ilusionns
  • 21
  • 19
  • 2
42 Comments
 
LVL 7

Expert Comment

by:kemi67
ID: 34925645
I notice that Router A and B have Fast internet interface in the same subnet
ip address 200.100.50.100 255.255.255.0
ip address 200.100.50.150 255.255.255.0
Is this OK?
Are these Fast Ethernet connected to the same switch?
 If yes, could be that a loop is autodetect
Try this suggestions from CISCO
http://www.cisco.com/en/US/docs/internetworking/troubleshooting/guide/tr1915.html

 
1.	 Use the show running-config privileged exec command to look for any loopback interface configuration command entries.

2.	If you find a loopback interface configuration command entry, use the no loopback interface configuration command to remove the loop.

3.	If you do not find the loopback interface configuration command, examine the CSU/DSU to determine whether they are configured in manual loopback mode. If they are, disable manual loopback.

4.	Reset the CSU or DSU, and inspect the line status. If the line protocol comes up, no other action is needed.

5.	If the CSU or DSU is not configured in manual loopback mode, contact the leased-line or other carrier service for line troubleshooting assistance.

Open in new window

0
 

Author Comment

by:ilusionns
ID: 34925778
doesn't matter if fast ethernet are in same subnets. i get the same problem even when ip addresses are not configured on ethernet interfaces as I am getting problem at serial interfaces only.I have checked cisco's website regarding this problem but wasn't able to solve this problem.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 34925954
Are these actual routers or a Packet Tracer setup?

Things that would cause the interface to be looped is:

A) The loopback command applied to the interface
B) The CSU/DSU in Loopback mode
C) A incorrectly pinned cable.
0
 

Author Comment

by:ilusionns
ID: 34926476
I am working on actual routers as I mentioned that I have created my lab for preparation of CCNA. I have attached screen shot on packet tracer so that people can get idea about the topology. the possible reasons that u have mentioned for a loop are correct but in my case you can see that loop back command is not applied to any interface ( see output of show interface command) also I am not connected to any ISP or such thing so CSU/DSU loopback is also not an issue. The last reason that a incorrectly pinned cable may be a issue but I want to confirm that what is meant by incorrectly pinned cable? you mean that cable is not properly plugged in or loose or something else?
0
 
LVL 7

Expert Comment

by:kemi67
ID: 34926548
I think he refers to a cable whose wires are not connected correclty. This happens if you use a cable they you made by yourself using an apposite wrench, not with a bought cable
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 34926662
Kemi67 is correct. If the cable has the signal terminated on the wrong pins, it can result in an interface being looped.
0
 

Author Comment

by:ilusionns
ID: 34926702
I have not prepared the cables myself in fact I have purchased from a shop, secondly if this is a wrong cable issue then why sometimes the link does not show loop & works fine??
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 34926792
>why sometimes the link does not show loop & works fine??

It could be an intermittent connection.

Do you have the same problem with the link between Router A and Router C? Have to swapped the cables?
0
 

Author Comment

by:ilusionns
ID: 34927681
I have swapped the cables & this time the loop is present at the other interface of Router A.it means that cable is faulty.
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 500 total points
ID: 34927721
Yep.
0
 

Author Comment

by:ilusionns
ID: 35068630
I have changed the DTE cable ( with a brand new V.35 Serial DTE). it worked fine up till 1 week and now I am getting another strange problem.
Now I am getting loop at serial interface of router B and at the same time serial 0/0 of Router A is showing serial 0/0 is down line protocol is down.the completer error is as below:

Router B
BB#sh int s0/0
Serial0/0 is up, line protocol is up (looped)
  Hardware is PowerQUICC Serial
  Description: connected to AA 1.1.1.1 via S0
  Internet address is 1.1.1.2/8
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 01:22:10
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/2/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     576 packets input, 35304 bytes, 0 no buffer
     Received 572 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     580 packets output, 35918 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
Router A
Serial0/0 is down, line protocol is down
  Hardware is PowerQUICC Serial
  Description: connected to BB 1.1.1.2 via S0
  Internet address is 1.1.1.1/8
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters 01:26:42
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 1158 kilobits/sec
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     611 packets input, 38429 bytes, 0 no buffer
     Received 611 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     611 packets output, 38429 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
     24 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

How is it possible that serial 0/0 of router A is showing completely down and at the same time the connected interface of Router B with serial 0/0 of router A is showing up & up but looped??
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35068802
It's possible that a short between certain pins could cause that symptom. I'd start with a cable problem... again. :-(
0
 

Author Comment

by:ilusionns
ID: 35081755
I have noticed that two of the routers are giving short( voltage shock) when i touch them & at the same time they give voltage shock when I touch serial cables joint.is that could be a problem??
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35082178
uhhh, YES!

Sounds like a ground loop.
0
 

Author Comment

by:ilusionns
ID: 35093309
The thing is how to get rid of this problem as this time when I swapped the cables the loop does not shift to the other interface means cables are ok. Now what to do with routers?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35093932
Try a different cable.
0
 

Author Comment

by:ilusionns
ID: 35093978
Actually this cable is a brand new one so I don't think that it would do any good.what do you think?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35093997
If the routers aren't plugged into the same outlet/power strip, try that. If you still get a shock, then I would suspect there's something wrong with one of the power supplies.
0
 

Author Comment

by:ilusionns
ID: 35094014
Routers are plugged in a single extension board.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35094084
If you disconnect the serial cable, do you still get a shock? If you do, then it's probably a power supply problem. If you don't, then it's the serial cable.
0
 

Author Comment

by:ilusionns
ID: 35127120
 I have checked that all three routers are giving shock at the area marked in the attached picture even if I disconnect the serial cables.Now question arises is how is it possible that all the powers supplies are giving problem as only the area marked with red eclippse is giving shock the upper & lower body of router is not giving shock.I also want to confirm that does a normal router gives shock in this particular area??
Router-2.JPG
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 50

Expert Comment

by:Don Johnston
ID: 35127258
Disconnect everything except the power cable.

Power off everything.

Do you still get a shock?
0
 

Author Comment

by:ilusionns
ID: 35127359
you mean that only power cable needs to be plugged in to router but  power source/extension board should be power off?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35127594
No. Unplug every cable except the power cable.

Turn off the routers.

Do you still get a shock?
0
 

Author Comment

by:ilusionns
ID: 35129999
yes all 3 routers are giving shock even when every cable is disconnected & routers are turned off.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35130241
How many routers are we dealing with here?

One of these probably has a short in the power supply.

Check for voltage between each router and a common ground.
0
 

Author Comment

by:ilusionns
ID: 35130492
there are 3 routers in the topology.I will check for voltage between routers.
0
 

Author Comment

by:ilusionns
ID: 35130592
can you explain how I have to check for voltage between each router and a common ground??
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35133096
I volt meter would be the best way. Negative lead on the common ground and the positive lead on the chassis of the router.

Absent that, one finger on ground and the other on the chassis of the router.

Having said that, electricity is dangerous. You should contact somebody with the proper training.
 
0
 

Author Comment

by:ilusionns
ID: 35135500
are you sure that it is the power supply of one of the routers that is causing problem as I have erased the NVRAM of the router that is causing problem bcoz it was showing its serial interface up & up but looped even when serial cable was unplugged also when I removed this router from toplogy the other 2 routers are working fine. After erasing NVRAM when I apply the no shut command at serial 0 interface it is showing int serial 0 is up line protocol is down. So is there a possibility that serial card may be faulty?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35136978
I'm not even thinking about serial interface. If you get a shock when you touch a router, that's a serious problem.
0
 

Author Comment

by:ilusionns
ID: 35137070
okay, but the chassis(only area where we plug serial cables etc & upper & lower portion of routers are not giving shock ) of other 2 routers are also giving shocks so it means their power supplies are also not working normally?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35137144
They shock you when there are no cables connected and the power is turned off?
0
 

Author Comment

by:ilusionns
ID: 35138144
no
0
 

Author Comment

by:ilusionns
ID: 35138180
sorry pardon me, actually in start it does not give shock but after sometime it starts giving shock.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35138532
Until the shock hazard is resolved, there is no way to proceed.
0
 

Author Comment

by:ilusionns
ID: 35144916
I have got rid of the shock, it was only on 1 router. Now my problem is that even when there is no serial cable is connected the serial interface of that particular router shows serial 0 as up.how is it possible that without serial cable being plugged in the interface is showing up?
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35146474
Bad interface.
0
 

Author Comment

by:ilusionns
ID: 35146573
didn't get your point, can u explain in detail the problem & remedy.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35146645
If the interface is showing up even though there's nothing connected to it, then it's a bad port.  Replace the interface.
0
 

Author Comment

by:ilusionns
ID: 35150242
when i some times boot the router it gives the message shown in attached pic.can you suspect what is this problem?just to tell you that when I re boot the router it becomes normal
Router-problem-rommon.JPG
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 35152543
No idea.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now