Server browses network slowly

Hello,
I have a Windows 2003 Server containing AD and DNS. It is the only computer on my network that browses the network slowly. If I click on Network Neighborhood it might take up to 2 minutes for it to display other computers. It has a DNS entry. The NIC is 1GB and is on a good switch. Does this sound like a DNS issue? What should I look at to figure out why it browses the network slowly. This slowness causes problems when I want to copy files from it to another machine.

Thanks,
John
LVL 1
jhiebAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
Darius GhassemConnect With a Mentor Commented:
Post ipconfig /all

Make sure Computer Browser service is enabled and you have NetBios over TCP\IP enabled as well
0
 
jhiebAuthor Commented:
I looked at my IP settings and there are three choices for Netbios over TCP IP. I am using the first choices, which is the default. Do you want me to specifically enable the radio button for NetBios over TCP/IP or is the default the same since it has a static IP. Secondly, if I make a change to this setting will it affect anything else on this server?

Here are my IP settings

Windows IP Configuration

Host Name . . . . . . . . . . . . : SERVER01
Primary Dns Suffix  . . . . . . . : myco.local
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : myco.local

Ethernet adapter Local Area Connection 2:

Connection-specific DNS Suffix  . :
Description . . . . . . . . . . . : D-Link DGE-530T Gigabit Ethernet Adapter (rev.B)
Physical Address. . . . . . . . . : 00-26-5A-05-B5-0C
DHCP Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.5
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 192.168.1.5
                                              192.168.1.10

0
 
Darius GhassemCommented:
Yes select enable. No this will not affect anything else on server.

Go to Network Connections click Advance Menu then Advance Settings make sure your primary NIC is listed first that is being used currently.
0
Worried about phishing attacks?

90% of attacks start with a phish. It’s critical that IT admins and MSSPs have the right security in place to protect their end users from these phishing attacks. Check out our latest feature brief for tips and tricks to keep your employees off a hackers line!

 
jhiebAuthor Commented:
OK, I have done both of these. I selected the radio button for Netbios over tcp/ip and my advanced settings show that my Local Area Connectin 2 (the NIC) is the default. Should I reset a service to make these changes effective? I just tried to browse a computer on the network using windows explorer and explorer is still taking awhile on some machines but not others.
0
 
Darius GhassemCommented:
Check those machines settings.
0
 
jhiebAuthor Commented:
I have checked the two machine settings you told me about, and they are where you wanted them to be.
0
 
Darius GhassemConnect With a Mentor Commented:
When  you go to Run then \\server\share. Is this fast?

Do you have AV installed? Maybe disable to test to see if this is scanning network traffic
0
 
jhiebAuthor Commented:
I will have to look at this again later, so I will close this and give you the points for helping me along. For some reason, I am suspecting the NIC as the problem. Everythign else looks good and that is the only thing I haven't done is to swap out the NIC with a new one. I just don't want to hassle with it. Thanks for your help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.