?
Solved

smtp responses slow when sending emails using smtp engine and proprietary program

Posted on 2011-02-18
6
Medium Priority
?
902 Views
Last Modified: 2012-05-11
our development team has put together a program that sends out email directly from a GUI once they put an email address in. it actually sends out 2 emails which are confirmations,one goes to the BUYER and one to the SELLER. the program apparently uses the default MAPI profile of the person that is logged into the PC to send email
we updated our exchange environment and we have a 2003 environment, as well as a 2007 environment.
when relaying email off of the 2003 environment, it works flawlessly
when relaying email off of the 2007 environment, there are some delays when sending email, and it looks to be as if it gets delayed 5 seconds, and sometimes 10 seconds if there is a lot of email traffic at once. i read up a little on tarpitting, could this be the cause of the delayed emails? anyone have any other ideas? how can i turn tarpitting off?
0
Comment
Question by:jsctechy
  • 2
  • 2
5 Comments
 
LVL 45

Accepted Solution

by:
Amit earned 2000 total points
ID: 34927922
To disable the tarpit behavior, set the value to 00:00:00

To check the SMTP tarpit interval on your ReceiveConnectors, use the following shell command:
get-ReceiveConnector | select name,tarpitinterval

You can set it to a higher value - I have mine set to 10 seconds - using set-ReceiveConnector:
set-ReceiveConnector "Receive Connector Name" -tarpitinterval 00:00:10

The value is in hours:minutes:seconds.

Hope this helps
0
 
LVL 1

Author Comment

by:jsctechy
ID: 34929228
do you think this tarpit interval could be the caus of this? do you think it could be something else?
0
 
LVL 1

Author Comment

by:jsctechy
ID: 34929232
also- do you think i can do this during business hours without disrupting email flow?
0
 
LVL 45

Expert Comment

by:Amit
ID: 34929297
As per your query you need to disable it so i give that answer.

As far as, whether this could be the reason. I assume not, you check the tracking logs of exchange server or right click on message and check the header information. Check where it is stucking....do you have any 3rd party spam server.

And if you really want to change it. Do it after business hours always. Any change related to Exchange must be done after business hours.
0
 
LVL 74

Expert Comment

by:Glen Knight
ID: 35170819
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I came across an unsolved Outlook issue and here is my solution.
There are literally thousands of Exchange recovery applications out there. So how do you end up picking one that’s ideal for your business & purpose? By carefully scouting the product’s features, the benefits it offers you, & reading ample reviews f…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Nobody understands Phishing better than an anti-spam company. That’s why we are providing Phishing Awareness Training to our customers. According to a report by Verizon, only 3% of targeted users report malicious emails to management. With compan…
Suggested Courses
Course of the Month9 days, 9 hours left to enroll

612 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question