• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 847
  • Last Modified:

Windows 7 "Documents" & "My Documents" folders identical

In migrating from my old XP PC I copied the old PC's "My Documents" folder to the new (64-bit Windows 7) PC's "Documents" folder.

Now I have a "My Documents" folder located under the Windows 7 "Documents" folder and both folders have the same 1200 files in them.

Not knowing how that happened I then tried to move the files in  "My Documents" up 1 level to "Documents" but recv'd an error that they are in fact the same folder!

A bit of research shows  "Documents" is not really a folder but a library.

Needless to say, having 2 identical "folders" located one inside another is awkward and unwanted.

I'm sure there is more than 1 way to skin this cat... What I want is all those files from my old  "My Documents" folder in my new  Documents "folder".

Suggestions?
0
joerockhead
Asked:
joerockhead
  • 3
  • 2
  • 2
  • +1
1 Solution
 
andreizzCommented:
First of all make a backup copy somewhere else, then delete both folders/files and then copy the files from within the backup folder back to C:\Users\YOUR_USERNAME\Documents
0
 
Frosty555Commented:
Typically, if you copy the "My Documents" folder from your XP machine to the User profile folder, e.g. to C:\Users\myuseraccount (NOT into the documents folder), Windows 7 will automatically put the My Documents folder in the Documents library, the My Music folder in the Music library, and similarely for the My Videos, Favourites folders will go into the appropriate Windows 7 location.

I was pleasantly surprised when I realized that Windows 7 will do this automatically for you.

You may want to delete the files you've already copied and just do it again from scratch.
0
 
joerockheadAuthor Commented:
andreizz - That is exactly what I did, it didn't work as intended.

Frosty555 - Sounds good.  Where exactly in real life (if you know) does Windows 7 store the "My Documents" folder that shows up under user\documents in the libraries?
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

 
David Johnson, CD, MVPOwnerCommented:
it is stored in c:\users\username\documents  as the default
0
 
andreizzCommented:
c:\Users\andreiz\Documents\

this is the path, try and browse it from within cmd with dir and cd commands to confirm.


0
 
joerockheadAuthor Commented:
ve3ofa & andreizz - You are both correct as far as this:  "[...]\Documents" is the new correct path to what was called "My Documents".

However, what you are missing is if you connect to your old PC and copy the contents of the "My Documents" folder from the old PC to "[...]\Documents" on the new PC you will end up with a "My Documents" folder under  "[...]\Documents" and they are duplicates of each other.

Note that I copied THE CONTENTS of the "My Documents" folder, I did not drag the top-level "My Documents" folder over. I went inside "My Documents", selected all and copied those thousands of items over and yet Windows 7 behaved as described above.

I have not tried Frosty's suggestion yet.
0
 
andreizzCommented:
this is very strange.. i'm out of ideeas..

try the same with some sample files from somewhere else, not my documets[the old one]
0
 
David Johnson, CD, MVPOwnerCommented:
simply delete the desktop.ini in the documents folder and it will show as 'documents' vice 'my documents'
0
 
Frosty555Commented:
joerockhead - I agree that doesn't make sense. There is nothing special about the Windows 7 "documents" location. I know windows explorer shows the Documents/Music/Videos etc. as "Libraries", but in reality each of those "libraries" just show the contents of the various user folders:

C:\Users\[yourusername]\Documents
C:\Users\[yourusername]\Pictures
C:\Users\[yourusername]\Music
C:\Users\[yourusername]\Videos

The only catch is that in Windows 7 the C:\Users\[yourusername]\My Documents folder is a symbolic link to the C:\Users\[yourusername]\Documents folder. The symbolic link exists so that old programs that hard-coded the My Documents folder will not break in Windows 7. It should make no difference to you, though.

If you copy the *contents* of the My Documents (e.g. enter the my documents folder, select all, go edit->copy) and paste it into the Documents library (e.g. go to the Documents library, right click inside, and hit paste), it should just copy the files like normal.

If you copy the entire My Documetns folder in it's entirety (Go to C:\Documents And Settings\MyUserName, select the My Documents folder, go Edit->Copy), and then paste it into the Users folder in Windows 7 (go to C:\Users\MyUserName, and go to edit->paste), then it should put the My Documents files into the "Documents" folder, and then automatically move the My Music, My Videos, My Pictures subfolders into the "Music", "Videos" and "Pictures" libraries respectively.

There should be no situation that makes links or duplicates of the files like you described.... that's why I suggested that you delete it and try it again. See if you can reproduce the behavior.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now