Citrix Reciever Android

Citrix Xenapp 4.5
CAG 4.6.2

Iphone, Blackberry and Ipad work fine with the citrix reciever Android phones will not connect.

Citrix Reciever from Android Market
I enter in the server info the same as i have on the iphone and the other devices that work.
When i click on the connection i get an error

Invalid Server Certificate -
The server certificate is invalid.  Do you wish to accept this certificate adn connect to the server anyway?

Accept or Cancel

I click Accept

Citrix Access Gateway Error
Gateway authentication failed. Check your credentials, address, gateway settings and network connection.

I have been told the certificate is the issue however I have a vaild cert.  On the CAG log I dont see any thing when i try to connect with the Android devices... I see the connections from the Apple and blackberry ones... Any help would be great.
LVL 1
wolfbirdAsked:
Who is Participating?
 
wolfbirdConnect With a Mentor Author Commented:
The Cert chain was in the wrong order on the CAG.
0
 
residentsCommented:
Are you putting the internal domain in the domain field? Also, have you tried logging in with an administrator account to see if you get anything different?
0
 
wolfbirdAuthor Commented:
Yes i have tried with the domain in the field and with it out... I have tried test accounts, live accounts and admin accounts.  
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
wolfbirdAuthor Commented:
More info:
We are using an Addtrust cert adn it is listed on the Android devices.  I exported the cacerts.bks from a users phone and and see the Addtrust cert.
0
 
thatcomputergrrlCommented:
We have the same issue! We use entrust for our ssl cert. The problem for us is that entrust's root CA doesn't come pre-installed on the android and there currently is not a way to install it on the phone. Unlike the iPhone that does OS updates and allows you to email and install the CA to the device. The only way to get it to work w the android is to change your ssl cert to one that's preindtalled on your phone..like verisign.
0
 
wolfbirdAuthor Commented:
We are using an "addtrust" root ca it is listed on the cacert.bks on the android phones.
0
 
wolfbirdAuthor Commented:
Still no solution going to install new certs on CAG.
0
 
wolfbirdAuthor Commented:
Close
0
 
wolfbirdAuthor Commented:
The chain is in the wrong order on the CAG
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.