New Windows 7 Install Wireless Network has no internet access

Hey Experts!!

I just installed Windows 7 Ultimate on my PC and I'm connecting wirelessly.  The PC can see the network and connect, but I have no internet access.  The drivers are up to date and the card isn't having any issues.  

It is throwing a weird IP address: 169.xxx.xx.xx

All of the other PCs on the network do not have an issue.  

Please help!
LVL 30
LZ1Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Frank_AlphaserveitCommented:
if you are receiving a 169 address it sounds like you aren't actually connecting to the network.

Can you post an ipconfig /all?

Is your LAN port enabled?
LZ1Author Commented:
LAN port is disabled.  

ipconfig /all results attached as jpg.
ee.jpg
Frank_AlphaserveitCommented:
it looks like DHCP is either disabled or not working properly on your wireless device.  Do you know what the IP address of your wireless device is?  Is it a wireless router or access point?

If it's a router, what i would so is manually give yourself an IP address on the same subnet (eg. wireless device is 192.168.1.1, give yourself 192.168.1.10, 255.255.255.0 mask, 192.168.1.1 gateway)

once that is set you should be able to open a web browser and browse to that IP of the wireless device and double check settings, specifically DHCP.
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

LZ1Author Commented:
DHCP is enabled.  It's a 2wire AT&T device.  I have no problem connecting with any of my other devices.  I think there's a total of 5 devices right now.  

There wouldn't be something wrong with the settings inside of Windows 7?  I did try to give the troublesome PC a static IP and still nothing.  It sees the router and "connects" but doesn't give internet access.
Frank_AlphaserveitCommented:
interesting.  I've seen behavior similar to this before, and the "cause" turned out to be when the connection is initially spotted by Windows, and you get the prompt asking if it's "Public, Work or Home" and you select "Public" the internet is no longer reachable.  Do you remember if you did get that prompt and what you selected?

What i did in that case was delete the wireless connection and the wireless adapter from device manager, reinstall, and then selected "work" (or in your case, "home").
LZ1Author Commented:
It keeps showing up as an unidentified public network.  I never got those prompts.  

I did kill the device from within device manager.  How do I kill the wireless connections???
Frank_AlphaserveitCommented:
lets see if we can change it to "Work" or "Home" without deleting.  Go to Network Sharing Center.  Under "View your active networks" you should see "Wireless Network Connection 2" and then "public" below it.  If you click on that it should allow you to change to Work or Home.

In attached image, mine is already set to "work"

 network
LZ1Author Commented:
It just gives me "Unidentified network" and it's not clickable.  It keeps throwing me into the "Public network".  

LZ1Author Commented:
In fact, I can't connect to ANY other network(secured or unsecured).....
Frank_AlphaserveitCommented:
do you have any AV/Firewall solution installed on your laptop?  If so have you tried temporarily disabling those services?

Can you ping 127.0.0.1?
LZ1Author Commented:
Nothing yet installed.  I should mention this is a desktop PC with a custom Windows 7 over XP install.  
LZ1Author Commented:
And I can ping 127.0.0.1
Frank_AlphaserveitCommented:
Well, the fact that you cannot connect to the internet/network even by manually entering correct IP information, and other devices are connecting just fine would lead me to believe this is a NIC/Windows issue.  If you've JUST installed Windows 7, this might not be a bad time to try a Windows reinstall, and this time a fresh one.  I'm not a big fan of upgrade/over-installs, and I've seen too many random issues occur that just magically disappears upon a reinstall.

Maybe another thing you can try is rolling back to an older NIC driver, but other than that the behavior you are experiencing would point me to a necessary reinstall.

good luck, sorry i wasn't able to help more.
LZ1Author Commented:
Ok.  I just did a complete fresh install.  Still the same issue.  I don't get it.  Everything was working fine on XP.  Nothing was carried over.  Even just after I installed Windows, the same thing came up as an unidentified network.  

Could it be hardware related? It's a Realtek wireless PCI card.
Frank_AlphaserveitCommented:
this is very odd.  It really only leaves the card being the issue.

This is Windows 7 Ultimate x64 or x86?
LZ1Author Commented:
64 bit
Frank_AlphaserveitCommented:
is the driver currently installed for the Realtek the stock Windows 7 driver or did you update it?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LZ1Author Commented:
Stock windows 7 driver. I'll see if I can find the updated version
Frank_AlphaserveitCommented:
what's the model# of the Realtek card?
LZ1Author Commented:
Sorry for the delay.  In the device manager it shows a Realtek 8185 Extensible 80211b/g Wireless Device
LZ1Author Commented:
Updated to Vista x64 drivers from the Realtek website.  After googling the issue, I found that I'm not the only one.  Figures......
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.