Disable java update notification for win 7 all users

How can I disable the Java update notification for all users on a computer?  I have read that I should use AUTOUPDATECHECK = 0  in the regedit.  But the value AUTOUPDATECHECK  is no longer parge of the java registry keys anymore.  Any ideas?
LVL 1
ForLoop5Asked:
Who is Participating?
 
Kody-BurgConnect With a Mentor Commented:
That must be such a headache! Deployment is awesome. Another deployment console that you might be interested in is SCCM from Microsoft.

I made a mistake when I said that you will need a .reg file to delete that key, when I went to look at my file on the deployment server, it is actually a .vbs file (VBScript).

Here is a .zip file containing the .vbs file that you will need to run.

 deljavaupdate.zip

You will have to edit the .vbs file so that the registry key that is listed in it matches the name of the actual registry key on the machine. The key in my script deleted the updater when Sun still operated java. Now Oracle does, so if your machines are up to date with Oracle's java, this script won't work until you update the script. Simply navigate to the key location in the registry (as you can see when editing that file) and write down the name of the current registry key. Then go into the script and change the name of that key to match. The name of the key in the script is case-sensitive, so be careful when you make the changes.

Regards,

Kody
0
 
BtechBCommented:
I have been looking here in hopes to find the answer today for our school. Near the bottom are the deployment.javaws.autodownload settings. God luck.

http://download.oracle.com/javase/1.5.0/docs/guide/deployment/deployment-guide/properties.html
0
 
connectexCommented:
Try setting this registry entry HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableJavaUpdate = 0
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Kody-BurgCommented:
Just delete the java updater from the startup in the registry. Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run and delete the java updater key. It should be a key pointing at a file named something like jusched.exe. The key is named something to the effect of SunJavaUpdatSche if I remember correctly. I'm not in front of a computer with that key available right now.

Best of luck,

Kody
0
 
connectexCommented:
I tried what Kody said. But the next Java release the updater returned. So really doesn't disable it completely.
0
 
ForLoop5Author Commented:
Connectex I have not hads a chance to try your suggestion yet.  Do yuou know if it works?  I have 100 computes now with the java update screen popping up on usetrs.  And Igf I cant find a fix I will soon have 200 with the annoying java update window askink users for admin pw to update.
0
 
connectexCommented:
No my previous suggest didn't work. But default, Java updater checks for updated on the 23rd of each month. On the 23rd it again reared it's ugly head. But I did some more checking. First Java has or should I say had a way of disabling the updater during the installation process but acording to this article http://www.oracle.com/technetwork/java/javase/silent-136552.html. It's now depreciated or no longer supported! Curse you Sun / Oracle! So now I found some other information claiming setting HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft\Java Update\Policy\EnableAutoUpdateCheck = 0 will disable the updater. After making the change I've noticed the update tab on the Java control panel applet is gone. But I still want to see what happens with the 23rd comes around again.
0
 
Kody-BurgCommented:
If you just run a .reg script from your deployment server console on your machines every time you update java, you won't have an issue with the updater. It will be turned off. If you are looking for a temporary fix, running a .reg script to do what I originally suggested will fix the problem. It is what we use where I work, and we have well over 200 machines. Never have any problems with it.

Regards,

Kody
0
 
ForLoop5Author Commented:
Hey kody I dont know what a deployment server console is. Can you tell me?  Also what kind of .reg file would I run?
0
 
Kody-BurgCommented:
In my work place, we use Altiris Deployment Solution to deploy our software from a central location with a single mouse-click. If you are deploying using MDT2010, then add the .reg script as an application. If you aren't using deployment in your environment, then just run the script on every machine after you install the OS and all the plug-ins and other software(s).

The script will need to delete the registry key that I mentioned in my original post.

I'm away from my desk at the moment, typing this on my mobile device. I will post the registry script that you need when I get back to my desk.

Thanks,

Kody
0
 
ForLoop5Author Commented:
Hey Kody Thanks.  I have download a trial of altirs.  Im interested.  I have over 800 computers in my building and currently I have to update software one at a time.....  AHH
0
 
connectexCommented:
I know this question has been closed but I have some new information on this issue. It's from http://wpkg.org/. They make a free Windows deployment product. While I don't use their product they do have a wealth of knowledge on silent installations and dealing with updaters and other common administrator frustrations. On the Java (http://wpkg.org/Java), it mentions:

Disable Automatic Update

JRE 6 Update 18 and Newer

Since approximately 1.6.18 / 6.0 update 18, Sun has included Java Auto Updater as a separate package that is automatically installed with the JRE. You can disable automatic updates by uninstalling the Java Auto Updater after the JRE is installed or upgraded, by using the command line: msiexec /qn /x {4A03706F-666A-4037-7777-5F2748764D10}

I've tried it and it does remove the jucheck.exe from the run key. So I think this is the best way to disable the auto update notification.

-Matt-


 
0
 
yo_beeDirector of Information TechnologyCommented:
Do you use Group Policy Preferencies?
If so you can delete that Shortcut from your domain by applying a Delete object.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.