Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Allow WLAN access to VPN connection on SonicWall TZ100

Posted on 2011-02-18
11
Medium Priority
?
2,989 Views
Last Modified: 2012-12-02
I am trying to get a WLAN to communicate with a network that is on the other end of a VPN. I am using a Sonicwall tz100 and have created a VPN between our corporate site and this site using a Site to Site VPN. When I am on the Local LAN I can see the coporate network but when I switch to a wireless connection I cannot see the coporate site. How can I get the wireless LAN to see the corporate site.
0
Comment
Question by:tparus
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +2
11 Comments
 
LVL 2

Expert Comment

by:hitsotntd
ID: 34929958
I am a custom to building L2L VPNs with Cisco equipment so I apologize for not being exact. You will need to make sure that you are allowing the IP range that the WLAN is giving out thru the VPN tunnel.

1. Are you getting your WLAN connection by using a wireless router of some kind? i.e. Linksys?
2. Can you get to the internet via the WLAN?
3. Can you ping your gateway while using the WLAN?
4. Can you ping anything on the Local network via the WLAN?
0
 
LVL 13

Expert Comment

by:kdearing
ID: 34930217
I'll bet your WLAN is on a different subnet.
You will need to modify the sonicwall rules to allow traffic between the WLAN and VPN subnets.
0
 
LVL 6

Accepted Solution

by:
Cas Krist earned 1000 total points
ID: 34932370
In your vpn setup you must specify which networks (local and remote) can be used in this vpn tunnel, Tab 'networks' be sure to change it on both sides of the vpn tunnel. And  indeed the firewall rules.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 33

Expert Comment

by:digitap
ID: 34934941
caskrist is correct.  currently, your vpn tunnel is specifying the LAN subnets are the only IP networks allowed over the VPN.  you need to add the WLAN subnet as an allowed subnet at both ends.  what this means is you'll need to create an address group and add both subnets then use the address group in the local subnets within the vpn settings.  you'll do this at the other end. is the other end a sonicwall?
0
 

Author Comment

by:tparus
ID: 34945064
OK, I did that however I cannot talk to the networks by name. I have added all the machines to the Hosts and LMhosts file on the client end yet cannot talk to the network by name. Does Vista use the Hosts and LMHOSTS file to resolve names? On the VPN connection, Advanced tab, I have 'Enable Windows Networking (NetBIOS) Broadcast' checked on both sides yet no communication. I can connect via IP but would like to connect via name.
0
 
LVL 33

Assisted Solution

by:digitap
digitap earned 1000 total points
ID: 34945104
ah, you can modify the DHCP scope on the WLAN to give your LAN DNS server as the DNS server for your WLAN hosts.  this is what i do, especially when i trust my WLAN hosts.  if i don't trust them, then they aren't getting the LAN anyway so i give them a public DNS server like, 4.2.2.2.

does that sound right?
0
 
LVL 2

Expert Comment

by:hitsotntd
ID: 34945764
I agree with digitap, the issue now is an DNS issue. As long as you can ping the other side of the tunnel successfully by ip address and not by name, that is an dns issue. To repeat what digitap stated, you will need to configure you WLAN access point/router to give out your LAN's DNS server's IP addresses.

FYI, Side note: When editing VIsta's host file, make sure to do it with with admin rights. example,

1.Open Notepad with Administrative privileges by clicking Start, All Programs, Accessories, and then right-click Notepad and select to open as Administrator.
2.Now that Notepad is open with Administrative privileges browse to (C:\Windows\System32\drivers\etc) in Notepad and open the hosts file.

0
 
LVL 6

Expert Comment

by:Cas Krist
ID: 34950029
You can also add a WINS server to the DHCP-scope for WLAN.
0
 

Author Closing Comment

by:tparus
ID: 34956068
Thanks for all your help on this.
0
 
LVL 33

Expert Comment

by:digitap
ID: 34956086
you're welcome, thanks for the points!
0
 
LVL 6

Expert Comment

by:Cas Krist
ID: 34960537
Thanks, good luck.
0

Featured Post

Are You Ready for GDPR?

With the GDPR deadline set for May 25, 2018, many organizations are ill-prepared due to uncertainty about the criteria for compliance. According to a recent WatchGuard survey, a staggering 37% of respondents don't even know if their organization needs to comply with GDPR. Do you?

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Creating an OSPF network that automatically (dynamically) reroutes network traffic over other connections to prevent network downtime.
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question