Solved

MS Word 2010 "Owner Files" Not Auto-Deleting from Network Share

Posted on 2011-02-18
6
3,651 Views
1 Endorsement
Last Modified: 2012-06-27
Using MS Word 2010, when opening an existing document from a network drive, an "owner file" is created on the drive.  This "owner file" is in the format ~$nnnnnnn.doc, is 1kb in size, and contains the UserID of the person who has the file open.  Upon exiting the MS Word session, the owner file should auto-delete, but it does not.  This tends to clog up the network share, and can lead to false indications of the file being open by someone else.  As far as I can tell, this is unique to MS Office 2010 (we never had the problem before upgrading to Office 2010.  How can this be corrected so that the "owner files" will automatically delete when exiting Word 2010?
1
Comment
Question by:pschobe481264
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 
LVL 1

Expert Comment

by:Apoc83
ID: 34930397
Is this an office wide issue or is it just one computer having this issue? Are the computers in a domain or is the shared location just another workstation?

Can you login as administrator and see if the problem replicates or not?
0
 
LVL 13

Expert Comment

by:BCipollone
ID: 34930483
Do the temp files clear when that user logs off the domain?

Try opening word with the /a switch
0
 
LVL 1

Author Comment

by:pschobe481264
ID: 34931169
It's an office-wide issue.  The computers are in a domain, and the Word folder is on a network share.
The temp files don't clear when that user logs off the domain.
0
[Webinar] Code, Load, and Grow

Managing multiple websites, servers, applications, and security on a daily basis? Join us for a webinar on May 25th to learn how to simplify administration and management of virtual hosts for IT admins, create a secure environment, and deploy code more effectively and frequently.

 
LVL 1

Accepted Solution

by:
Apoc83 earned 500 total points
ID: 34931225
Pschobe

Check your NTFS permissions on the folder. If they do not have full permissions on the folder, try giving it to them and see if the problem goes away.

Another thing you can do is make a test folder and see if you have the same problems with doc files in that folder. Just make sure you dont place the test folder under the folder your having issues with.
0
 
LVL 1

Author Comment

by:pschobe481264
ID: 34944663
Due to the fact that Apoc83's suggestion, although not the actual fix, got me on the right track, I'm awarding the points to Apoc83.  

Here's the resolution:

The files that are not deleting are actually "Owner Files".  Owner files are in the format ~$nnnnnn.doc, are only 1Kb in size, and contain the UserID of the person that has the file open.  They are designed to prevent multiple users from trying to update the same file, tell MSOffice who has what open and why, etc.  

Normally, Owner FIles are automatically deleted when you close MSWord (or Excel, etc.).  However, something else comes into play with MSOffice 2010's enhanced security features and accessing files that it thinks may be unsafe.  Due to the way that we authenticate to a legacy domain for access to a file server, MSOffice thinks that files on the network drive  came from the Internet, and then opens them in an enhanced security mode known as "Protected View".  That's the view with the yellow bar at the top of the Word window which tells you that the file is potentially unsafe.  You have the option of clicking on Enable Editing, which then lets you work on the file.  If you do that, however, the Owner File won't be deleted from the source directory, which MSOffice thinks is probably from the Internet.  It's a "feeture" of Office 2010; had the file actually been from the Internet, it would have downloaded to the temporary directory and left behind the Owner file for future system reference.

So, the fix is to change MSWord options (File -> Options -> Trust Center -> Trust Center Settings -> Protected View options).  De-select "Enable Protected View for Files Originating from the Internet".  This will prevent the enhanced Protected View security feature from coming into play when opening files from the legacy network, and the files will automatically delete when you leave your Word session. The downside, of course, is that you no longer have the safety net of Protected View on files actually coming from the Internet.  

Probably have to do the same for MSExcel.
0
 
LVL 1

Author Closing Comment

by:pschobe481264
ID: 34944678
Good diagnostic questions/issues, which led me to the actual facts!
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

It is often necessary in this forum and others to illustrate Word fields as text with the field delimiters replaced with the curly brackets that the delimiters resemble when field codes are being displayed on the document. This means that the text c…
Microsoft Word is a program we have all encountered at some point, but very few of us have dug deep into its full scope of features, let alone customized it to suit our needs. Luckily making the ribbon (aka toolbar, first introduced in Word 2007) wo…
The viewer will learn how to make their project stand out over others by learning how to change colors and shapes, add spaces, change directions, and add bullets to their charts.
Learn how to make your own table of contents in Microsoft Word using paragraph styles and the automatic table of contents tool. We'll be using the paragraph styles in Word’s Home toolbar to help you create a table of contents. Type out your initial …

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question