Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 754
  • Last Modified:

Netflix in Windows 7 Media Center has stopped playing content

This week I noticed that when I try to view Netflix content in Windows 7 Media Center I get a message that states "Navigation to this page has been canceled.".  I can view it in the browswer just not in media center.  My 360 works fine to and I have two Windows 7 Ultimate 64-bit computers and I'm getting the same message on both.  I've been using this service for more than two years without a problem and a few queries in MS's knowledge base reveal no acceptable solutions.  I've cleared my browser cache and I'm not using any other browser except IE 8.  Any advice?  It's weird, I tell ya, just weird.  
0
jbsverloc
Asked:
jbsverloc
1 Solution
 
ded9Commented:
Uninstall netflix from program and features. Reset media center setting and run the media center setup again. Install netflix and check

http://www.microsoft.com/windows/windows-media-center/netflix.aspx



Ded9
0
 
Jackie ManCommented:
According to the advice of GuyLR, the fix is as follows:-
      
"Another Greenbutton post by Barb claims this is a less destructive workaround for the webpage navigation error.

http://thegreenbutton.com/forums/p/9...02.aspx#521502

If you are experiencing "Navigation to the webpage was cancelled" inside Windows Media Center, here are work around fix instructions. This is less destructive than other versions that have been posted:

1. In IE, File menu, Import and Export, export cookies to a file and edit out netflix cookies. the cookies I removed are:

netflix.com

netflix.ca

community.netflix.com

You may only have netflix.com cookies (there are multiple entries, I had 7)

save to cookiesedited.txt

2. Close both Media Center and IE
3. Open IE and open the Security tab in Tools, Internet Options.
4. Disable "Protected Mode" under Internet (you should re-enable it after the work around) close your browser and restart it
5. If you have Netflix.com in your trusted sites, please remove it
6. Clear all cache/temporary files and cookies, you do not have to delete the other options.
7. Import the edited cookiesedited.txt file
7. Log into Netflix in IE (play a couple seconds of a movie to double check that it works, pause whatever you played). Don't exit IE yet.
8. Open Media Center Netflix (while IE is still open) stream something different. This should work
9. close Media Center
10. In IE, re-enable protected mode and restart browser. Close browser
11. Open WMC and streaming should still work"

Source: http://www.avsforum.com/avs-vb/showthread.php?p=20026712
0
 
jbsverlocAuthor Commented:
You know, I tried this several times and this morning, boom, it worked.  That's strange.  Can't explain it.  Thanks for the help.
0

Featured Post

Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now