Solved

Cannot publish Windows Server Administrative Tools with XenApp 6

Posted on 2011-02-18
5
2,213 Views
Last Modified: 2014-03-24
I would like to publish some of the Windows Server Administrative Tools using XenApp 6. When I try do so, I receive an error when trying to open the application with the clients.

"Application Name" failed to start.

The Citrix server is unable to process your request to start this published application.
Please try again. If the problem persists, please contact your administrator.


Is it not possible to publish msc applications with XenApp?
0
Comment
Question by:pphm
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 15

Expert Comment

by:Lee Osborne
ID: 34933725
Have you tried publishing it as the MMC first, followed by the location of the snap-in to publish?

For example, to publish ADUC, create a new published application:

Command Line: "C:\WINDOWS\system32\mmc.exe" "C:\WINDOWS\system32\dsa.msc"
Working Directory: "C:\WINDOWS\system32"

Lee
0
 

Author Comment

by:pphm
ID: 35013840
Just tested it. It doesn't like the extra parameter. I can open MMC fine but if I add any snap-ins and save the file, I get the same error as before when trying to open the file.
0
 

Accepted Solution

by:
pphm earned 0 total points
ID: 35122883
I ended up creating batch file and using that to start the applications. The msc applications start if the session has already started so using a batch script calls the command prompt first allowing the session to start.
0
 

Author Closing Comment

by:pphm
ID: 35163478
Figured out the solution on my own. The other solution provided did not work.
0
 
LVL 1

Expert Comment

by:Matsco
ID: 39950596
Use Active Directory Administrative Center instead. This performs the same function.

%windir%\system32\dsac.exe
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Citrix policies are the most efficient method to configure and tune XenDesktop environments, allowing organizations to control connection, security and bandwidth settings based on various combinations of users, devices or connection types.  Citrix …
CITRIX XENAPP 6.5 FARM CUSTOM POLICY - CHANGE MANAGEMENT WINDOW REBOOT SCHEDULE
How to install and configure Citrix XenApp 6.5 - Part 1. In this video tutorial we have explained step by step installation of Citrix XenApp 6.5 Server on Windows Server 2008 R2 is explained in this video. We have explained the difference between…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question