Intermittent Internet on One Computer

I'm hoping it's something stupid that I'm just missing. About a week ago I changed my network configuration to the following:

Internet -> DSL Modem -> Windows 2003 Server (firewall, router, and DHCP server) -> Wireless access point (DHCP not enabled)

It's been working fine. We have two laptops and a few devices all running on the wireless network. All of a sudden tonight one of the laptops (a Dell Inspiron 2200 with Windows XP) started having trouble accessing web pages. The signal strength will be at Very Good. We'll load a couple of pages and then all of a sudden, FireFox will say "The connection has timed out."

The Windows 2003 Server has a .3 IP address, the wireless access point has a .2 IP address. The laptop currently has a .21 address, which it's getting via DHCP. From DOS, I can sometimes ping the server; sometimes it times out. I can reliably ping the wireless access point. I can also reliably ping the other laptop on the wireless access point. I can also ping the problem laptop from the other laptop on the wireless access point. From the diagnostic tools on the wireless access point, sometimes I can ping the problem laptop and sometimes I can't.


If I disable the wireless network card and plug the laptop in via ethernet, it works fine.

We've rebooted the laptop, the wireless access point, and unplugged and plugged back in the wireless access point.

I'm at a loss... any ideas?
LVL 14
quizwedgeAsked:
Who is Participating?
 
akahanConnect With a Mentor Commented:
If there's an IP address conflict, then SOMETHING on your network has a static IP address, which is conflicting with addresses being handed out by DHCP.  If the offending device is only connected to your network sometimes, then you'll get intermittent problems...you'll only see problems when the device with the static ip address is connected.  

I wonder if you could have a neighbor who is sometimes connecting to your wireless AP, or an iPhone that's set with a static IP address, or some other wireless offender.  Perhaps when the problem is occurring, you could look at the AP's table of who's connected, and see if there are any devices you don't recognize.
0
 
XLITSCommented:
Is the problem laptop within a reasonable range to the WAP?  If it is on the edge of the range of it's connection you will get sporatic drops.  If it is within range, I might try updating the driver of the wireless card on the problem laptop.  
0
 
edbedbCommented:
It sounds like the laptop's wireless adapter is failing. Try a USB adapter or replacing the original one.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
akahanCommented:
From your description, it seems pretty clear what the problem is NOT:

It's not the wireless connection, as you can reliably ping the WAP even when you're having the problem.
It's not a setting being wrong, since it works sometimes.
It's not a DHCP problem, since you're getting a sensible address.
It's not a problem with Firefox, since (1) ping to the server is unreliable, and that's not Firefox dependent; and (2) the wired connection works fine.

I'd suspect a problem with the TCP/IP stack.  Try:

Go to your command prompt window. Start> Programs> Accessories> Command Prompt (Windows XP). The command prompt window will appear.
In the command line type: netsh int ip reset resetlog.txt . Press enter.
Restart the computer.

Any joy?

If not, perhaps try updating the driver for the wireless card on the laptop.  Not because you're using an old driver (after all, it was working fine a couple weeks ago, right?), but because the driver may have gotten corrupted.  Do this by going into Control Panel, System, Device Manager, and then UNINSTALLING the wireless NIC.  Then, reboot the PC, it'll find the wireless NIC as "new hardware," and reinstall the drivers, hopefully correctly.


0
 
ChiefITCommented:
I just experienced this the other day...

Many companies are now sending their wireless routers or APs on a specific channel. The significance of that is, they are on the same channel. In my case the closest neighbor's access point was on the same channel as mine. So, I had a problem with is wireless interfering with mine. You should be able to set your AP to a different channel. Some are set to automatic, which will try and find a channel if the channel is used, (channel meaning same frequency).

The pic attached is a wireless spectrum analyzer. It shows a 802.11 B carrier that is interferred with by a 802.11G carrier... Then, it shows another B carrier on by itself. So, there are three signal carriers on this screen shot. The B carrier signal looks like a half round. The G looks like a plateau.

When two frequency carrier signals are too close or are the same freqency (as in this case), they may cause radio frequency interference and cause your AP to periodically loose connection.

The answer for me was to change my Wireless router's channel to channel 11. Try changing your AP channel..

The problem with wireless is it is growing exponentially. People are going to wireless APs. So, many of us will have to learn how to control channels in order to try and keep all other APs in the local area from interfering with one another.
chanalyzer-lg.jpg
0
 
ChiefITCommented:
My neighborhood looks something like this:

channelyzer-in-my-neighborhood.docx
0
 
Ravi AgrawalCommented:
Check under the Wifi NIC's Power management options >> Turn off all power saving options.

Open Windows Device Manager >> Type devmgmt.msc in the Run Dialog Box (Windows + R key pressed together will bring up the Run Dialog box.) Expand Network Adapters / Locate your Wifi NIC / Select it & Right click / select properties / Power management tab / Uncheck all power saving options.

Disable & then enable the Wifi connection. Test.

Any luck...

If no, then I would delete the NIC from Device Manager & let it reinstall. Remap the APN & test.

To remove NIC from Windows Device Manager >> Type devmgmt.msc in the Run Dialog Box (Windows + R key pressed together will bring up the Run Dialog box.) Expand Network Adapters / Locate your Wifi NIC / Select it & hit the delete key. Reboot.

Ravi.
0
 
Ravi AgrawalCommented:
GRRR,,,

sorry to repeat akahan's comment.

Ravi.
0
 
quizwedgeAuthor Commented:
Sorry for the delay in responding. Some time later after posting the message, while the laptop was just sitting there open, it displayed an error message... something about an IP address conflict. (Sorry, I forgot to write down the exact message.) I gave it a static 192.168.2.X IP address, manually set the router IP address and DNS address. It was working, but I wanted to give it a day to make sure that it wasn't something random. I'm not sure why it didn't give the IP address conflict in the beginning.

I haven't switched back to DHCP yet. Would the conflicting IP address fit the problems I was having or is it just a random fluke that it's working now?

@XLITS The wireless card is within range of the WAP. Before setting the IP address, I tried it about 5 - 10 feet from the WAP.

@akahan good suggestion on the TCP/IP stack and driver. I haven't updated it yet, but probably wouldn't be a bad idea to do anyway.

@ChiefIT I had previously switched the channel. IIRC, it's set to 10. There are a bunch of wireless networks that I can pick up, so I tried to choose the channel that seemed the most free.

@grtraders If it's determined that the DHCP issue wasn't the culprit and it's a random fluke, I'll try your suggestion (power saving options) after trying the solution from @akahan

Thanks for the help
0
 
quizwedgeAuthor Commented:
Well, I went through the DHCP log and couldn't find the conflict, but I won't claim to be anywhere near knowledgeable on running a DHCP server. My experience has been that it pretty much just ran on its own and I didn't have to do much to it. That being said, the laptop is working now so there must have been some kind of conflict. Either a neighbor connected (still running WEP on that AP, which I know can be broken) or my DHCP leases were just off.

Thanks for all of the help.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.