Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1210
  • Last Modified:

Android wifi - have IP address but can't browse internet

This question is related to #26536109

Experts, still trying to solve an issue with my Android phone not able to browse past my router with a wifi connection.

Samsung Epic phone - properly configured according to Sprint tech support
Linksys WAP - properly configured according to Linksys tech support
Linksys Router - DHCP turned off, no MAC filtering - properly configured according to Linksys tech support
WinServer 2008 Std - DNS Server, DHCP Server, AD Domain Server
DSL modem

Windows laptops with dedicated IP addresses can connect just fine.

Thanks in advance.

0
bobinorlando
Asked:
bobinorlando
  • 6
  • 3
1 Solution
 
JAN PAKULAICT Infranstructure ManagerCommented:
phone static ip is in the same subnet as geateway interface for wan?

Jan MA CCNA
0
 
JAN PAKULAICT Infranstructure ManagerCommented:
are you using any type of hardware firewall on system like cisco asa or sonicwall?
0
 
bobinorlandoAuthor Commented:
no hardware firewall

router is 192.168.1.1
subnet mask is 255.255.255.0

phone static ip is set to 192.168.1.201 on the phone and in windows server DHCP
although how windows could recognize an android phone I don't know
However, the phone wireless settings is actually showing the phone getting an IP of 192.168.1.106 and not 201


0
Evaluating UTMs? Here's what you need to know!

Evaluating a UTM appliance and vendor can prove to be an overwhelming exercise.  How can you make sure that you're getting the security that your organization needs without breaking the bank? Check out our UTM Buyer's Guide for more information on what you should be looking for!

 
JAN PAKULAICT Infranstructure ManagerCommented:
on dhcp server do cmd
ping 192.168.1.106
ping 192.168.1.201

then do

arp -a

this will show your mac addresses of this ips
compare it with your android mac address

Your router dont have any mac filters?
can you connect without wireless security to internet?

JAN MA CCNA
0
 
JAN PAKULAICT Infranstructure ManagerCommented:
on dhcp server go to start administrator tools --> dhcp server - make sure that your dhcp server has 1 reservation for your phone mac address
0
 
bobinorlandoAuthor Commented:
Ok. It has an IP address of 192.168.1.201

Client IP Address: 192.168.1.201
Name: Android
Lease Expiration: Reservation (inactive)
Type: None (all other IPs show DHCP here)
Unique ID: the mac address shows here
Description: Android
Network Access Protection: Off
Probation Expiration: N/A
0
 
JAN PAKULAICT Infranstructure ManagerCommented:
you have incorrect mac in dhcp (reservation is inactive)

0
 
bobinorlandoAuthor Commented:
I deleted and re-entered the reserveration
Now it says Reserveration (active)

I can ping the router and the DNS/DHCP server but I can't get past them to the DSL modem beyond that to the net.




0
 
JAN PAKULAICT Infranstructure ManagerCommented:
can you ping from dsl modem your android ip - you have to log in to router ios (telnet?) and do traceroute or ping
you can also try to put ip address of your router interfaces in android (wan and lan ones) - if you can connect to lan interface of router from android you probably have some sort of vlans , access list or mac filtering on router - which wont let you pass through

if you can ping android from dsl router but not other way around could you give us router config - login to router and do

sh run

paste here outcome

0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 6
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now