• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2505
  • Last Modified:

Group Policy only applying IE7 proxy settings after second logon

School system migrating from Novell to Microsoft AD.  We migrated our first building last week and have run into a little snag with our Group Policy.  All other policies are shooting down perfectly, except for our IE proxy settings.

Last year we deployed IE7 to our school division using a customized install of IE7 using the IEAK.  Part of the configuration was to have the Proxy settings and exceptions built into the install of IE7.  This worked great for us until we began our migration to Microsoft AD, which has forced us to use a new proxy address.

Long story short, it appears that the workstations that had our customized install of IE7 are not applying the "new" IE proxy server and exceptions settings sent down by Group Polilcy upon the user's first logon.  If the user logs off and back on again, the correct proxy settings are applied.

This is not a problem for our teachers and administrative offices because those users typically use the same workstation.  This is a problem for our computer labs and laptop carts for student access.  It is rare for a student to use the same computer twice in the same week - they usually sit at any available computer when they come into a computer lab.

I have read that IE 7 applies proxy settings as per-machine rather than per-user, so I have already tried changing the computer policies to disable the application of IE settings as per-machine.  This did not change anything.

I've also tried setting the typical Internet Explorer maintenance configurations, as well as, the settings available in Group Policy Preferences - none have made a difference.

This problem doesn't seem to be occurring our IE8 or IE6 workstations, nor on our workstations that did not use our customized install of IE7.  

Is there anything I'm missing??  My last resort is to script the proxy exceptions and hope for the best, but we have 14 proxy exception lists (depending on the security group/computer combination) and that's a lot of scripts to maintain.

Servers:  Windows Server 2008 R2
Clients:  Windows XP Sp3

0
IRollC30
Asked:
IRollC30
  • 6
  • 4
1 Solution
 
DonNetwork AdministratorCommented:

Do you have the following enabled?



Computer Configuration\Administrative Templates\System\Group Policy\IE Maintenance Policy Processing. Set to Enabled and "Process even if the Group Policy Objects have not changed".


0
 
IRollC30Author Commented:
Yes, and all over the place too.  There are several (I'm going to say 10) GP settings that I changed to "Process even if blah blah blah has not changed".
0
 
DonNetwork AdministratorCommented:
Any errors in event logs?

Does the policy apply after first logon if you run gpupdate afterwards?

have you tried loop back policy?

0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
DonNetwork AdministratorCommented:
Ahhh....found something I experienced in past about "Gopher" and forgot until now

http://nickganga.com/2009/03/13/internet-explorer-7-advanced-proxy-settings-via-group-policy/
0
 
IRollC30Author Commented:
Any errors in event logs?

Does the policy apply after first logon if you run gpupdate afterwards?

have you tried loop back policy?

You will have to excuse my ignorance, this is my first "real" dealings with Group Policy.  I've worked with ZEN (Novell) policies for a few years, but true-blue Group policy is new for me.

Any errors in event logs?  Haven't checked, but I will next week.

Does the policy apply after first logon if you run gpupdate afterwards?  Yes

Loop back policy?  Haven't tried yet but can try if there are no other options.
0
 
DonNetwork AdministratorCommented:
Try removing "Gopher" from the proxy in case you just missed my previous post
0
 
IRollC30Author Commented:
Ahhh....found something I experienced in past about "Gopher" and forgot until now

http://nickganga.com/2009/03/13/internet-explorer-7-advanced-proxy-settings-via-group-policy/

I just looked through the printed version of the policy and I do have Gopher enabled.  I'll make the change you suggested and let you know on Tuesday if it worked.

I'm going to freak my freak if this is the cause of my problem...
0
 
DonNetwork AdministratorCommented:
Hopefully :)
0
 
IRollC30Author Commented:
Hopefully :)

Yup, fixed my problem.  Thank you so much for your help - I really appreciate it.
0
 
DonNetwork AdministratorCommented:
Who woulda thunk? ;^)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 6
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now