OWA URL change and disabling RRW

I am running an SBS 2008 server and would like to the change the way the OWA URL is specified as I have seen with other companies.

For example, currently whenever I type http or https:\\mail.domain.com it will automatically redirect to https:\\remote.domain.com\owa then the OWA logon page is shown with https:\\remote.domain.com\owa show in the address bar.

I had already registered a UCC with alternative name mail.domain.com and the domain name mail.domain.com to point to the my external IP.  Everything works great except for one small cosmetic thing that when it gets directed the resulting URL after the page is loaded shows https:\\remote.domain.com\owa instead of staying as https:\mail.domain.com

How can I change the URL so that SBS2008 will keep the URL even after the OWA page is loaded?

A perfect example of this is AMD - https://myemail.amd.com/ that after the OWA page is loaded up the URL still says "https://myemail.amd.com/" not "https://remote.amd.com/owa

The second issue is that I want to disable RRW as we have no use for it but I don't want to delete the virtual directory.  I know you can disable RRW from the SBS Console but each time after a restart it automatically restart the service.  Is there a way to make it stay disabled until switched on re-enabled?

Thanks in advance.

Please be detailed with your answer.
LVL 18
Wayne88Asked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
lscarborConnect With a Mentor Commented:
1. Here's a detailed explanation of changing the prefix 'remote' to somethingelse. There are issues you should know about, but it can be done. It's important for certain updates for example.

http://www.sbstraining.net/post/2009/01/SBS-2008-remotedomain-prefix.aspx

2. I recommend just using the console to remove access to RWW  Go to Shared Folders and Web Sites. Pick Web Sites. Pick RWW. Disable RWW in tasks.
0
 
Wayne88Author Commented:
Hi Iscarbor,

I am still looking into number 1 and I am aware of how to disable the RRW from the SBS console but looking for a different solution because as I stated that it seems to renable itself after each server restart.

Wayne
0
 
lscarborCommented:
Sorry.  You could go to the user roles and remove access to RWW in the properties.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
Wayne88Author Commented:
Thanks for answering number 1 and this will get the job done.  I will assign 1/2 of the points or give you all if no one else can figure how to disable the RRW site permanently.

As for the second qustion, I am still looking for a way just to ensure that the RRW site doesn't re-enable itself after restart.  Not sure why MS let us disable the site but not permanently....real silly.
0
 
lscarborCommented:
It re-sets itself after disabling it in the roles?
0
 
lscarborConnect With a Mentor Commented:
Go to IIS (not the 6.0 version)
Under the left panel, pick your server, then Sites
Pick SBS Applications
Right-click Remote
Then Advanced
Delete HTTP from the protocols section.
Restart the server

0
 
Wayne88Author Commented:
Thanks Iscarbor for all your help. That will work.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.