Microsoft Access Security Notice

I'm developing a run-time based Access 2007 application for a client.  I need to be able to set it so that the users do not get security notices every time they start the application.  I initially thought I was running into Trusted Location issues (see this question; however, I added code to create a trusted location and that did not stop all of the security notices.  My client is still getting the "Microsoft Access Security Notice" every time they start the application, even after verifying that the trusted location for the app had been set.

I found the KB stating that users can fix this by installing Office 2007 SP2; however, my client is running Office 2010

What specifically is causing this and how can I get rid of it?  
LVL 1
mlunsfordAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
SheilsConnect With a Mentor Commented:
I have been advised that sagekey handles that pretty well.

http://www.sagekey.com/installation_access.aspx
0
 
mlunsfordAuthor Commented:
Exl04,

I tried changing the SandBoxMode and that did not eliminate the error (even after setting it all the way down to 0).
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
Boyd (HiTechCoach) Trimmell, Microsoft Access MVPConnect With a Mentor Commented:
It would help to know a little ore about your database setup::

Since you said users then I would expect that you have properly set up for  multiple users by Splitting your Access database into application and data. Is this correct?

Also is the front  end compiled into an ACCDE?

Do you have the front end on each user's machine?

0
 
mlunsfordAuthor Commented:
Yes, I have the database split into a data BE and a logic FE, with the FE compiled into an ACCDE.  The entire Access portion of the database is distributed to each user (it does connect to some remote databases, but those are entirely outside Access and the requests are passed through a web service).

I think I may have found a solution here: http://bytes.com/topic/access/answers/764640-disable-access-security-notice

I'm waiting to hear back from the client to see if that removed the notice on their end.
0
 
mlunsfordAuthor Commented:
I just heard back from the client and changing "VBAWarnings" did not help.
0
 
Exl04Connect With a Mentor Commented:
mlunsford it may not be you project/access, use some Root Cause Analysis techniques/tools to trouble shoot. Seems like most of the people with similar situation don’t have any problem adjusting settings, using some tools to overcome the problem, so I will start installing it in another machine, another network, talk to the network administrator of the place you are installing it, he may have some setting that not let it install, check service packs for machine installing for Office/Windows, etc…document/ organize you trouble shooting…. Let’s see more advice from experts, give more details of your problem..
0
 
Exl04Commented:
"it may not be you project/access" with this I mean that the problem may not reside in you project
0
 
mlunsfordAuthor Commented:
Exl04,

Thanks for your advice.  The application will be distributed to end users in a non-controlled environment and needs to "just work", so unfortunately, my ability to address issues is limited to what can be accomplished within the installer and the application itself.

However, after trying the "VBAWarnings" tip with my client and being told it didn't work, I realized that even though I developed the application in Access 2007 he had a full version of Office 2010 installed on his computer.  After changing the path from "Office\12.0" to "Office\14.0", it worked!  So I guess I'll need to set keys for multiple versions of Office.
0
 
Exl04Commented:
“and the requests are passed through a web service” ....this will probably need to be post it in a section with IIS Sever experts too
0
 
Exl04Commented:
Glad you found a solution...
0
 
Boyd (HiTechCoach) Trimmell, Microsoft Access MVPCommented:
One of the nice things about Access 2010 is that user only has to trust the document once.



0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Connect With a Mentor Infotrakker SoftwareCommented:
Make sure that you're very upfront with your client about this process and clearly inform them that you are disabling security options on that machine. While most won't care, you don't want to get into a situation where you've disabled security matters on a machine without the client's knowledge. In the event of a virus/malware infestation, you don't want to be one who opened the gate without telling the gatekeeper!

And please don't take this to mean that you are NOT being upfront with your client, as that's not what I intended. It's just food for thought.
0
 
mlunsfordAuthor Commented:
Agreed and thanks for the input.  
0
 
mlunsfordAuthor Commented:
I realized that the issue on my client's machine that was preventing Trusted Locations from being the solution, was that I was setting an Office 2007 TL and he is running Office 2010.  I set it to add TLs for both, and the issue was resolved so I can fortunately avoid using the VBAWarnings setting entirely.
0
 
DatabaseMX (Joe Anderson - Microsoft MVP, Access and Data Platform)Commented:
RE: " I initially thought I was running into Trusted Location issues (see this question; however, I added code to create a trusted location "

I would like to see that code

thx.mx
0
 
mlunsfordAuthor Commented:
I added a key in HKCU\Software\Microsoft\Office\12.0\Access\Security\Trusted Locations for the install location of the database.  And also one in Office\14.0.  Since the exact install location can change based on machine or Windows version, I also check the value in VBA and change it to the application folder if it doesn't match.
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
0
All Courses

From novice to tech pro — start learning today.