Solved

Help with Cisco 5505 (8.3) Config

Posted on 2011-02-19
4
763 Views
Last Modified: 2012-05-11
Can someone help with a Cisco 5505 (8.3) configuration problem? I have a dynamically assigned IP address from the cable modem ISP and am trying to configure simple internet access for the local hosts. The inside hosts are getting the correct DHCP information but can not communicate outside. I can ping the inside interface 198.162.1.1 but nothing on the outside.

packet-tracer input inside tcp 192.168.1.10 4444 198.133.219.25 80 returns "No route to host"

Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
MAC Access list

Result:
input-interface: inside
input-status: up
input-line-status: up
Action: drop
Drop-reason: (no-route) No route to host

I had a similar config running in pre-8.3 days but that was with a static IP, so I'm guessing its a simple config issue but I can't find it.

thanks



domain-name test.com
enable password ghYNAT7italwLNV1 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa831-k8.bin
ftp mode passive
dns server-group DefaultDNS
 domain-name test.com
object network internal_lan
 subnet 0.0.0.0 0.0.0.0
access-list outside_in extended permit icmp any any echo-reply
access-list outside_in extended deny ip any any log
pager lines 24
logging console emergencies
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
object network internal_lan
 nat (inside,outside) dynamic interface
access-group outside_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 209.18.47.61
dhcpd auto_config outside
!
dhcpd address 192.168.1.10-192.168.1.40 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username jpb1 password xafpdRxNT9ChAFLv encrypted
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:d10fe4e4491935f2c1c28d4f9ff9e58b
: end
0
Comment
Question by:jamietfoster
4 Comments
 
LVL 2

Expert Comment

by:mwblsz
ID: 34935663
no route set up, need to add following set up

route outside 0.0.0.0 0.0.0.0 x.x.x.x

x.x.x.x is the gateway provided by your ISP

sincerely
0
 
LVL 34

Expert Comment

by:Istvan Kalmar
ID: 34935916
Hi.

The config seems to be god, did you get IP addres from ISP?
did you put 'clear xlate' ?

Best regards,
Istvan
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 34937624
@mwblz,
 >ip address dhcp setroute

This sets the default route automatically, no reason to manually set it.

Enable ICMP inspection instead of using ACLS if you want to use ping to test connectivity:

policy-map global_policy
 class inspection_default
 inspect icmp

no access-group outside_in in interface outside

Check the interface to make sure that you are getting an IP address via DHCP. If connected to a cable modem, shut off the modem and the ASA, wait a good 5 minutes for the modem to clear. Power up the modem, then power up the ASA. Then check to make sure you get an IP address and a default route.
0
 

Author Closing Comment

by:jamietfoster
ID: 34938092
That did it irmoore, thanks to all for the help!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
PEAP authentication 7 46
Cisco ASA 5505 Login issues 2 38
CCNA lab 6 37
Help with inter-vlan routing on a Cisco SG500. 12 28
How to configure Site to Site VPN on a Cisco ASA.     (version: 1.1 - updated August 6, 2009) Index          [Preface]   1.    [Introduction]   2.    [The situation]   3.    [Getting started]   4.    [Interesting traffic]   5.    [NAT0]   6.…
This article assumes you have at least one Cisco ASA or PIX configured with working internet and a non-dynamic, public, address on the outside interface. If you need instructions on how to enable your device for internet, or basic configuration info…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question