Help with Cisco 5505 (8.3) Config

Can someone help with a Cisco 5505 (8.3) configuration problem? I have a dynamically assigned IP address from the cable modem ISP and am trying to configure simple internet access for the local hosts. The inside hosts are getting the correct DHCP information but can not communicate outside. I can ping the inside interface 198.162.1.1 but nothing on the outside.

packet-tracer input inside tcp 192.168.1.10 4444 198.133.219.25 80 returns "No route to host"

Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
MAC Access list

Result:
input-interface: inside
input-status: up
input-line-status: up
Action: drop
Drop-reason: (no-route) No route to host

I had a similar config running in pre-8.3 days but that was with a static IP, so I'm guessing its a simple config issue but I can't find it.

thanks



domain-name test.com
enable password ghYNAT7italwLNV1 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa831-k8.bin
ftp mode passive
dns server-group DefaultDNS
 domain-name test.com
object network internal_lan
 subnet 0.0.0.0 0.0.0.0
access-list outside_in extended permit icmp any any echo-reply
access-list outside_in extended deny ip any any log
pager lines 24
logging console emergencies
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
!
object network internal_lan
 nat (inside,outside) dynamic interface
access-group outside_in in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd dns 209.18.47.61
dhcpd auto_config outside
!
dhcpd address 192.168.1.10-192.168.1.40 inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username jpb1 password xafpdRxNT9ChAFLv encrypted
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
  inspect ip-options
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:d10fe4e4491935f2c1c28d4f9ff9e58b
: end
jamietfosterAsked:
Who is Participating?
 
lrmooreConnect With a Mentor Commented:
@mwblz,
 >ip address dhcp setroute

This sets the default route automatically, no reason to manually set it.

Enable ICMP inspection instead of using ACLS if you want to use ping to test connectivity:

policy-map global_policy
 class inspection_default
 inspect icmp

no access-group outside_in in interface outside

Check the interface to make sure that you are getting an IP address via DHCP. If connected to a cable modem, shut off the modem and the ASA, wait a good 5 minutes for the modem to clear. Power up the modem, then power up the ASA. Then check to make sure you get an IP address and a default route.
0
 
mwblszCommented:
no route set up, need to add following set up

route outside 0.0.0.0 0.0.0.0 x.x.x.x

x.x.x.x is the gateway provided by your ISP

sincerely
0
 
Istvan KalmarHead of IT Security Division Commented:
Hi.

The config seems to be god, did you get IP addres from ISP?
did you put 'clear xlate' ?

Best regards,
Istvan
0
 
jamietfosterAuthor Commented:
That did it irmoore, thanks to all for the help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.