• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1313
  • Last Modified:

"Ghost" Folder on My Windiws 7 Desktop

So this leftover folder won't go away.  There is nothing in it.  I try to drag it to the recycle bin.  I select it and try to delete it.  I right click it and the display sez: Open or Create Shortcut.  This folder shows up in Windows Explorer and can't delete it there either.   How do I get rid of this annoying useless icon.
 Screen-Shots-of-Frozen-Folder.doc
Hopefully my screen shot gets through.  I was thinking I could just paste a *.jpg screen shot.  Getting a screen shot was pretty difficult too.
0
dockboy549
Asked:
dockboy549
  • 5
  • 3
  • 2
  • +3
5 Solutions
 
btdownloads7Commented:
What is the folder called? Are you sure it's a folder and not something else with a folder icon? When you open it, what path does it show in the address bar ("c:\users\.....)? Are you logged in as an administrator?
0
 
bytetracerCommented:
OK. As I see from your screenshot, whatever it is, it is not a shortcut. It can be either a folder or something that is using a folder icon to represent itself.
What happens when you try to open it?
Did you check for hidden and/or system files in it (if it is a folder)?
First, you should answer btdownloads7 questions, so we have enough info to help you.
0
 
David Johnson, CD, MVPOwnerCommented:
is this folder located in c:\users\public\desktop or c:\users\username\desktop ?
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
dockboy549Author Commented:
I believe to have indicated that there seems to be nothing in the folder,  Nothing happens when I double click it.  It does not open because there is nothing in it.  There is no path as there is nothing in the folder.
It appears in the long list of my computer and it's the last thing in the line.  There is nothing in it and it won't delete.  No messages about having administrator privilidges or anything else.  This little ole laptop is administered, and used by me and used by my wife.  I failed to mention the folder was somehow associated with the process of install a Linksys by Cicso Wireless N router Model WRT120N about a year ago.  I just ignored said "Ghost" folder for all this time.  What happened was I tried to install the Linksys/Cisco software on the Windows 7 Laptop as this was going to be the only wireless, as the other 2 PC's would be hard wired to the router.  I don't need to access data or software on any of the other PC's in the house.  We the install didn't work on the Windows 7 machine.  So after "beating my head against the keyboard" for hours I thought I might as well install the routher software on one of my XP Desktop PC.  Prest-o-Change-o immediately upon install of the Cisco Solftware I had conectivity.  All 3 PC's  (1 Win7 Laptop, 2 Desktop XP PC's. up and running.  OH! and most importantly the "Ghost" folder appeared.  I can't remember where it came from.  (But of course I can't remember what I had for breakfast).  Between this and my orginal question and info this is all I know.  If important my Win7 is Home Premium, about the bottom of the line.
0
 
btdownloads7Commented:
OK, a couple of things -- if the folder was empty (and was actually a folder), it would open when you double-clicked on it and show you that it's empty. That's where you would see a path in the taskbar. So from what you've said, this is NOT a folder, or it used to be one and is not corrupted on the filesystem. It seems to be just a desktop item that was added by some software (possibly Linksys), and somehow got "stranded". There are only a couple of things that you can do:

1. If only have one admin user on your system, create another one
2. Restart your PC in Safe Mode, and log in as the second amin user
3. Pull up the original user's desktop in Windows Explorer (probably in c:\users\username\desktop)
4. see if the non-deletable item is there, and try to delete it
5. If it won't let you delete it run Scandisk on your C: drive (it'll tell you that is has to restart and do it at boot-up

If none of the above resolves it, let me know, and there is one last thing I'll have you try
0
 
dockboy549Author Commented:
btdownloads7:
Did what you advised to no avail.  I got a new administrator account set up (Surprised Myself).  Restarted in Safe Mode.  But forgot half what you had written.  So restarted in Safe Mode with Networking and that worked so I could refer to your instructions.  Results: Ghost folder only appears on the desktop.  Scandisk doesn't seem to be a part of Win 7 as I did a search.  So looks like we're down to the "one last thing"
0
 
Dave4125Commented:
It looks like the folder is named with a space. A name that under normal conditions you can't name a folder in Windows. The easiest solution is to delete it through the Command Prompt. Open the Start Menu and type cmd and press [Enter]. Type in RMDIR "\\?\C:\Users\<username>\Desktop\ ".
0
 
dockboy549Author Commented:
Dave4125:
Couldn't get your string to work.  Kept getting "can't find file" messages and "can't find path" messages.  I probably need some real hand holding on this dealy.  I got started is this PC stuff in the 80's and learned to deal with DOS commands but not perfectly and it's been a lot of years and I'm a mature (old) retired guy...
0
 
btdownloads7Commented:
wow, wait a minute -- you logged in as a different user, and the folder was still on the desktop? If so, it's not in that user's desktop, but on the common desktop. That folder shoudl be under c:\users\public\desktop. Try going there using Windows Explorer and see if it's there and try to delete it. Scandisk is a part of Win7, but sorry, i forgot that you can't run in from the start menu. You have to go open Computer, right-click on the C drive, go to Properties, then go to the Tools tab, and click "Check Now". Check the box for it to do the recovery of bad sectors, and let it run. It will probably take a couple of hours.
0
 
Dave4125Commented:
Oh, it's in the Public folder. Try this command instead, RMDIR "\\?\C:\Users\Public\Desktop\ ".
0
 
Russell_VenableCommented:
Save this as a cmd file and place it in c:\ directory, open command prompt, enter temp.cmd <name of folder> Example: temp.cmd tempfolder temp.cmd This will change directory to your Public desktop and delete the folder.
0
 
dockboy549Author Commented:
I'm going to wrap this up.  Nothing seems work,  especially since I don't understand exactly what to do on the ones where typing a command line at the prompt.  Everyones input is appreciated.
0
 
dockboy549Author Commented:
From day one of this probblem which was several months ago, I thought this problem must be a Registry problem.  But no one mentioned it so it must not be part of the issue.
0
 
Russell_VenableCommented:
Hmm I wish there was a interaction option here then atleast you could talk live. You know what I mean? I am pretty sure this is a easily solved problem.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

  • 5
  • 3
  • 2
  • +3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now