Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3400
  • Last Modified:

How to disable IPv6 Autoconfiguration ?

Specifically my question relates to Windows Core, so please provide a command line, not GUI answer.

As you can see on the obfuscated output below, I have configured a static address, but "Autoconfiguration" is still showing as "Yes" and the host still has DHCP IDs.

For security reasons I want to disable autoconfiguration, and preferably remove DHCP settings too.





C:\Users\Administrator>ipconfig /all
Ethernet adapter Local Area Connection 6:
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : NIC1
   Physical Address. . . . . . . . . : 00-26-55-ff-ff-ff
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : ffff:ffff:f:f::f(Preferred)
   Link-local IPv6 Address . . . . . : fe80::cd60:ffff:ffff:ffff%371(Preferred)

   IPv4 Address. . . . . . . . . . . : 10.0.0.16(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.224
   Default Gateway . . . . . . . . . : 10.0.0.0
   DHCPv6 IAID . . . . . . . . . . . : 1979xxxxxx
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-ff-ff-ff-00-26-55-ff-ff-ff

   DNS Servers . . . . . . . . . . . : ffff:ffff:f:f::f
                                       10.0.0.15
   NetBIOS over Tcpip. . . . . . . . : Enabled

Open in new window

0
TwentyFourSeven
Asked:
TwentyFourSeven
  • 2
2 Solutions
 
BxozCommented:
c:\>reg add hklm\system\currentcontrolset\services\tcpip6\parameters /v DisabledComponents /t REG_DWORD /d 255

Open in new window


http://geekswithblogs.net/cajunmcse/archive/2010/02/05/quick-way-to-disable-ipv6-in-windows-2008-server.aspx
0
 
TwentyFourSevenAuthor Commented:
riiiiight....  <bashing head against keyboard>

DID YOU EVEN READ THE BODY OF THE QUESTION ?  DID YOU LOOK AT THE IPCONFIG OUTPUT ?

Sorry for the all-caps but it really annoys me when people rush in thinking they'll grab 500 points for an answer when they haven't bothered to even read the question.  It happens all to frequently on Experts Exchange these days.

I said in my question I configured a static address.  The ipconfig output shows static addresses for both IPv4 and IPv6.

All I want to do is set "Autoconfiguration Enabled" to No.  And get rid of the DHCPv6 IAID rubbish.

0
 
BxozCommented:
Ok, it's seems you have to create a key

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Value name: IPAutoconfigurationEnabled
Value type: REG_DWORD
Value in hexadecimal: 0 (A value of 0 disables APIPA support on this computer)

http://support.microsoft.com/default.aspx?scid=kb;EN-US;244268
http://www.itechtalk.com/thread1822.html
0

Featured Post

Prep for the ITIL® Foundation Certification Exam

December’s Course of the Month is now available! Enroll to learn ITIL® Foundation best practices for delivering IT services effectively and efficiently.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now