Solved

Wireless on Apple iMac

Posted on 2011-02-20
13
1,513 Views
Last Modified: 2012-05-11
I have an Apple iBook and newly purchased Apple iMac, however, the Wi-Fi signal bandwidth on the iMac is consistently and considerably less on the iMac versus the iBook laptop. I have moved the iMac around to different areas of the house to see if the bandwidth reception would change or increase, but no dice. I can move the iBook to the same areas of the house and the bandwidth is consistently better. I have even placed the iBook next to the iMac. The iBook Wi-Fi bandwidth is fantastic while the iMac's bandwidth crawls. The ISP is pointing to Apple as having the problem and Apple is pointing to the ISP. If the bandwidth is consistently performing at the same level throughout the house for both devices, I suspect it is a wireless card setting on the iMac that needs tweaking. I have run speed tests on both devices and the iBook is consistently 10 to 12 times faster than the iMac. How and where can I tweak the setting on the iMac’s Wi-Fi card to increase it's bandwidth reception?
0
Comment
Question by:BleedBurntOrange
  • 7
  • 3
  • 2
  • +1
13 Comments
 
LVL 11

Expert Comment

by:mccrick
ID: 34938510
It could easily be a hardware issue with the iMac such as bad card or disconnected antenna

That said, I recommend going through all relevant Mac fixes. Zap PRAM. Safe Boot. Repair Permissions, etc.

Also look for settings that you can change in your router, particular the channel. You can also change protocols such as turning or "N" and only running at "G" speeds. You might want to take your iMac to a neighbor's or other hotspot to see if the problem follows you or stays home with the router.

The funky things with Routers is assuming that the router is set up properly and working well just because it works with a handful of computers. I would try setting router to factory defaults, then changing channels, turning off security (while testing) and reducing the speed.
0
 

Author Comment

by:BleedBurntOrange
ID: 34938777
Mccrick - all good suggestions.  I did not mention that this iMac was exchanged for another iMac that was exhibting the same issue. Wouldn't a diconnnected antenna not allow for any wi-fi connectivity? The iMac can conenct, but at a very low speed. In addition, Apple TechSupport has been engaged. They are dumb-founded by the issue. Another paculiarity, unlike a typical WAP, the bandwidth is not split evenly with the users. The iBook seems to rob bandwidth from the iMac. The bandwidth is not evenly shared between the two devices.

I'll report my findings.
0
 
LVL 11

Expert Comment

by:mccrick
ID: 34939001
a disconnected antenna can cause the described symptom, but I don't think that is your problem. If you want to go down to OfficeMax or wherever, you can have this problem solved in about $40. Get another router.

A more prudent and more technical answer would be to see if you can flash the ROM on your router (firmware upgrade).
0
 
LVL 32

Expert Comment

by:nappy_d
ID: 34939168
What is the wireless router in use?

I know had that issue where wireless traffic was not being equally distributed between all devices.

I change my router firmware to DD-WRT and enabled QOS. Once I did this, all machines were able to get excellent speeds.
0
 

Author Comment

by:BleedBurntOrange
ID: 34939835
The wireless router is from the ISP, Verizon FIOS. I am hoping it can be fixed with QOS. But the router webpage GUI is not allowing me to input the password. I'll follow up.
0
 
LVL 11

Expert Comment

by:mccrick
ID: 34939999
some routers have compatibility issues with macs. Try Firefox or if you know someone with a PC laptop, you might get in that way. I haven't seen the mac compatibility issue in awhile, but it might help.
0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:BleedBurntOrange
ID: 34940846
Mccrick - I tried access to the router via a windows laptop using IE8; no bueno. The same issue manifested itself as it did on the iMac. I was able to verify that the Airport card on both the MacBook Pro and the iMac had the exact same settings. Speedtest after speedtest garnished the same results. The XP laptop I was using as well had better results/bandwidth access than the iMac. Verizon had us change the encryption from WEP to WPA-Personal to try and resolve, but that should not have made a difference. Verizon was hesitant to acknowledge that Qos would resolve the issue. So, we are still trying.
0
 
LVL 32

Expert Comment

by:nappy_d
ID: 34942356
So which ever computer is the FIRST to connect wirelessly gets the best bandwidth?  It that correct?

IF that is the case, QOS is most likley the fix.

Also, what about connecting to a LAN port on the FIOS device? I assume all works normally there, correct?
0
 

Author Comment

by:BleedBurntOrange
ID: 34983951
It doesn't matter if the laptop is the first or third device to connect. I tried with my netnook and I had very good speedtest results even with the Mac Book Pro conencted. If the iMac conencts to a LAN connection on the back of the FIOS router, the speed is 25MB. He ended up connecting an Airport Extreme for Wi-Fi versus using the Wi-Fi from the FIOS router. I have not followed up with the user since Tuesday. Will get feedback to and follow up.
0
 

Author Comment

by:BleedBurntOrange
ID: 35028934
The issue was resoved by disabling the Wi-Fi of the FIOS router and connecting an Apple Airport Extreme. Access jumpled to 25MB from 2 MB.
0
 
LVL 19

Expert Comment

by:Kash
ID: 35068030
out of equation, are the Macs fully up to date with all software updates and firmware updates?
0
 

Accepted Solution

by:
BleedBurntOrange earned 0 total points
ID: 35174311
I was unable to determine the root cause of why the Wi-Fi from the ISP FIOS router would give preference to a laptop connection over the desktop connection regardless of where they were located in the house. Since the iMac was fresh out of the box, I do not know what updates it would have required or how to get them done. However, since the addition of the air port extreme did not negatively impact the Mac Book Pro’s bandwidth connectivity; and,  allowed the iMac to connect at the same or better connection rate as the laptop, the users consider the matter resolved and closed. Unfortunately, none of the recommendations posted helped to resolve the issue.
0
 

Author Closing Comment

by:BleedBurntOrange
ID: 35205146
none of the recommedations helped to determine the root cause or solve the problem.
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

For Sennheiser, comfort, quality and security are high priority areas. This paper addresses the security of Bluetooth technology and the supplementary security that Sennheiser’s Contact Center and Office (CC&O) headsets provide.  
DECT technology has become a popular standard for wireless voice communication. DECT devices are not likely to be affected by other electronic devices and signals because they operate in a separate frequency-band.
This Micro Tutorial will show you how to maximize your wireless card to its maximum capability. This will be demonstrated using Intel(R) Centrino(R) Wireless-N 2230 wireless card on Windows 8 operating system.
Viewers will learn how to connect to a wireless network using the network security key. They will also learn how to access the IP address and DNS server for connections that must be done manually. After setting up a router, find the network security…

744 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now