DNS Listen Address

We recently transitioned to a new 2008 R2 Enterprise PDC with Exchange 2010 Enterprise.  The server is an HP Proiant ML370 G6 Server with a Qlogic Quad Port Multifunction Gigabit Server Adapter.  I have disabled two ports.  I am using one port to authenticate VPNs using Routing and Remote Access.  The other port is the primary port for everything else.

When I reboot the server, I find that the primary NICs address is not listed on DNS's Interface listing of addresses, and the seconday NIC's address is listed as Listen only on the following addresses.

1.  Why would the primary NICs address be skipped over on the DNS Interface?
2.  Why would the secondary NIC be listed.  It is not even listed to be Registered in DNS.

I have used the following command to define the Listening port:
dnscmd Srv1d.DomainName.com /ResetListenAddresses 10.0.0.41
but with the same results.

As a bit more background, I only want the primary NICs address to be listed in DNS, otherwise some our our office's SQL Srvr applications will not work if there are two addresses listed for the computer name.

Any help would be appreciated.
Everytime
ArchitectChuckAsked:
Who is Participating?
 
ArchitectChuckConnect With a Mentor Author Commented:
I am going to try using Task Scheduler to run the following command in a batch file 5 minutes after a server startup/reboot:

dnscmd Srv1d.DomainName.com /ResetListenAddresses 10.0.0.41

This is what I am doing now manually and it is working.  DNS, Routing and Remote Access are playing together nicely and only one address is showing up in the Forward Lookup Zone.

Let me know if you have any other suggestions.

Thanks everyone!!
0
 
Netman66Commented:
Make sure that primary NIC is at the top of the binding order or the service won't bind to it and therefore won't use it to listen on.

Once the binding order is correct, set it again from the DNS console.

0
 
ArchitectChuckAuthor Commented:
Where do I verify the binding order?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
brwwigginsIT ManagerCommented:
I would double check the binding order of your NICs and make sure the "primary" one you use for server communication is at the top of the list. Then double check your DNS

Start -> Control panel
under “Network and Internet” click “View network status and tasks”
On right click “Change adapter settings”
Tab ALT so menu bar appears then: Advanced -> Advanced Settings.
0
 
ArchitectChuckAuthor Commented:
The binding order appears to be correct.  It also allows me to control the bindings for each connec tion.

For my primary NIC, File and Printer Sharing for Microsoft Networks IPv4 is first
Cient for Microsfot Networks IPv4 is Second.

IPv6 is not selected in eaither case and is not selected on any NIC on the server.

On the secondary NIC the priority level is the same but could be changed.
0
 
ArchitectChuckAuthor Commented:
This is the confioguation of the 2nd NIC.  Should I consider unsellecting any of these options since it is only servicing Routing and Remote Access?
NIC-2.jpg
0
 
Netman66Commented:
Don't need to worry about what you have there for the second nic.

Can you post an IPCONFIG /all please?
0
 
ArchitectChuckAuthor Commented:

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Srv1d
   Primary Dns Suffix  . . . . . . . : DomainName.com
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : Yes
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : DomainName.com

PPP adapter RAS (Dial In) Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : RAS (Dial In) Interface
   Physical Address. . . . . . . . . :
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 10.0.0.15(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.255
   Default Gateway . . . . . . . . . :
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter #3
   Physical Address. . . . . . . . . : 1C-C1-DE-74-92-48
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 10.0.0.41(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 10.0.0.1
   DNS Servers . . . . . . . . . . . : 10.0.0.41
                                       10.0.0.36
   NetBIOS over Tcpip. . . . . . . . : Disabled

Ethernet adapter Local Area Connection 2:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : HP NC375i Integrated Quad Port Multifunction Gigabit Server Adapter #4
   Physical Address. . . . . . . . . : 1C-C1-DE-74-92-49
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 10.0.0.42(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :
   DNS Servers . . . . . . . . . . . : 10.0.0.41
   NetBIOS over Tcpip. . . . . . . . : Disabled
0
 
ArchitectChuckAuthor Commented:
FYI:  10.0.0.36 is our old 2003 server that remains at DC.

Where does the (Preferred) come from on all of the Interfaces?
0
 
Netman66Commented:
It's using that IPv4 rather than the IPv6 stack.  It's normal.

If NIC 3 is at the top of the binding order and you have set that as the listening interface, then it should stick.

I would remove the DNS address from NIC 4 and also ensure it doesn't register in DNS.  Delete any record in DNS that is attached to that IP address.

Other than that, I can't think of anything else that would break that setup.

0
 
ArchitectChuckAuthor Commented:
I have done as you suggested, and that does work.  The probelm is that at that point in time, I cannot use VPN.  When I reactivate NIC 4 to allow Routing and Remote access to work, I start having the same problem.

I did remove the DNS address from NIC 4.  When I did that, it told me it would use the local address by default.  I was concerned that it was using 10.0.0.42, the address of that NIC instead of NIC 3.


What problem would be created if I removed DNS server from this server and then reinstalled it.  The problem first occured when I tried to setup IPv6.  I stripped all of that out, but there may be some legacy stuff creating the problem.
0
 
Netman66Commented:
If your old DNS server is still around and you point everything to that server, probably no issue, however I don't think that will solve the problem.

Since you're using RRAS then it's possible it needs to listen on that interface.  Is there no other option to select listen on both nics?
0
 
Hypercat (Deb)Commented:
Here's an old article I used to use when I had RRAS and DNS on the same server under Windows 2003 server. Not sure if it still applies to Windows 2008, but I would think it would be similar. Take a look:

http://support.microsoft.com/kb/292822/en-us
0
 
ArchitectChuckAuthor Commented:
The solution is a good workaround, but doesn't establish why 2008 R2 is resetting the listening address during a reboot.

Thanks to everyone that offered help!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.