?
Solved

Speed on Wireless N Connection

Posted on 2011-02-20
17
Medium Priority
?
935 Views
Last Modified: 2012-05-11
Hello,

I am using TP-link TL-WR1043ND wireless N gigabit router.  When I made wireless connection on my Dell Latitude E4300 laptop (with Intel WiFi Link 5100 adapter, using WPA2-PSK),  it can only connect at 130MB.  It doesn't seems trying to connect at 300MB.  I checked on the router, the max transfer rate was already set to 300MB.  Is there any additional setting required?

Many thanks.
0
Comment
Question by:ICKW
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 4
  • 2
  • +4
17 Comments
 
LVL 12

Accepted Solution

by:
enachemc earned 224 total points
ID: 34940953
connection speed is highly dependent on the signal strength and quality
0
 

Author Comment

by:ICKW
ID: 34940975
I just tested it beside the router though.  The signal should be strong though.
0
 
LVL 20

Assisted Solution

by:woolnoir
woolnoir earned 224 total points
ID: 34941084
Do you have any other WIFI networks in range ? the 300mbps bandwidth relies on having 2 receive channels to provide the 300mbps... if you're contending for the frequency space that may explain the issues you are receiving.

Have you tried changing the channel setting on the router ?
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Author Comment

by:ICKW
ID: 34941099
I can see it only ask for 1 channel on the router, how to set 2 channels?

Thanks.
0
 
LVL 3

Assisted Solution

by:Jordanlcn
Jordanlcn earned 224 total points
ID: 34941895
As woolnoir said it requires 2 receive channels.  That you cannot set/configure. The N Setting of the router should be doing that automatically.  What woolnoir is saying is that there might be another wireless source/network in range of your area and is contending with the frequency.  Since most wireless runs on the same frequency routers uses a unique channel id to separate itself from the rest.

Just try changing the channel of your router from 1 to whatever if it increases bandwidth.  If not report back and lets try something else.  If it does please see note below.


NOTE: If this helps please credit woolnoir with the solution.
0
 

Author Comment

by:ICKW
ID: 34943885
Yah.. I tried different channels though... it sometimes even worst.. and only connect for 54MB.
Getting exhausted....

0
 
LVL 1

Assisted Solution

by:cicloide
cicloide earned 220 total points
ID: 34944346
Intel talks about OS limitations too "Up to 2X greater range enabled by 1x2 Draft-N implementations with 1 transmit spatial stream and 2 receive spatial streams. Up to 5X Bandwidth increase based on the theoretical maximum receive bandwidth enabled by 1x2       
Draft-N implementations with 1 transmit spatial stream and 2 receive spatial streams. Actual wireless throughput and/or range will vary depending on your specific operating system, hardware and software       
configurations. Check with your PC manufacturer for details."
In the other hand, it looks like you need 3 clear channels to do that. That means pretty much the whole 2.4G band for yourself. If there is any interference in the air that band is likely to be discarded and the 300Mb connection aborted to switch to a lower speed.
0
 
LVL 24

Expert Comment

by:rfc1180
ID: 34945528
You are more than likely not using 40Mhz channels, which is required for a 300Mbps connection:

http://www.intel.com/support/wireless/wlan/sb/cs-025393.htm

Check the "Fat Channel Intolerant" if you not already.

Fat Channel Intolerant
This setting communicates to surrounding networks that this Wi-Fi adapter is not tolerant of 40MHz channels in the 2.4GHz band. The default setting is for this to be disabled (turned off) so that the adapter does not send this notification.

Billy
0
 
LVL 13

Assisted Solution

by:kdearing
kdearing earned 440 total points
ID: 34947444
Using 40MHz channels in the 2.4GHz range would require using 9 of the 11 available channels (in the US).

The chances of all those frequqncies being clear of interference and other wifi? Pretty slim.

And don't forget the overhead. The troughput you see is typically 1/2 of the raw throughput.
0
 
LVL 1

Expert Comment

by:cicloide
ID: 34947560
Remember that the channels overlap. If I am right, you can get up to 3 channels with minimum overlap in the 2.4GHz band. That is why I think you would require a clear spectrum to reach the use of 3 channels simultaneously.
0
 
LVL 24

Assisted Solution

by:rfc1180
rfc1180 earned 668 total points
ID: 34947890
>would require a clear spectrum to reach the use of 3 channels simultaneously.
in aspects to 802.1g and 802.11n 20Mhz (150Mbps), but not with 40Mhz. His concern is getting the full 300Mbps throughput which requires at least 40Mhz channel spacing which is what kdearing has pointed out.

Billy
0
 

Author Comment

by:ICKW
ID: 34948474
I tried to change it to 40MHz on the router though.... However, it's still the same.......
Is there any specific setting required on the Intel WiFi 5100 adapter?  I checked the spec and it should support up to 300MB though.....

Thanks all for the input.
0
 
LVL 13

Assisted Solution

by:kdearing
kdearing earned 440 total points
ID: 34948559
As we've said, given the overhead and the inevitable existence of interference and other wifi signals...
You seeing 130Mbps throughput is pretty good.

Unless you live out in the middle of nowhere (no other 2.4GHz signals), I doubt you'll get any better.
0
 

Author Comment

by:ICKW
ID: 34948666
I'm not sure what the real throughput is though..... I just see the wireless connection status and it shows 120MB - 130MB.  Also, this is my first time using N.  I want to know whether I'm really connecting the 300MB or 150MB though...
0
 
LVL 24

Assisted Solution

by:rfc1180
rfc1180 earned 668 total points
ID: 34948807
> I want to know whether I'm really connecting the 300MB or 150MB though...
If it shows 150Mbps, then you are connected at 300Mbps, the task manager network properties or other properties are going to only indicate full duplex speed and not aggregate.

Billy

0
 

Author Comment

by:ICKW
ID: 34949342
How can I test the aggregate speed?
0
 
LVL 24

Assisted Solution

by:rfc1180
rfc1180 earned 668 total points
ID: 34953129
set up 2 wireless hosts, download jperf and setup on as a server and the other as a client and test using UDP.

http://sourceforge.net/projects/jperf/

Billy
0

Featured Post

Will your db performance match your db growth?

In Percona’s white paper “Performance at Scale: Keeping Your Database on Its Toes,” we take a high-level approach to what you need to think about when planning for database scalability.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
The Summer 2017 Scholarship Winners have been announced!
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this video we outline the Physical Segments view of NetCrunch network monitor. By following this brief how-to video, you will be able to learn how NetCrunch visualizes your network, how granular is the information collected, as well as where to f…
Suggested Courses

765 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question