554 SMTP Sync error

Hi there

I am battling to send mail to one specific domain.

if i try to telnet to the MX records ip and do the normal helo, mail from etc, i get the 554 SMPT sync error. (if i run the full command and dont wait for the returns from the recipient server.

if i send just the telnet xxx.xxx.xxx.xxx 25 command, and then wait till i get the response it goes further, but when i send the helo, it gives me:
---------------
220 spool.XXXXXX.com ESMTP Exim 4.69 Mon, 21 Feb 2011 09:57:36 +0200
"helo
501 Syntactically invalid HELO argument(s)"
----------------

any ideas? it seems this is the only domain that is giving me this problem?

kingaltonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bevhostCommented:
Some servers will get upset if you don't wait for each response before sending the next command
eg: in postfix see http://www.postfix.org/postconf.5.html#reject_unauth_pipelining

The HELO (or EHLO) command must be followed by a FQDN hostname.
eg
HELO myserver.mydomain.com
0
bevhostCommented:
Are you using cpanel?
0
PsiCopCommented:
What exactly do you send at the HELO banner?

You should wait for the system's HELO banner. Why aren't you?

A standard anti-SPAM tactic is to automatically consider any pre-greeting traffic as the hallmark of a spammer. Ordinary senders shouldn't have any problem waiting to see the greeting before sending their own HELO.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

kingaltonAuthor Commented:
I am just using the telnet commands to test why our trend IMSS server is not getting mails through to he domain, the IMSS server should be sending the correct info out, with the correct SMTP "strings".

but i cannot get mail through to this domain.

the ip i am trying to send to is: 192.96.88.150
0
nociSoftware EngineerCommented:
The site in question actualy validates if the site mentioned AFTER the helo is the address it receives mail from....

And it will tarpit your connection if you exceed it's rules.
These are all anti spam methods. And they are easy to implement on exim...

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gheistCommented:
exim can process smtp commands in all-smalls and otherwise hand-typed.
but once it detects sync error it simply disregards the rest.

if you use some software script that talks SMTP - it is better to use it against your own mail server and let your mail server software talk to the internet.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.