Solved

Cisco ASA 5505 VPN user can not connect the Internet

Posted on 2011-02-21
9
579 Views
Last Modified: 2012-05-11
Hi,
I configure a vpn on my ASA 5505 i can connect to the local network but when i am connect by vpn i can not anymore browse the Internet

I give you my configuration

Can someone help my

Thanks

AXel
: Saved
:
ASA Version 7.2(4) 
!
hostname cyFW
domain-name company.be
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.21.10 cysnt101
name 192.168.21.30 Ricoh
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.21.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.254.3 255.255.255.0 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp setroute 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 195.238.2.21
 name-server 195.238.2.22
 domain-name company.be
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any 
access-list outside_access_in extended permit icmp any any time-exceeded 
access-list outside_access_in extended permit icmp any any unreachable 
access-list outside_access_in extended permit icmp any any echo-reply 
access-list outside_access_in extended permit tcp any interface outside eq ftp 
access-list outside_access_in extended permit tcp any interface outside eq ftp-data 
access-list outside_access_in extended permit ip any interface outside 
access-list inside_out extended permit icmp any any 
access-list inside_out extended permit ip any any 
access-list inside_nat0_outbound extended permit ip any 192.168.21.192 255.255.255.192 
access-list inbound_on_inside extended permit ip any any 
pager lines 24
logging enable
logging asdm informational
logging mail emergencies
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool cyVPN 192.168.21.200-192.168.21.249 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ftp cysnt101 ftp netmask 255.255.255.255 
static (inside,outside) tcp interface ftp-data cysnt101 ftp-data netmask 255.255.255.255 
access-group inbound_on_inside in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.254.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.21.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 60 set pfs group1
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

group-policy cyvpn internal
group-policy cyvpn attributes
 dns-server value 192.168.21.10
 vpn-tunnel-protocol IPSec 
 default-domain value cy.local
username user password D75KIduQxaMjRVSR encrypted
username user attributes
 vpn-group-policy popvpn
tunnel-group cyvpn type ipsec-ra
tunnel-group cyvpn general-attributes
 address-pool cyVPN
 default-group-policy cyvpn
tunnel-group cyvpn ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect icmp 
  inspect ftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:42e2979f3abfc5fdfe9645b9f8180d06
: end
asdm image disk0:/asdm-524.bin
asdm location cysnt101 255.255.255.255 inside
asdm location Ricoh 255.255.255.255 inside
no asdm history enable

Open in new window

0
Comment
Question by:ap-technology
  • 5
  • 3
9 Comments
 
LVL 35

Accepted Solution

by:
Ernie Beek earned 334 total points
ID: 34942334
You'll need to add split tunneling:

access-list Split_Tunnel_List standard permit 192.168.21.0 255.255.255.0
group-policy cyvpn  attributes
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split_Tunnel_List
tunnel-group cyvpn  general-attributes
default-group-policy cyvpn
exit


That should do the trick.
0
 

Author Comment

by:ap-technology
ID: 34942382
Thanks it seems to be ok
I have a otgher question
When i am connect by vpn i can not ping and connect on the LAN Default gateWay
the ip is 192.168.21.x

Thanks for your help
0
 
LVL 34

Assisted Solution

by:Istvan Kalmar
Istvan Kalmar earned 166 total points
ID: 34942384
and you need to change the pool:

no ip local pool cyVPN 192.168.21.200-192.168.21.249 mask 255.255.255.0
ip local pool cyVPN 192.168.22.200-192.168.22.249 mask 255.255.255.0

and the nonat :
no access-list inside_nat0_outbound extended permit ip any 192.168.21.192 255.255.255.192
access-list inside_nat0_outbound extended permit ip any 192.168.21.192 255.255.255.192

clear xlate



0
 

Author Comment

by:ap-technology
ID: 34942469
I put the new configuration

With that configuration
I can browsed the Intenet
I can not ping a lan IP
i can not access to the Lan default Gateway

The Lan Range is : 192.168.21.x
When i connect by VPN i recieve the IP : 192.168.21.200

Thanks for your help

Axel


: Saved
:
ASA Version 7.2(4) 
!
hostname CYFW
domain-name company.be
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.21.10 cysnt101
name 192.168.21.30 Ricoh
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.21.254 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.254.3 255.255.255.0 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address dhcp setroute 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
 name-server 195.238.2.21
 name-server 195.238.2.22
 domain-name company.be
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list outside_access_in extended permit icmp any any 
access-list outside_access_in extended permit icmp any any time-exceeded 
access-list outside_access_in extended permit icmp any any unreachable 
access-list outside_access_in extended permit icmp any any echo-reply 
access-list outside_access_in extended permit tcp any interface outside eq ftp 
access-list outside_access_in extended permit tcp any interface outside eq ftp-data 
access-list outside_access_in extended permit ip any interface outside 
access-list inside_out extended permit icmp any any 
access-list inside_out extended permit ip any any 
access-list inside_nat0_outbound extended permit ip any 192.168.21.192 255.255.255.192 
access-list inbound_on_inside extended permit ip any any 
access-list Split_Tunnel_List standard permit 192.168.21.0 255.255.255.0 
pager lines 24
logging enable
logging asdm informational
logging mail emergencies
mtu inside 1500
mtu outside 1500
mtu dmz 1500
ip local pool CYVPN 192.168.21.200-192.168.21.249 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
asdm image disk0:/asdm-524.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface ftp cysnt101 ftp netmask 255.255.255.255 
static (inside,outside) tcp interface ftp-data cysnt101 ftp-data netmask 255.255.255.255 
access-group inbound_on_inside in interface inside
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 192.168.254.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
http server enable
http 192.168.21.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac 
crypto dynamic-map outside_dyn_map 20 set pfs group1
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 40 set pfs group1
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-SHA
crypto dynamic-map outside_dyn_map 60 set pfs group1
crypto dynamic-map outside_dyn_map 60 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!

group-policy cyvpn internal
group-policy cyvpn attributes
 dns-server value 192.168.21.10
 vpn-tunnel-protocol IPSec 
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value Split_Tunnel_List
 default-domain value cy-cpb.local
username tdoig password D75KIduQxaMjRVSR encrypted
username tdoig attributes
 vpn-group-policy cyvpn
username pdamseaux password d6cSxp3bFIukC/d5 encrypted
username pdamseaux attributes
 vpn-group-policy cyvpn
username fsiweb password S6y1QMbaDtEQbRfV encrypted privilege 0
username fsiweb attributes
 vpn-group-policy cyvpn
username eseynaeve password pRFja5h19qegHsJf encrypted
username eseynaeve attributes
 vpn-group-policy cyvpn
username jmorent password g/C80Y58Cx0FBE7m encrypted
username jmorent attributes
 vpn-group-policy cyvpn
username tslegers password 81Here7lwN1wIF3U encrypted
username tslegers attributes
 vpn-group-policy cyvpn
username lfain password d4ruMzVfKYR.pZWJ encrypted
username lfain attributes
 vpn-group-policy cyvpn
username oborlee password RNuIMAMcS/GyHsRL encrypted
username oborlee attributes
 vpn-group-policy cyvpn
tunnel-group cyvpn type ipsec-ra
tunnel-group cyvpn general-attributes
 address-pool CYVPN
 default-group-policy cyvpn
tunnel-group cyvpn ipsec-attributes
 pre-shared-key *
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect icmp 
  inspect ftp 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:42e2979f3abfc5fdfe9645b9f8180d06
: end
asdm image disk0:/asdm-524.bin
asdm location cysnt101 255.255.255.255 inside
asdm location Ricoh 255.255.255.255 inside
no asdm history enable

Open in new window

0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 

Author Comment

by:ap-technology
ID: 34942511
i add the following commande

nat (inside) 0 access-list inside_nat0_outbound

Open in new window


And now the vpn user can ping the lan address

But i can not ping the Lan Gateway 192.168.21.254

Thanks

Axel
0
 
LVL 35

Assisted Solution

by:Ernie Beek
Ernie Beek earned 334 total points
ID: 34942582
Try: management-access inside
0
 

Author Comment

by:ap-technology
ID: 34943059
Hi,

Thanks for all your help,

All my quesion are solved.
0
 
LVL 35

Expert Comment

by:Ernie Beek
ID: 34943074
You're welcome, glad we could help.
0
 

Author Closing Comment

by:ap-technology
ID: 34943143
Thanks
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Join & Write a Comment

This is an article about my experiences with remote access to my clients (so that I may serve them) and eventually to my home office system via Radmin Remote Control. I have been using remote access for over 10 years and have been improving my metho…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

747 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now