Solved

Remote Desktop not working with XP machines, but does with Win7

Posted on 2011-02-21
6
745 Views
Last Modified: 2012-05-11
I have a network running with an SBS2008 box.  The local ISP has installed a VPN connection (Juniper router).  You log in over the Internet, click "Start Network" and withina few seconds, a VPN connection is secured.

At this point you can be at home and run Remote Desktop Connection and put in the IP address of the machine back at the office.  

Could be a coincidence, but right now, if the machine at the office is running Windows & Pro, the Remote Desktop connection works.  If the machine is running Windows XP Pro, Remote Desktop fails to find the machine.

Yet, Remote Desktop works from any machine to machine from within the LAN.  Remote Desktop Connection is enabled as a firewall exception (as a group policy) on all machines.

Anyone ever heard of RD problems where Win 7 machines can be connected to but not Win XP?

How would I troubleshoot this?
0
Comment
Question by:DaveWWW
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
6 Comments
 
LVL 11

Expert Comment

by:dougaug
ID: 34943003
Maybe this is hapenning because windows xp remote desktop client version is older than windows 7. Try to set the option in your server where it allows connections from older versions of remote desktop client.
0
 
LVL 59

Expert Comment

by:Darius Ghassem
ID: 34943034
Try downloading RDP 7 for Windows XP then install on XP client

http://support.microsoft.com/kb/969084
0
 
LVL 11

Expert Comment

by:MichaelVH
ID: 34943039
as dougaug said; this is probably due to the security restriction (Network Level Authentication) for RDP-connections as from Server 2008.
What you could do is set the "Remote settings" to "Allow connections from computers running any version of Remote Desktop (Less Secure)".

Michael
0
PeopleSoft Has Never Been Easier

PeopleSoft Adoption Made Smooth & Simple!

On-The-Job Training Is made Intuitive & Easy With WalkMe's On-Screen Guidance Tool.  Claim Your Free WalkMe Account Now

 

Author Comment

by:DaveWWW
ID: 34945169
It looks like the default remote desktop settings in the XP Firewall settings are to allow traffic through Port 3389 on the local network only.  It appears that I need to select the option for "Any computer (including those on the Internet)", but it is greyed out, because it is set by group policy.  Where in the SBS 2008 group policy would I find this parameter?
0
 
LVL 59

Accepted Solution

by:
Darius Ghassem earned 500 total points
ID: 34945447
0
 

Author Comment

by:DaveWWW
ID: 34945645
Thanks - I set the policy to allow XP hosts to allow connections from any IP address (was set to LAN-only) and it worked.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I was prompted to write this article after the recent World-Wide Ransomware outbreak. For years now, System Administrators around the world have used the excuse of "Waiting a Bit" before applying Security Patch Updates. This type of reasoning to me …
After seeing many questions for JRNL_WRAP_ERROR for replication failure, I thought it would be useful to write this article.
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question