Solved

Sending emails with inline images using Outlook 2010.

Posted on 2011-02-21
5
1,172 Views
Last Modified: 2012-05-11
Hello all,

I am facing an issue with my application. I can't send emails with inline images using Outlook 2010.
I have upgraded my Office 2007 to Office 2010 two weeks before. The application was working fine with office 2007 and 2003. The issue started from the Office 2010 installation.

I was using the MAPI Session object to upload the inline images with outlook 2007. But now I can't do that. Even the MAPI installation is not succeeding. It is telling that I have to keep Office 2007 to complete the installation. I had uninstalled the 2007 version.

Can anybody suggest me a way to implement this on outlook 2010?.


Thanks
0
Comment
Question by:gopalv
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 12

Expert Comment

by:Hairbrush
ID: 34943774
Looking at http://msdn.microsoft.com/en-gb/library/ee692174.aspx#OfficeOutlook2010ObjectModelChanges I don't think there are any breaking changes in Outlook 2010, so your code that ran fine in Outlook 2007 should run unaltered in 2010.

It sounds like there is a problem with your Office 2010 installation after your upgrade, and that is what is preventing your code from running.  Do you have a clean machine that you can try it on?  I would suggest that rather than trying to rewrite your code...
0
 

Author Comment

by:gopalv
ID: 34946794
Hi,
   Here are some additional details/clarifications.:

1. My code to generate emails that worked in outlook 2007 is working just fine on outlook 2010.
2. I used the MAPI component (CDO 1.2.1) avaialbel for outlook 2003 & 2007 only in instaces where there was an embedded image in the body of the email - http://www.microsoft.com/downloads/en/details.aspx?FamilyID=2714320d-c997-4de1-986f-24f081725d36&DisplayLang=en 

NOTE: embedded images work if I provide a public url i.e. http://someserver/image.jpg but the image I provide as a local path reference (c:\image.jpg) does not show correctly.

3. I am not able to install CDO 1.2.1 on my machine with Outlook 2010. it says its not supported - http://blogs.msdn.com/b/deva/archive/2010/01/19/outlook-2010-why-cdo-1-2-1-not-supported-with-outlook-2010.aspx
http://support.microsoft.com/kb/2028411

As a result, any emails with embedded images in them show up with a red x where the image should be placed and the image that should be embedded shows up as an attachment instead. See attached screenshot.

The image at teh beginnign of the email body is a local image and the image at the bottom of the body (that displays correctly) is an image from a public url.

Any feedback is appreciated.
embeddedimages-outlook2010issue.png
0
 

Accepted Solution

by:
gopalv earned 0 total points
ID: 35081607
This is working fine now.
Closing the question
0
 

Author Closing Comment

by:gopalv
ID: 35126169
Issue fixed myself
0
 

Expert Comment

by:DCTec
ID: 37553455
It would be nice if you explain how you fixed your problem for all people with the same problem.
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
Many of my clients call in with monstrous Gmail overloading issues with Outlook. A quick tip is to turn off the All Mail and Important folders from synching. Here is a quick video I made to show you how to turn off these and other folders in Gmail s…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question