• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 21078
  • Last Modified:

Juniper Network Connect Error: nc.windows.app.23787 - Cannot start the Network Connect service. Please re-install

I'm using a PC with Win 7 ultimate and when trying to connect to a Network Connect page, after Host Checker is executed, then that error happens.
What I've done so far

Clean cache, cookies, etc.
Clean uninstall and reinstall it
Deactivate Comodo FW and activate Win 7 FW
Try to restart service

You can find attached the Network Connect logs

I have a laptop with same OS and firewall (Comodo), and on the same network has no issues.

Any ideas?

Thanks

Walter
Network-Connect-6.5.0.zip
0
ISUY
Asked:
ISUY
  • 6
  • 3
  • 2
  • +1
1 Solution
 
deimarkCommented:
If I recall, that is a generic windows error and can apply to a few different reasons however, I have had a look at the Juniper KB and can see the following:


Summary:
When users try to launch Network Connect they get an error "cannot start the network connect service, please reinstall network connect" error nc.windows.app.23787

Problem or Goal:
This behavior can occur if the Network Connect service is disabled or if the service is disabled for the hardware profile that you are currently using.

Solution:
Try uninstalling Network Connect from computers add/remove programs and launch to see if it fixes the problem.
If the above does not help then try the following steps on the clients computer:
 

    Click Start, point to Programs, point to Administrative Tools, and then click Services.
    Double-click the service that did not start.
    Click the Log On tab.
    Verify that the service has not been disabled for the hardware profile that you are using. If it has, click Enable.
    Click the General tab. Verify that the service has not been disabled in the Startup Type box. If it has, click Automatic to have it start when you start the computer.

Re-establish Network Connect session.
0
 
ISUYAuthor Commented:
Hi all:

Can someone help me out?? :)

Thanks
0
 
deimarkCommented:
If the below does not help:

Click Start, point to Programs, point to Administrative Tools, and then click Services.
    Double-click the service that did not start.
    Click the Log On tab.
    Verify that the service has not been disabled for the hardware profile that you are using. If it has, click Enable.
    Click the General tab. Verify that the service has not been disabled in the Startup Type box. If it has, click Automatic to have it start when you start the computer.

Re-establish Network Connect session.


Then I would suggest raising a case with JTAC as the issue will be local that particular machine, perhaps hardware/software interactions.
0
Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

 
ISUYAuthor Commented:
Hi Deimark:

I thought I've replied back your first post. Sorry about that.

I've checked and service is on Automatic state, but do not get enabled.

Thanks
0
 
deimarkCommented:
Have you tried a windows reinstall?

If yes, then JTAC is the way ahead sadly as they will have a more detailed knowledge of the interactions of the hardware and software here.

Take note though, one of the 1st things they will ask you to do is likely to be reinstall windows.
0
 
ISUYAuthor Commented:
I will have to try.... but that will have a big impact... I'll see what I can do...
Thanks!

0
 
ISUYAuthor Commented:
please close this question
0
 
ISUYAuthor Commented:
may be
0
 
trivinCommented:
I lost several days about this problem.

The solution is, check your public folders.  I had the public folder, but it was empty, there was only one folder of juniper.
I fill it with the contents of a public folder of another computer.  And it works!  No need to reinstall.

0
 
ISUYAuthor Commented:
Hi

Where the Public folders are located?
0
 
trivinCommented:
in the users folder.
There should be, Public, Default, and your own profile.
When the public folder is empty, then it wont work.
0
 
Member_2_7969195Commented:
I have had the same problem, I have realized that Juniper Network Connect Service was not started, It was desabled, so I have gone to windows services on "services.msc" and I have made it abble, and it has solved my problem. =)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

  • 6
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now