Solved

network drives disconnecting

Posted on 2011-02-21
19
1,998 Views
Last Modified: 2012-05-11
This weird issue/problem has been going on for a while on this particular PC, and I’ve ran out of ideas to use on this problem.

At work we use a Novell server to keep My Documents and shared folders that different department use, and for some reason this ladies PC keeps the network drives mapped for different amount of times but looses them eventually; the amount of time the drives are kept is different for whatever reason. This is bad because this lady holds the world record as far as keeping many of her My Documents along w/ the shared documents of her department going at the same time, and needless to say she is not happy when she has to restart her PC. Maybe worse than that, this lady also keeps the world record of multiple email messages she is working on open at the same time. It would take her forever to read all of her open emails and decided to save or get rid of them…so we don’t do this part anymore but she doesn’t like it at all.

I have no idea what causes the network drives to disconnect to begin with. She does use any USB drives at all. As you can see by the screen shot 1 attached, logging back into Novell while still in Windows doesn’t map the drives; this is what I wish I could find out how to fix. If you double click on the network drive in my computer you get screen shot 2.

I really don’t have much to do on the server side of things—just install the Novell client on the workstations and set the files to save there. I’m not sure what version of Novell server we use, but I’d assume it’s got to be up to date.

Her PC will easily reconnect the connect drives if you restart her PC, but this is not a smooth way of fixing this issue that happens often. Because she has all of her My Documents open from the server, and the server mapping is lost, we can’t re save her documents easily; instead, I have to manually re save her world record of open stuff to the hard drive, and remember which files I saved and where to reopen them for her.

I’ve made sure to turn off the power saving dealing w/ the NIC card, windows auto update disabled, made sure NAV corporate doesn’t scan network drives, got the latest driver for the NIC (Intel d82566dm-2). I’ve un installed & re installed the Novell client still does that same. There is the HP scanner software but I disabled the auto update in there too. I’ve done little things such as used registry cleaner w/ ccleaner and defragged the drive but not much else I can think of. There are other PCs of this same model used in the college, but off hand I can’t think of one that still has XP on it.

I haven’t done the whole PC over again from scratch w/ XP, but this PC doesn’t have any other problems except this one. This lady takes her PC as her livelihood, and if I were to take this PC for a day and redo she’d have to take the day off.
Her PC is an HP 5800 Microtower, Intel Core 2 Duo 3.0ghz, 4.0gig RAM, Windows XP SP 3, and the latest Novell client release for XP; something like RCi I believe.

This lady does have a UPS, and the PC is set to hibernate mode when it loses power and runs from the UPS, but there are times the UPS records shows it hasn’t activated but the drives are still disconnected.

I think the answer for this is to redo the PC & put Windows 7 on it. There are a few other people that have the Novell drives disconnect for whatever reason, but these people have Windows 7, and I’m able to use the Novell login within Windows to get the drives back again, which saves a lot of trouble.

I’ve mentioned the Windows 7 idea to the lady many times but she doesn’t want to do it; says she is used to the Windows she works w/.

There may be some re connect time interval setting in the client I need to change or some kind of file caching, but I’m pretty much out of ideas on what else to try on this one.

I’m not really out for an absolute fix to make the drives never disconnect again, but what I’d like to find a fix for is how to make the Novell login re map the drives as it does in Windows 7. Maybe this is some registry setting in XP that causes the drives not to re map?

I’d think there is someone out there that has had the same problems/experiences with this issue.
Thanks for any ideas

ss1.JPG
ss3.JPG
0
Comment
Question by:kevluck373
  • 9
  • 9
19 Comments
 
LVL 34

Expert Comment

by:PsiCop
ID: 34947876
<pet peeve>
You don't have a Novell server.

Novell is a company. It makes a number of products, including NetWare, GroupWise, ZENworks, SuSE Linux, etc.

You have a NetWare server. Or possibly an Open Enterprise Server - you're not very specific on what exactly you have, or the version thereof.

You didn't say Microsoft 7, did you? So why say Novell server?
</pet peeve>
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 34947897
Since you didn't bother to describe the back-end environment (e.g. NetWare or OES, version) or the version of Novell Client 32, it's very difficult to give you good advice. The detailed descriptions of her PC and NIC aren't really germane.

Are you running NCP over TCP/IP or (shudder) IPX?

When you install Client 32, do you select the appropriate protocol? It's never a good idea to install it with both TCP/IP and IPX support, but since we don't know what you're running, it's hard to say which you should use.

A lot more information is needed to get any further into helping you.
0
 

Author Comment

by:kevluck373
ID: 34948114
Well we use netware server along w/ groupwise, but as I mentioned my work is at the PC level not the server itself, which means I don't know specifics about the netware server such as version and so on.

We/I don't install IPX just TCP/IP, and I very much assume that's what the novell client uses. don't have file & printer sharing installed either.

I'm just really interested in finding out if there's a way when I log back in as her using the Novell client while still in Windows the drives can or will re connect instead of seeing the mapping errors as seen in the included screen shot.

it seems to me it must be something particular w/ this PC. other users get their files from the same server and never have the same problem this PC does. very rarely an occasion of the drives disconnecting on other users of the same model PC, but even then I'm able to simply login again in w/ Novell client while still in Windows and the drives come back...why I have to restart her PC is the part I'm stuck on.

i hope this gives some more workable info
0
 
LVL 19

Expert Comment

by:deroode
ID: 34954375
Two things come to mind:
- On the first sreenshot (ss1) 40 Novell G.... are opened. Are these the emails you mentioned? Does the problem als occur when less emails are open, or is is more a matter of time?
- When re-loggin in the mappings don't seem to work, which is probably because they have a slash after the Vol1: The O: mapping seems to work well because it maps to CCCFILES\SYS:Public (without a slash after SYS:) Do the mappings originally come from the login script (i.e. do they work when logging in the first time) or are the mappings established because you (or your user) have established persistent mappings ("reconnect on logon")
Try to modify the login script: MAP ROOT s:=CCCFILES\VOL1:PSHARED\etc
Or use the NDS syntax instead of bindery: (bindery syntax maps to a server, NDS syntax maps to a volume object in NDS): MAP ROOT S:=.CCCFILES_VOL1.OU_OF_SERVER.ORG_NAME:PSHARED\etc
Check with Consoleone what the exact name and context of the volume object is.
0
 

Author Comment

by:kevluck373
ID: 34961013
I don't think this has to do w/ her having many GW messages open. I checked her PC first thing this morning and the drives were disconnected again somehow. Being I had to restart her PC Monday she didn't have many emails open.

The weird thing about this morning is the first thing I did was to double click on the drive in My Computer and got the not accessible message, but then I tried right clicking on the N in the systray, chose login, and this time it worked for whatever reason. I don’t think it’d make a difference if I double clicked on the drive in My computer and then try logging on to fix the not being able to login again while still in Windows; something I’ll keep in mind though.

The mappings are done in the scripts when she logs on. I’ll change the scripts w/ your suggestions tomorrow.

The word, excel, etc, files she has open come from the server, and I'm wondering if that may have something to do w/ this?
I’ve been researching on the internet about this, and I’ve seen it mentioned a few times to have file caching turned off but possibly turn file commit on; says file commit will take performance down.

This is an off the problem question, but have you ever been able to use console1 in Windows 7. I haven’t, and the only way I’ve been able to get it to work is to use virtual XP downloaded from Microsoft.

Thanks for your time & help
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 34961209
OK, so you NetWare back-end is at least NetWare v5.0, and it is configured to use NCP over TCP/IP (Novell called this "Pure IP").

And good, you install Client32 for TCP/IP only. Mixing protocols is a common mistake.

Since the disconnects are intermittent, I'd suggest the following troubleshooting items:

Make sure your Name Resolution Providers and correctly enabled and in the proper order for your environment. If you use SLP (and odds are you do, unless someone munged the NetWare environment setup), make sure Client32 prefers that. (If you're not fluent with the back-end environment, you might want to check with whoever runs it to verify what the correct Name Resolution Provider should be - or compare the workstation to one that doesn't have any problems)

If DHCP is in use, check to see that it is handing out the proper Options in the DHCP Reply. For example, if the DHCP Reply contains the IP (or IPs) of the network's Directory Agent(s), make sure they're all correct.

Insure the NCP Signature Level is set appropriately. If Client32 is configured to request (but not require) NCP Signatures, but the server infrastructure has the feature entirely disabled, then Client32 is wasting time making requests that aren't going to be honored.

Check the SLP Scope and use of Broadcast.

Avoid (as in do not install) Micro$oft Client for NetWare Networks. It is a buggy piece of garbage and absolutely should not be installed on workstations using Client32.
0
 

Author Comment

by:kevluck373
ID: 34979174
One thing I’ve noticed about the Novell client is when the PC locks itself—uses the screen saver w/ resume shows login on screen—and you see the Novell login screen when you move the mouse or hit the keyboard the server part is ghosted out. The tree & the context boxes are still filled in on the login screen but not the server.

I’ve tried to take a screen shot of the login w the server ghosted out but haven’t had luck w/ it; guess you have to be logged into Windows to do the print screen.

You can still login from the login screen but seems to take a while longer because the server isn’t specified for some reason.
If I go to the Novell client properties, system login profiles, choose default, properties, the server is specified there, but for whatever reason still doesn’t display the server in the login screen.

Looking through the advanced settings, advanced menu settings, advanced login within the Novell client properties I haven’t noticed anything that could be blocking the server in the login screen; yet, if you restart the PC the server is not ghosted out anymore.
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 34979659
What about the power profile of the PC? Is it sleeping the NIC, or going into some sort of partial hibernation?

What you describe sounds like loss of network connectivity and Client32 is having to re-negotiate the entire connection.
0
 

Author Comment

by:kevluck373
ID: 34980490
The PC is on a UPS and set to hibernation. When the server is ghosted out on the login screen, and you may already know, but you can't click in the box and type the server; just gray and you can't click in it.

I've included some screen shots of the configuration of settings, but this could be the root/cause of the problem. Somewhat odd though, sometimes the drives disconnect, but you look at the UPS log and no outage or intervention of the UPS is listed.
hibernate.JPG
power.JPG
UPS.JPG
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 34

Expert Comment

by:PsiCop
ID: 34985085
The UPS intervention isn't what I'm thinking of. Does it go into hibernation? If so, I suspect that is the cause.
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 34985101
Once it actually goes into hibernation, the server if going to think the workstation crashed (reasonable assumption - the workstation is running WinBlows, after all). When the workstation fails to respond to packets from the server asking Are you still there?, the server will terminate the connection.

When the workstation comes out of hibernation, the authentication and cryptographic states of its connection are no longer valid. It has to go through the re-authentication process.
0
 

Author Comment

by:kevluck373
ID: 34989522
I suppose the UPS without hibernation won't allow the user to reboot w/ all the applications that were running?
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 34993901
Well, if it isn't running on the UPS, then why would it need to hibernate?

Hibernation is reasonable when power fails for more than a few seconds and the workstation needs to do something before the UPS batteries die. But in the ordinary course of operation, why would the workstation hibernate?
0
 

Author Comment

by:kevluck373
ID: 34996719
I checked it out this morning and the drives were disconnected, but this time I manually mapped the drives for her.

I've set the UPS to turn the PC off after 5 minutes of being on the UPS along w/ turning hibernation off. I've always done the hibernation for her because she leaves the word record of things open @ once, and if the power outage goes past 5 minutes, she'll be able to turn her PC back on w/ her world record off open stuff to continue where she left off.

You may have already answered this one, but since the server part of the client is ghosted out, can you include the server in the contex or may be the login name? Maybe users.CCCC.CCCCFiles in the context?

Tree : CCCC

context: users.CCCC

server: ghosted out
0
 
LVL 34

Accepted Solution

by:
PsiCop earned 250 total points
ID: 35002886
I'm not sure if you can do that (include the Server's Context) in the box. However, you could implement Contextless Login.

You may also be able to fully specify the Context of the user's Object in that box. I've never tried either one, but it won't hurt to experiment.
0
 

Author Comment

by:kevluck373
ID: 35018304
I'm experimenting w/ the LDAP contextless login, and I have enabled LDAP contextless login & Context search scope. The screen shot I've included says the context field should include at least 1 item.

I'm not sure how you'd exactly specify the right item. The context of this user would be users.CCCC, but I'm not sure if I'd have to do the different kind of specifications such as ou= and so on.
contextless1.JPG
0
 

Author Comment

by:kevluck373
ID: 35018397
Here's another screen shot of the error I get when I try to specify the context in the LDAP.

I can add the server in the servers box w/o getting an error message, and I've been playing around w/ the contextless login on the ladies PC that's having the problems, but doesn't seem to work w/ just specifying the server.

I don't suppose you have to use something like the bindrey active authenticator.
contextless2.JPG
0
 
LVL 34

Expert Comment

by:PsiCop
ID: 35023176
You mean Bindery Emulation?

I don't think Contextless Login and Bindery Emulation are related - I used to know what specifically required Bindery Emulation, but I can't recall everything. I know that NoRM uses it, but I think something else does too. But I don't think it has anything to do with Contextless Login.

Regretfully, it's difficult for me to be more helpful. I'm no longer day-to-day with NetWare, and while I still have it around, the fact that It Just Runs kinda works against me. I'm just not monkeying around with it all the time, and I'm not in an environment that uses Contextless Login, so I don't have that to poke around on my side.
0
 

Author Closing Comment

by:kevluck373
ID: 35023450
He stuck w/ me for a good amount of time and I was able to use ideas/suggestions I'd never thought of.
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
Are you unable to connect or configure Hotmail email account in Microsoft Outlook 2010, 2007? Or Outlook.com emails are not downloading to Outlook? Lets’ see the problem and resolve Outlook Connector error syncing folder hierarchy (0x8004102A).
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now