Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1122
  • Last Modified:

Sharepoint 2010 site permissions not working

I have a very unusual issue going on in my new SharePoint 2010 farm.

A user reported that there are no files in their new library. I went to the library and I see the files just fine, so I'm thinking oh no big deal they just don't have permissions to that library. However when I checked the library permissions it was simply inheriting permissions from the parent site, and the user is in a group giving them read permissions to both the site and the library. I then ran a "check permissions" on the site, and it comes back confirming they have read access. I then checked the documents specifically to make sure they did not have unique permissions, and again she has read permissions to these individual files.

In an effort to resync the permissions, I broke inheritance on this library, and they tried again to view files but alas she still cannot see them although it shows she has read permissions to it.

Finally I added her to another group with contribute permissions on this site and library, but again she still cannot get access despite it showing she now has permissions.

All in all I'm a bit stumped as SharePoint shows the user has correct permissions, but in reality they can't get access. Any help would be very much appreciated!

Oh and BTW this is not a view issue, this is our standard all documents view, all other users are using the same view and see all the documents.

 Check permissions for user in this library Groups present lin this library
0
dkirchhefer
Asked:
dkirchhefer
1 Solution
 
GeorgeGerguesCommented:
[1] Check that files are Checked in .
[2] If approval workflow is enabled on library , make sure they are published / approved docs.


Best of luck

0
 
dkirchheferAuthor Commented:
Thank you George! I didn't even think that the site admin might have accidentally enabled content approval!

I turned it off and everythign is now visible to the user.

Thanks for your help!
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now