Exchange 2010 - OWA - Rights management operation failed

We just implemented a new Small Business Server 2011 over the weekend, now when a user logs into the OWA interface they are prompted with an error that says Rights Management Operation Failed.

Details below:
Request
Url: https://*domain*.org:443/owa/forms/premium/SubPageEventHandler.aspx?ae=Item&a=Preview&t=IPM.Conversation&id=CID.jIn1wxoZZU%2bjrR2iSj2XgA%3d%3d.LgAAAAASs9o68YbcS4%2fbs67BEavYAQDz8JgEoEZ4SrmGTqEj14JyAAAABEMlAAAB.LzcAAAAEQyEAAAAANWkCAAAAAAA%3d&calist=&canary=863b68c5e25b4195a54e53519b93c578&SP=1&pfmk=M46%3a1298313956191&subpage=ReadConversation.ascx
User host address: *ip address*
User: *Name of User*
EX Address: /o=First Organization/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=*User Name*
SMTP Address: *Email Address*
OWA version: 14.1.218.13
Mailbox server: *FQDN*

Exception
Exception type: Microsoft.Exchange.Data.Storage.RightsManagementPermanentException
Exception message: Rights management operation failed.

Call stack

Microsoft.Exchange.Clients.Owa.Core.UserContext.get_IsIrmEnabled() 
Microsoft.Exchange.Clients.Owa.Premium.ConversationUtilities.LoadConversation(UserContext userContext, OwaStoreObjectId owaConversationId, PropertyDefinition[] requestedProperties) 
Microsoft.Exchange.Clients.Owa.Premium.ReadConversation.OnLoad(EventArgs e) 
System.Web.UI.Control.LoadRecursive() 
System.Web.UI.Control.LoadRecursive() 
System.Web.UI.Control.LoadRecursive() 
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Inner Exception
Exception type: Microsoft.Exchange.Security.RightsManagement.RightsManagementException
Exception message: BindValidityTimeViolated

Call stack

Microsoft.Exchange.Security.RightsManagement.Errors.ThrowOnErrorCode(Int32 hr, LocalizedString contextMessage) 
Microsoft.Exchange.Security.RightsManagement.Errors.ThrowOnErrorCode(Int32 hr) 
Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.DrmEnvironment.InitializeEnvironment() 
Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.Initialize() 
Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.InitializeIfNeeded() 
Microsoft.Exchange.Data.Storage.RightsManagement.RmsClientManager.get_IRMConfig() 
Microsoft.Exchange.Clients.Owa.Core.UserContext.get_IsIrmEnabled()

Open in new window

tomtcsAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
MichaelVHConnect With a Mentor Commented:
Hi there,

somehow I suspect that IRM is enabled for the virtual directories.

Could you please do the following?

1. Log on to the exchange server and open (as Administrator) the Exchange Management Shell (EMS)
2. Run "Get-OWAVirtualDirectory | FL" and search for IRM; you'll probably see that it's enabled.
3. Run "Set-OWAVirtualDirectory -IRMEnabled $false"

Now reset IIS and try OWA again.
0
 
tomtcsAuthor Commented:
[PS] C:\Windows\system32>Set-OWAVirtualDirectory -IRMEnabled $false

cmdlet Set-OwaVirtualDirectory at command pipeline position 1
Supply values for the following parameters:
Identity:

What do i put for identity?
0
 
MichaelVHCommented:
could you post me the outcome of the Get-OWAVirtualDirectory command please?
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
tomtcsAuthor Commented:
figured it out based on your comment: owa (Default Web Site)

Performed an IIS reset and working now :)
0
 
sovranCommented:
This fix worked for me. Same issue. The identity that it is asking fro is listed in the output of the GET command. It my be SERVERNAME\owa (Default Web Site) for you....
0
 
tamaneriCommented:
this worked for me too. thanks guys.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.