?
Solved

Remote Web Workplace (RWW) stopped working on SBS 2008

Posted on 2011-02-21
11
Medium Priority
?
1,393 Views
Last Modified: 2012-05-11
After a simple reboot of our SBS 2008, remote web workplace no longer works.
When we go to https://remote.domainnamegoeshere.com it shows the default IIS7 logo
If we go here https://remote.domainnamegoeshere.com/remote we get a 404 error

Any suggestions?
0
Comment
Question by:rheide
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 6
  • 5
11 Comments
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34945959
Did you apply any updates? If so several Windows updates require a second reboot before the RDP protocol will work again.
0
 

Author Comment

by:rheide
ID: 34945969
WOW - that is scary but good to know. There could have been updates that were installed previously - we were rebooting because the server was a big "sluggish"

So - if do all your work remote - you could potentially have an issue as you wouldn't be able to access the server again - is that accurate?

In this instance, I just rebooted again now (based on your suggestion).

Thanks for the quick reply - I will report back in a few minutes.
0
 

Author Comment

by:rheide
ID: 34946114
ok, that does not seem to have fixed anything

Still getting the IIS7 logo

when I go to ..../remote - I get the following:
Server Error in '/' Application.
--------------------------------------------------------------------------------

The resource cannot be found.
Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /remote/logon.aspx

0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
LVL 77

Expert Comment

by:Rob Williams
ID: 34946142
>>" if do all your work remote - you could potentially have an issue as you wouldn't be able to access the server again - is that accurate?"
Correct and very frustrating when you get caught. It only happens a once in a while and not on all servers.
As per a similar post yeaterday where I stated:
As a result it is best to do one of the following when applying updates remotely.
1) work from the console instead
2) have an alternate logon method such as TeamViewer, Logmein, etc. that doesn't use RDP protocol
3) write a script that will automatically reboot the server in 20-30 minutes. Do your restart, if you can reconnect, cancel the script/scheduled reboot
4) where you are the LAN you could use the shutdown command to remotely reboot a server
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/SBS_Small_Business_Server/Q_26834539.html
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34946176
In the IIS management console when you click on "sites" does it show as all being started?
0
 

Author Comment

by:rheide
ID: 34946201
In IIS after I click on Sites, the Default Web Site shows a question mark onto of the globe.

Under SBS Web applications (where remote and owa are)- it shows as stopped with the same error as below.

In Windows SBS Console - Shared Folders and Web Sites and click on Web Sites tab
It shows RWW, OWA and Internal Web Site
RWW and OWA show a red x
if I click on it and hit enable this site, I get a message that says "The Web site cannot be started. Another web site may be using the same port."

I'm troubleshooting right now but wanted to post this real quick.
0
 
LVL 77

Accepted Solution

by:
Rob Williams earned 2000 total points
ID: 34946282
In the right hand pane it will show to which port the web site is bound. Do you have any add-on web based utilities in that window such as A/V consoles that might conflict? Especially on port 443.
0
 

Author Comment

by:rheide
ID: 34946307
You got it. Now if you wouldn't mind ... can we try to figure out what would cause this.

I went to default web site and noticed references to 443 over to the right so I just stopped it and then started "SBS Web Applications" and its working.

Any ideas how this happened and/or what to do to prevent the same issue the next time I reboot?
Also, what functionality did I just loose?

Thanks a bunch!!!
0
 

Author Comment

by:rheide
ID: 34946342
just to clarify, I can get to the RWW login (and can login).

If I try to access /owa - I get the following error
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C)
Timestamp: Mon, 21 Feb 2011 20:40:35 UTC


Message: Syntax error
Line: 6
Char: 1
Code: 0
URI: https://remote.domainnamehere.net/owa/8.1.393.1/scripts/premium/flogon.js

0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 34946427
>>"I went to default web site and noticed references to 443 over to the right so I just stopped it and then started "SBS Web Applications" and its working."
The default configuration of the default web site, under bidings, is just port 80. Not sure how 443 was added, perhaps by the update?

The OWA error I think is a different issue and I am not familiar with that. I did Goggle and find this for what it is worth:
http://my-technet.com/index.php/microsoft/exchange/exchange-2007/blank-owa-page-after-installing-exchange-rollup-patch/
0
 

Author Comment

by:rheide
ID: 34946648
Ok - I'll leave that issue for another time!!
Thanks,
R
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
Suggested Courses

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question