Solved

cfChart Error

Posted on 2011-02-21
4
888 Views
Last Modified: 2012-05-11
I'm getting the following error:

Text outside XML: default  
 
 
The error occurred in C:\ColdFusion9\wwwroot\myMobiSaver\login\member\charts.cfm: line 215
 
213 :                           <cfchartdata item="Cell Phone Coupons" value="#val(vCellThirty)#">
214 :                           <cfchartdata item="Coupons Printed" value="#val(vPrintThirty)#">
215 :                           <cfchartdata item="iPod Coupons" value="#val(viPodThirty)#">
216 :                           </cfchartseries>
217 :                           </cfchart>
 
I posted my entire cfchart code below.
<cfquery name="cellcoup" datasource="#DSN#">
						SELECT DISTINCT coupname, SUM(cell) AS total FROM tracker
						WHERE DATE_SUB(CURDATE(),INTERVAL 60 DAY) <= hitdate AND
    					Memberid=#memberid#
						GROUP BY coupname
						</cfquery>
                          <strong>Total coupons for cell phones</strong> <br />
                          <cfchart 
		scalefrom=0
		scaleto=20
		font="arial"
		fontsize=16
		gridlines=10 
		show3d="yes"
		foregroundcolor="##0000CC"
		databackgroundcolor="##CCCCCC"
		chartwidth="580"
	>
                          <cfchartseries 
  type="BAR" 
  seriesColor="blue" 
  paintStyle="shade"
  seriesLabel="xxxx">
                          <--- FIRST 0
                          <cfoutput query="cellcoup"> <---- LOOP THROUGH QUERY, DRAW EACH POINT
                          <cfchartdata item="#cellcoup.coupname#" value="#val(cellcoup.total)#">
                          </cfoutput>
                          <---- END 0
                          </cfchartseries>
                          </cfchart>

Open in new window

0
Comment
Question by:sonicimpulse
  • 2
  • 2
4 Comments
 
LVL 39

Accepted Solution

by:
gdemaria earned 500 total points
ID: 34947475

Does your Coldfusion folder still have the default.xml file in it?   Did you modify it in anyway?  

 Location of default.xml file for charting under coldfusion folder
0
 

Author Comment

by:sonicimpulse
ID: 34947536
only folder I have is the "cache"  I'm missing all of those files.

How do I get them back?
0
 
LVL 39

Expert Comment

by:gdemaria
ID: 34948507

Copy from another server or reinstall?

What version are you running?
0
 

Author Closing Comment

by:sonicimpulse
ID: 34970484
Thanks.  I did a reinstall and it works perfect now.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently while working on a project I got a very annoying cfdocument has no body error message. I had never seen this error before. So I checked the code. The code was pretty simple; it was Just showing me the cfdocumnt tag and inside that tag a …
Developer portfolios can be a bit of an enigma—how do you present yourself to employers without burying them in lines of code?  A modern portfolio is more than just work samples, it’s also a statement of how you work.
Explain concepts important to validation of email addresses with regular expressions. Applies to most languages/tools that uses regular expressions. Consider email address RFCs: Look at HTML5 form input element (with type=email) regex pattern: T…
This tutorial will teach you the core code needed to finalize the addition of a watermark to your image. The viewer will use a small PHP class to learn and create a watermark.

948 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now