[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1096
  • Last Modified:

InfoPath data source external SharePoint site

I’m trying to use an external SharePoint site for my data source “ HTTPS://external” and I receive this error “ InfoPath cannot connect to the site The site may be temporarily offline or your computer might not be connected to the network.” If I use the alternate access mapped site ”  http://internal “ I can make the data connection. Using the Internal address for the data connection, I cannot fill in the InfoPath form from the external site.
The real question how can I build a form in InfoPath that a user can fill out from a HTTPS:// address outside of the internal site.
0
HuckTx
Asked:
HuckTx
  • 4
  • 2
1 Solution
 
clayfoxCommented:
I have played with this before and I understand the issue.

My guess is that unfortunately your external url does not work internally as well.

One option is to use a computer externally open the form design there.  Go through and setup the external data connection where it can be validated and then save your template again.

Then republish it.  It is clunky but that may be the only way.  Otherwise you need that external link to work via DNS and permissions internally as well.

Another option is to export the template source files and manually change the URL in the manifest file.
0
 
HuckTxAuthor Commented:
Thanks for the notes, My internal url works grate with InfoPath It just my external URl. The external url does have a fully qualified domain name and work except for InfoPath. I"m thinking it has something to do with the port infopath is using Port 80, my external site is HTTPS witch uses port 443. I was watching the traffic from infopath to the HTTP connection and it was only passing Port 80 Traffic. Is there a way to configure the port InfoPath uses?
0
 
clayfoxCommented:
InfoPath can use https.  I have had to use that before.

Now is the error in form design or when the person tries to execute the form.

One thing to remember is that during execution, IE security settings are used.  You need to have the https site URL in your local intranet security zone or you will get messages like this.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
HuckTxAuthor Commented:
More Details
I created a test form with two test boxes. went to publish the form to a SharePoint list, first tried to publish to https://external.company.com go error " The Following URL is not valid: Https://external.company.com" Second used http://internal and could publish just fine. My URL for internal and external are "https://projects.company.com and https://Projects"

Security Zone
Sorry, Are you referring to the five alternate access mappings zone?
My Https:// is in the Extranet zone and my http:// is in the Internet zone
0
 
HuckTxAuthor Commented:
Thanks for the Post, I worked out the problem.
The problem was I had my site extended wrong and that was the reason the form work internally and not externally.
I extended my site using an internal URL "http://projects" for the host header section when i extended the root site. so when you tried to fill out the form from the web side it could not find the Info Path Form Server because it did not have access to the internal URL.
I Deleted the site and extended it using the external URL "https://projects.xxxxx.com" after extending I went to AAM and added the internal URL "http://projects" and everything is good.
0
 
HuckTxAuthor Commented:
Worked the problem out myself
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now