Catalyst configuration - shared host

Hello,

I'm having trouble installing Catalyst on my shared host.

(Apache, perl 5.8.8)

Here is the issue:

I installed Catalyst:Runtime and Catalyst:Devel in local directory.
However, when I run "catalyst.pl Hello" to create a test app I get this missing module error:

"Can't locate Moose.pm in @INC"

As far as I can tell I have everything installed but for some reason it can't seem to find this module.

Can anyone elaborate as to what module this is and what might be going on?

Thanks

MAC
LVL 8
mac-willAsked:
Who is Participating?
 
APNFSSCConnect With a Mentor Commented:
What prints out to the screen if you run the following cpan

cpan> install Moose

0
 
APNFSSCCommented:
0
 
mac-willAuthor Commented:
Thanks.  However, this issue seems to be the wrong version of Moose installed.  I'm having trouble installing Moose altogether.

0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

 
APNFSSCCommented:
how did you install catalyst... what was the process you followed?
0
 
mac-willAuthor Commented:
basically I just did:

cpan> Catalyst::Runtime Catalyst::Devel


I think the problem is the Moose dependency installation is failing but I can't seem to figure out why.
0
 
mac-willAuthor Commented:

..........

"Out of memory error"

.......


I just noticed this, thanks.

I've contacted the system admin.
0
 
mac-willAuthor Commented:
Thanks for the help.

If anyone is having this same issue it is a problem with the installation of the Catalyst dependencies from a jailshell.
Also from a cpanel web installer.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.