Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Turn off auto-brightness in windows 7 ASUS M50VM Laptop

Posted on 2011-02-22
20
Medium Priority
?
2,211 Views
Last Modified: 2012-08-14
How do you stop the auto-brightness.

Adaptive brightness service is stopped, via msconfig.
All brightness settings switch to full.....

.... but still auto adjusting to the light in the room.
0
Comment
Question by:griffja21
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 7
20 Comments
 
LVL 3

Expert Comment

by:JanStoops
ID: 34949621
Have you restarted the computer. According to faq on the website of asus you have to use Fn key and A (says nothing about disabling any services)
0
 

Author Comment

by:griffja21
ID: 34949725
Function key and A, doesn't yield any feedback, so not sure what that does.

Restarted lots.  Boots up in full brightness and then readjusts straight away.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 34974874
If the Fn+A key isn't working, you must have disabled or uninstalled the hotkey utility; but, moving left from the power button are 5 status led's and then the light sensor.  Cover it with two layers of black electrical tape or anything else opaque over the sensor and the light sensor will always think its in a very dark room.
0
Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

 

Author Comment

by:griffja21
ID: 35000438
Thermorduric

There is no outstanding relevant suggestion to respond to.

The question was not, "how do I make brightness auto adjust think I'm in a dark room?"  
Or
"how do I make auto adjust permanently dim the brightness"

Surely closure requests are adequate notifications of intention and is a response.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 35002629
And I did not suggest coverring the sensor as a permanent solution; but, rather, as a perfectly viable test.

"If the Fn+A key isn't working, you must have disabled or uninstalled the hotkey utility" (or I guess it could be broken)  Which is it?
0
 

Author Comment

by:griffja21
ID: 35026151
I've not uninstalled any utilities, and some hotkeys are working....

e.g. Fn + F2 switches WiFi on/off.
e.g. Fn + F5 moves the slider up the scale, in "Control Panel\Hardware and Sound\Power Options", though this has no effect on the screens brightness.

some are not....
e.g. Fn + "down arrow" does not "play/pause"

I've also installed all the relevant utilities I can find on the ASUS support site in case I was missing something, though it's not evident what all the utilities are for and what effect they should have.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 35026270
The hotkey utilities interact with the BIOS and hardware.  The fact that some other keys don't work gives me the sinking feeling that its an ASUS bug which may have to be addressed by them.
Please try covering the sensor hole and report that that does stop it from auto adjusting.
You don't have access to another unit where you could see if the Fn-keys work differently, do you (like maybe on display where you bought it)?
0
 

Author Comment

by:griffja21
ID: 35026291
Covering the sensor dims the screen.  I don't have access to another unit.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 35027666
OK, then what happens if you turn the brightness all the way up with the hole covered?
That might just make it stay bright always!
0
 

Author Comment

by:griffja21
ID: 35041833
Please refer to the initial  question and my post on :  03/03/11 03:58 AM, ID: 35026151

Not sure if we all see the same time on posts so the ID is included in the reference.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 35043363
I understand that you want to disable the auto brightness feature; but, given that some of the Fn keys are dysfunctional (other than the one to turn off autobrightness), you either have defective hardware, ASUS screwed up the BIOS for your system, or they didn't test their hotkey software properly with your hardware.

ASUS' documentation stinks and there is no way we'll get them to give us the port and bit to set which would disable the autobrightness, so we're stuck.

You either HAVE TO pursue it as a warranty defect with ASUS or find a workaround.  There are no other choices.  Sorry.........
0
 

Author Comment

by:griffja21
ID: 35081679
Install SP1
0
 

Accepted Solution

by:
griffja21 earned 0 total points
ID: 35081830
Installing SP1 fixes the adaptive brightness issue.  Still cannot adjust brightness without a reboot.
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 35082199
So Windows 7 SP1 makes the sensor disable function work; but, it now won't remember your LCD brightness settings?
0
 

Author Comment

by:griffja21
ID: 35082692
Please read the thread
0
 
LVL 43

Expert Comment

by:Davis McCarn
ID: 35086676
and nowhere earlier did you mention that you could not adjust the brightness; I always read the thread.
0
 

Author Closing Comment

by:griffja21
ID: 35126173
Eventually found an answer
0

Featured Post

Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article is a collection of issues that people face from time to time and possible solutions to those issues. I hope you enjoy reading it.
When asking a question in a forum or creating documentation, screenshots are vital tools that can convey a lot more information and save you and your reader a lot of time
Windows 8 came with a dramatically different user interface known as Metro. Notably missing from that interface was a Start button and Start Menu. Microsoft responded to negative user feedback of the Metro interface, bringing back the Start button a…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question