Solved

Unable to change the submit behaviour of an InfoPath form as a SharePoint Webpart

Posted on 2011-02-22
3
3,763 Views
Last Modified: 2013-11-05
Hello all,

I've got an InfoPath 2010 form that I've added as a webpart on a SharePoint 2010 page. It's all working fine however I'm unable to change the Submit Behaviour. As you can see in the attached screenshot the behviour is greyed out and I've not got an idea as to why. Really I need the form to open a new form on submit.

 Submit behaviour greyed out on InfoPath Webpart
Any pointers greatly apprectiated.
Dan
0
Comment
Question by:chrislewissecurity
  • 2
3 Comments
 
LVL 28

Expert Comment

by:clayfox
ID: 34952962
My guess would be it is detecting the submit as an illegal type or you have not set a default submit.

In your form go into the Submit options and check. In 2010 they now have a box to select the default submit.

SharePoint needs to see this default and there may be some stipulations on what kinds of Submits a webpart will allow. I have not played with this yet.

I would assume submit to a library would be fine.

I think on a webpart you would want it to close and not leave the form open. This should be a reset of the form which i think is what you want, but again would need to play with it.
0
 

Author Comment

by:chrislewissecurity
ID: 34958910
Hi Clayfox,

On my submit I'm using custom rules with the data connection as the last option. I may be being blind but I can't see a tick box for a default Submit option :S could you screenshot where I should see it?

Unfortunately on this particular webpart I need the form to open a new form after Submit.

Curiously, and adding a bit more detail, this option was available the first time I added the form to SharePoint but now it is greyed out as shown in the screenshot from my first post.

Thanks,
Dan
0
 
LVL 28

Accepted Solution

by:
clayfox earned 500 total points
ID: 34960796
I am guessing it does not like your rules.

In SharePoint 2010 at the end of the submit data connection wizard I have been seeing a check box but maybe it is only for Filler forms.

There is also the Submit Options button in the ribbon. There you can configure the default.  I am guessign you should only have one submit.

I would make a test and create a new button with just the submit and see if you get the same issue, or a new simple form.  I am guessing something you added to the button has broken this.

If you use design checker does it show any warnings or errors?
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Since upgrading to Office 2013 or higher installing the Smart Indenter addin will fail. This article will explain how to install it so it will work regardless of the Office version installed.
I thought I'd write this up for anyone who has a request to create an anonymous whistle-blower-type submission form created using SharePoint 2010 (this would probably work the same for 2013). It's not 100% fool-proof but it's as close as you can get…
This video shows and describes the main difference between both orientations in Microsoft Word. Viewers will understand when to use each orientation and how to get the most out of them.
The viewer will learn how to create a normally distributed random variable in Excel, use a normal distribution to simulate the return on an investment over a period of years, Create a Monte Carlo simulation using a normal random variable, and calcul…

911 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now