Solved

Lotus Notes local address book

Posted on 2011-02-22
24
5,642 Views
Last Modified: 2013-12-18
Hi

Does anyone know how I can stop Lotus Notes looking at the local address book (names.nsf) for addresses?   They do use the local address book, but don't want it used for lookup
0
Comment
Question by:PCGB
  • 9
  • 5
  • 4
  • +2
24 Comments
 
LVL 22

Accepted Solution

by:
mbonaci earned 50 total points
ID: 34951501
I'm not sure, but AFAIK, you unfortunately cannot do that using any kind of setting.
The only thing that comes to mind is to create a new database from the pernames.ntf (personal names) template and transfer contacts there which would leave the current address book empty.

Any other kind of tempering with local address book could cause "locations", "server connections", "accounts", ... to malfunction.
Like e.g. changing the Type in db properties from "Domino Directory" to "Standard".
0
 
LVL 4

Expert Comment

by:QuinF
ID: 34951646
Some of my users have several local contacts they don't want to appear when sending emails and I have them remove their email address.  That seems to work for us.
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 34951766
Or even better, delete those users completely :)
0
 
LVL 4

Expert Comment

by:QuinF
ID: 34951801
They usually need them for the home address or the phone numbers and not email because we use Lotus Traveler and the contacts transfer to their iPhones.
0
 

Author Comment

by:PCGB
ID: 34951818
Thanks for the updates so far.    

This is the situation.     The people who are having this issue are BlackBerry users who have had their phone contacts added into names.nsf for OTA updates.   So the contacts are mostly just phone numbers from previous device.    Unfortunately now when they type a name, if it matches one from their names.nsf, it gets pickedup.   I can live with this issue, but they cannot
0
 
LVL 4

Expert Comment

by:QuinF
ID: 34951914
Yeah, if there is a John Smith in the Local AD and a John Smith in the Public AD, even if the Local contact doesn't have an email address, Lotus Notes uses that one first.  They need to have an "Exclude contact from email" feature.  I guess you can change the view to select no contacts on the Local AD and then your problem would be solved.
0
 
LVL 6

Expert Comment

by:bluemeln
ID: 34951965
The setting for opting in or out of using the local address book is located in the user's location settings. Edit the location > Mail tab > Recipient name type-ahead > You have the option between Disabled/Local Only/Local then Server. In your case, you would choose Disabled.

To set this for everyone in the email domain, you would change the Server Configuration Settings document: Domino Admin > Configuration tab > Server > Configurations > Basics tab > Type-ahead enabled or disabled.
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 34952062
Disabled?
Then it wouldn't work for names in server's address book neither?
0
 
LVL 6

Expert Comment

by:bluemeln
ID: 34952093
That is correct. I have not found a system-wide setting for controlling the Location settings, none that works.
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 34952159
No, I mean if you choose Disabled in your local location document, then type-ahead wouldn't work.
And, as I understood, PCGB needs type-ahead to work, but only for users listed in server's address book (as if there was "Recipient name type-ahead" option "Server only")?
0
 
LVL 6

Expert Comment

by:bluemeln
ID: 34952702
Oh, right. Yes, of course, it needs to be "Server Only." Was thinking one thing and typing another. Brain cramp. But yea, that's the solution.
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 34952729
Yes, but there's no option "Server only" :))
I formulated that option to better describe what PCGB wants to do.
Notice "...as if there was..."
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 

Author Comment

by:PCGB
ID: 34952943
location > Mail tab > Recipient name type-ahead >  only give me the options of

Stop after first match
or
exhaustively check each address book

This is not boding well :(

0
 
LVL 6

Expert Comment

by:bluemeln
ID: 34953203
PCGB, the different options can be explained by different client versions of Lotus Notes. I am using 8.0.2 client on an 8.5.1 server. It sounds like you are running a v8.x client in Standard mode. If you run it in basic mode (add the parameter -basic at the end of the command line in the shortcut), you will see the options I see.

You have two options: Either turn off type-ahead completely, or use the location setting "exhaustively check" but instruct your users not to keep person records in their local address books that are identical to the public address book. If they still need to keep these records locally, have them distinguish the name of the entry slightly from that of the public address book. Example:
Public address book: John Doe
Local address book: John Doe (at home)

Any solution that can set the type-ahead to "Server Only" (a setting thus far not available) would have to be programmed, so I would put this question into the Domino/Scripting categories. We have a domain with over 20 servers in different subdomains and the method of instructing the users has worked very well once they knew what to do.
0
 
LVL 4

Expert Comment

by:QuinF
ID: 34953321
If you can only identify the local address book view it uses to perform its lookups and change it to not contain contacts.  Just not sure which view it uses.
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 34958976
That's a good idea QuinF.
The view that Notes uses for name lookup is named ($Users).

You can try appending:
    & Form != "Person"

to the view selection formula.

That should do the trick.

You can also try renaming the view.
0
 
LVL 10

Expert Comment

by:larsberntrop
ID: 34959651
Another angle:

In the person document for the Domino Domain Directory, a person has a mail type (the field MailSystem).  This can be set to None (the value of the field is then a string, "100"

I think it is an interesting experiment to set the MailSystem field to "100" of the person documents in the Local addressbooks users want to skip.  Then restart the Notess application and try what happens.

This would be a safer way of changing the local nab.  The proposed change to alter the $users view  would be too much.
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 34959960
We're talking about users added in the local address book, not registered users in DD.
I'm not sure about previous versions, but in 8.5.2 there is no such field on the Contact form.
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 34959976
Oh, I get it (now).
But I think that the lookup is done simply by looking up the Users view, without any further filtering.
I could be wrong though. It would be interesting to find out...
0
 
LVL 10

Expert Comment

by:larsberntrop
ID: 34961912
I told you it is interesting...  The local mail router is a simpler version of the Domino router, it might follow part of its rules...
0
 

Author Comment

by:PCGB
ID: 35005528
Hi Guys,

Thanks for all your answers.   In the end I have gone for the option of leaving the names.nsf empty and switching off the syncing.  all addresses are stored in the mailfile.

I didn't think that this issue was as complex as it turned out to be
0
 
LVL 22

Expert Comment

by:mbonaci
ID: 35005579
Didn't I, in my first post, suggested to (re)move all contacts from local address book?
0
 

Author Comment

by:PCGB
ID: 35006080
Sorry, yes you are right.   I didn't fully understand the terminology.
0
 

Author Closing Comment

by:PCGB
ID: 35006102
I answered No to the solution being easy to follow, this is not due to the answer, but my not understanding the terminology
0

Featured Post

Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Join & Write a Comment

Even if you have implemented a Mobile Device Management solution company wide, it is a good idea to make sure you are taking into account all of the major risks to your electronic protected health information (ePHI).
If you get continual lockouts after changing your Active Directory password, there are several possible reasons.  Two of the most common are using other devices to access your email and stored passwords in the credential manager of windows.
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…

760 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now