Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4408
  • Last Modified:

Office 2010 Upload Center 'Sign In Required' Issue When Uploading Changes to MOSS 2007 Documents

I've just finished rolling out MS Office 2010 Plus throughout my organization and a frustrating issue has reared its head; when my users try to edit a document from any Shared Documents library on the Intranet site (MOSS 2007) , they're given an error by the Upload Center stating that a login is required.  When they click on the 'Resolve' option, nothing happens.

This is where things get interesting.  When I performed my testing, I did so on two virtual machines that exist on the same subnet as my Sharepoint server.  No such errors with the Upload Center exist in that scenario.  My users, however, are on a different subnet.

No other issues exist in regard to routing, so I'm convinced that this is local to either IIS or MOSS itself, but am so far stymied as to where to look.  Network is 2003 R2 functional level with two Server 2008 R2 domain controllers.

Please let me know if any additional information is required to assist, and thanks for any tips.
0
geotechenv
Asked:
geotechenv
1 Solution
 
Dale HarrisProfessional Services EngineerCommented:
I think this might not be an issue with Office 2010, which means I can help.

Can I ask you if you have the same issue when using Office 2007?  What about a .txt file?

I don't currently have Office 2010 to test this out with, but I feel pretty good about MOSS 2007, so let me know how your trials go.

Dale Harris
0
 
geotechenvAuthor Commented:
I do not have this problem with Office 2007; 2007 does not have the "Upload Center."

Would LOVE to have a solution; so far, I've come up with nothing.  Everywhere I've turned has been a dead end.
0
 
Dale HarrisProfessional Services EngineerCommented:
Well if the user is required to sign in at one location, but not another, it sounds like some kind of authentication getting blocked in the Upload center for Office 2010.

What kind of authentication do you have for your IIS hosting your SP Server?

Please list all of the checkboxes that are checked in your settings.

DH
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
geotechenvAuthor Commented:
On the Sharepoint - 80 website, I have the following regarding Authentication Methods:

Enable anonymous access is UNCHECKED
Integrated Windows authentication is CHECKED
Digest authentication for Windows domain servers is UNCHECKED
Basic authentication (password is sent in clear text) is UNCHECKED
.NET Passport authentication is UNCHECKED

On the Default Web Site, Authentication Methods is as follows:

Enable anonymous access is CHECKED
Integrated Windows authentication is UNCHECKED
Digest authentication for Windows domain servers is UNCHECKED
Basic authentication (password is sent in clear text) is UNCHECKED
.NET Passport authentication is UNCHECKED

...This intrigues me.  Integrated authentication should probably be checked for the Default Web Site, should it not?

0
 
Dale HarrisProfessional Services EngineerCommented:
I think we are only worried about the Sharepoint - 80 site, unless you have a different configuration than what I imagine.

I would try checking "Digest authentication for Windows domain servers" and see if that clears up your issues.

Then I would look into Office 2010 options and see if there's something there for authentication you can tweak.

HTH,

Dale Harris

0
 
Dale HarrisProfessional Services EngineerCommented:
Also, from what I'm reading:
http://itknowledgeexchange.techtarget.com/itanswers/have-authentication-problem-been-resolved-in-sharepoint-2010/

It looks like you should get the latest update for Office 2010 just in case it wasn't included in your copy of the software.

HTH,

DH
0
 
Dale HarrisProfessional Services EngineerCommented:
I want to highlight this from the above article:
"I assume you've put your SharePoint sites in your users' IE intranet security zones currently"

HTH,

DH
0
 
geotechenvAuthor Commented:
Trusted Sites Zone, Intranet Zone...  Doesn't make a difference.  No updates available for Office 2010, and enabling the Digest authentication option had no effect.

The thing I keep coming back to is that it works fine on the subnet that the server belongs to, but not on my users' subnet.
0
 
Dale HarrisProfessional Services EngineerCommented:
Is a port being blocked for authentication?  Can you switch the IPs and VLANs over on your other one that's not working and make sure it's not those boxes?  This would eliminate half of your variables.

DH
0
 
geotechenvAuthor Commented:
It isn't workstation-specific; I've verified that.  It does appear to be subnet-specific.

Worth noting?  The site is called Intranet, but the server is not.  IIS is redirecting http://[server name] to http://intranet.  But it always has been, so I do not know why this is such an issue for Office 2010.
0
 
Dale HarrisProfessional Services EngineerCommented:
I wonder if it's actually something wrong with your setup, or if it's a Microsoft bug :(

Have you tried allowing integrated authenticating with your default website and seeing if that fixes it?  It should be pretty easy to determine if you're going through your default website at all by going to IIS and right-clicking on it and hitting browse.  That should either bring up nothing, or your site.

HTH,

DH
0
 
geotechenvAuthor Commented:
Well, we can call this one resolved.

Somewhere along the line, a server named Intranet had been built and joined to the domain.  I had dismissed the idea that this was a DNS issue early on simply because it didn't manifest itself on the same subnet as the server.  I reasoned that if it was a DNS issue in anyway, I'd see other symptoms (like the site not loading in the browser at http://intranet, for example).  Additionally, it could not possibly be DNS because Office 2007 users could make changes to documents on the Sharepoint site without any problems at all.

Once I located the rogue server named Intranet and removed it from the domain, the issue vanished for my 2010 users.

It's always the simplest things that drive you nuts...

Thank you to everyone who tried to help.
0
 
Dale HarrisProfessional Services EngineerCommented:
I'm glad you got it resolved.  I guess you did spell it out with your previous statement:

IIS is redirecting http://[server name] to http://intranet.  But it always has been, so I do not know why this is such an issue for Office 2010.

And then my comment of:

I wonder if it's actually something wrong with your setup

I guess we were looking at it the whole time :)

Have a good one.

DH
0
 
siltechCommented:
we have same issue but in our case nothing related to dns or another server.
we have sharepoint 2010 and office 2010, like in the original question upload center is asking to sign in.
in office 2007 without the upload center everything works great, now i know the purpose of the upload center is to reduce network bandwidth (seems it's doing the job since i cant upload documents) but it's really annoying because currently the only way is from the web site or office 2007.
i've tried to disable it but without success.
someone can help?????
0
 
Ingeborg Hawighorst (Microsoft MVP / EE MVE)Microsoft MVP ExcelCommented:
This question has been classified as abandoned and is being closed as part of the Cleanup Program. See my comment at the end of the question for more details.
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now