?
Solved

404 IIS 7 ASP.NET Big File Upload Problem

Posted on 2011-02-22
3
Medium Priority
?
2,087 Views
Last Modified: 2012-05-11
I have the script at the bottom to upload files. If I upload files les than 20 mb around no problem upload perfect but if I put a 179 mb file or higher the IIS7 give me this error:
(404) Not Found. I made a trace of the error and found tell this:

MODULE_SET_RESPONSE_ERROR_STATUS
ModuleName RequestFilteringModule
Notification 1
HttpStatus 404
HttpReason Not Found
HttpSubStatus 13
ErrorCode 0
ConfigExceptionInfo  
Notification BEGIN_REQUEST
ErrorCode The operation completed successfully. (0x0)

Could you tell me what can I do to solve the problem?
Thank you here is the code

        String savePath = @"C:\inetpub\wwwroot\esp\alianza\actividades\nutricionIII\videostemp0\";



        if (FileUpload0.HasFile)
        {

            string FileExtention = System.IO.Path.GetExtension(FileUpload0.FileName);
            if (FileExtention == ".flv")
            {
         
                String fileName = FileUpload0.FileName;


                savePath += fileName;



 
                FileUpload0.SaveAs(savePath);

                UploadVideo0StatusLabel.Text = "Todo se subió correctamente";

               
            }

            else
            {
                UploadVideo0StatusLabel.Text = "is not flv";

            }



        }

    }
0
Comment
Question by:coerrace
  • 2
3 Comments
 

Author Comment

by:coerrace
ID: 34952557
HEre is my web.config. file I read somewhere to change  maxAllowedContentLength look:
<configuration>




      
      <system.web>
    <customErrors mode="Off"/>
            
            <authentication mode="Forms">
                  <forms name="TestAuthCookie" loginUrl="login.aspx" timeout="1000">
                        <credentials passwordFormat="Clear">
                              <user name="test" password="test"/>
                              <user name="test" password="test"/>
                        </credentials>
                  </forms>
            </authentication>
            <authorization>
                  <deny users="?"/>
            </authorization>
            <compilation targetFramework="4.0">
                  <assemblies>
                        <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/></assemblies></compilation>
            <pages controlRenderingCompatibilityVersion="3.5" clientIDMode="AutoID"/>
      </system.web>

    <system.webServer>
        <security>
            <requestFiltering>
                <!-- maxAllowedContentLength: bytes -->
                <requestLimits maxAllowedContentLength="3000000000"/>
            </requestFiltering>
        </security>
     
     </system.webServer>

</configuration>

But now give me this error with my web.config an I want 2 upload a file of 200 mb that´s it.

Maximum request length exceeded.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Web.HttpException: Maximum request length exceeded.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[HttpException (0x80004005): Maximum request length exceeded.]
   System.Web.HttpRequest.GetEntireRawContent() +11314919
   System.Web.HttpRequest.GetMultipartContent() +221
   System.Web.HttpRequest.FillInFormCollection() +345
   System.Web.HttpRequest.get_Form() +137
   System.Web.HttpRequest.get_HasForm() +11317092
   System.Web.UI.Page.GetCollectionBasedOnMethod(Boolean dontReturnNull) +141
   System.Web.UI.Page.DeterminePostBackMode() +163
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +249
0
 
LVL 29

Accepted Solution

by:
Paul Jackson earned 2000 total points
ID: 34953779
Open IIS 7 SnapIn
Select the website you want enable to accept large file uploads.
In the main window double click 'Request filtering'
once the window is opened you may see on top a list of tabs eg: file name extensions, rules, hidden segments and so on...
regardless the tab you select, in the main window rightclick and select "Edit Feature Settings" and modify the "Maximum allowed content length (bytes)"

0
 

Author Closing Comment

by:coerrace
ID: 34954747
Works Thank you
0

Featured Post

NFR key for Veeam Backup for Microsoft Office 365

Veeam is happy to provide a free NFR license (for 1 year, up to 10 users). This license allows for the non‑production use of Veeam Backup for Microsoft Office 365 in your home lab without any feature limitations.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
High user turnover can cause old/redundant user data to consume valuable space. UserResourceCleanup was developed to address this by automatically deleting user folders when the user account is deleted.
Is your data getting by on basic protection measures? In today’s climate of debilitating malware and ransomware—like WannaCry—that may not be enough. You need to establish more than basics, like a recovery plan that protects both data and endpoints.…
In a question here at Experts Exchange (https://www.experts-exchange.com/questions/29062564/Adobe-acrobat-reader-DC.html), a member asked how to create a signature in Adobe Acrobat Reader DC (the free Reader product, not the paid, full Acrobat produ…
Suggested Courses

850 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question