Solved

How to setup an anoynomous site!! Help ASAP

Posted on 2011-02-22
7
270 Views
Last Modified: 2012-05-11
I created a web application, with anonymous access enabled,  also windows authentication enabled with kerberos.

I created a content type

I enabled the content type on the page library

I created a page layout with a loginview, some controls on the anonymous template and some on the logged in template

 

Its showing me the logged in template, but when I press LOG OUT, (Just because I want to try surfing my site as an anonymous user), I copied the url of the page. and after logged out, I paste it into the browser, Sometimes I get 1 401 error, or sometimes  I just see the page again as logged in user, I want to test as an anonymous

 

please help
0
Comment
Question by:LuisEstebanValencia
7 Comments
 
LVL 10

Expert Comment

by:pramodsk40
ID: 34952222
0
 

Author Comment

by:LuisEstebanValencia
ID: 34952374
I did the 3rd example which applies to sharepoint 2010

but when I log out, close the browser, and copy the url http://luis-pc/Nederlands/Paginas/Agendas/ICT-Event-of-the-year-2011.aspx

then I see the page as systemaccount

:(
0
 
LVL 21

Expert Comment

by:chapmanjw
ID: 34952508
Your browser is auto-logging you in.  

I would try with a different browser (like FireFox) that doesn't automatically pass your Windows credentials to the site.
0
Salesforce Made Easy to Use

On-screen guidance at the moment of need enables you & your employees to focus on the core, you can now boost your adoption rates swiftly and simply with one easy tool.

 

Author Comment

by:LuisEstebanValencia
ID: 34952678
Already tried

 

but I still get the Unauthorized error.

I double checked and anonymous is enabled on the top site collection permissions. And it says Entire WebSite.

So I used google chrome, to try to navigate, but it still asks me for a username and password, if its really anonymous? why is still showing me the authentication window?

FYI

On central admin, it has also anonymous access enabled, but at the same time it has enabled windows authentication.

I am afraid that if I uncheck windows authentication, then I might lose the permissions to edit everything? because my local user is the farm administrator I am not inside a domain either.
0
 
LVL 6

Expert Comment

by:ThatSharepointGuy
ID: 34955532
One thing you can do is use STSADM/PowerShell to add yourself back in to site permissions (ie - Full Control, Owner, etc) if you need to.  Just search on technet "Add user to site".

Just off the wall, have you tried going into IIS and ensuring that AA is enabled there?  Just a hunch, and I could be wrong, but I use that for Non-SharePoint servers when i want to allow everyone in.
0
 

Author Comment

by:LuisEstebanValencia
ID: 34955856
I just checked IIS and anonymous access is enabled as well there.

dont know what else to do
0
 
LVL 6

Accepted Solution

by:
sabby447 earned 500 total points
ID: 34958685
Some pointers

1. If you are getting automatically logged in then please check if that website is added to any of security zones i.e. trusted or intranet most probably, Remove that from there
2. What it looks as is that you are trying to use the url on the same server where you have the site and please share if you are using a different host header name, If yes then you will have to add that host header in backward host header check or disable loopback check  in registry, Follow this article : http://support.microsoft.com/kb/896861 
3. Please ensure Anonymous and everyone users have access to the site

Please follow and share if this helps any and if you need any further information
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Move SharePoint data to a new server 3 68
DataTables - table not rendering.  No error either 5 76
Sharepoint KB 2 84
Is sending authentication through SOAP secure? 3 17
I used to be SharePoint evangelist in our company, so my Outlook always full of questions about how to do this, or where I can find that. One day I found such an email with the following question: "how to attach 3-State workflow (one of the workflow…
We had a requirement to extract data from a SharePoint 2010 Customer List into a CSV file and then place the CSV file into a directory on the network so that the file could be consumed by an AS400 system. I will share in Part 1 how to Extract the Da…
Email security requires an ever evolving service that stays up to date with counter-evolving threats. The Email Laundry perform Research and Development to ensure their email security service evolves faster than cyber criminals. We apply our Threat…
In an interesting question (https://www.experts-exchange.com/questions/29008360/) here at Experts Exchange, a member asked how to split a single image into multiple images. The primary usage for this is to place many photographs on a flatbed scanner…

821 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question