How to setup an anoynomous site!! Help ASAP

I created a web application, with anonymous access enabled,  also windows authentication enabled with kerberos.

I created a content type

I enabled the content type on the page library

I created a page layout with a loginview, some controls on the anonymous template and some on the logged in template

 

Its showing me the logged in template, but when I press LOG OUT, (Just because I want to try surfing my site as an anonymous user), I copied the url of the page. and after logged out, I paste it into the browser, Sometimes I get 1 401 error, or sometimes  I just see the page again as logged in user, I want to test as an anonymous

 

please help
LuisEstebanValenciaAsked:
Who is Participating?
 
sabby447Commented:
Some pointers

1. If you are getting automatically logged in then please check if that website is added to any of security zones i.e. trusted or intranet most probably, Remove that from there
2. What it looks as is that you are trying to use the url on the same server where you have the site and please share if you are using a different host header name, If yes then you will have to add that host header in backward host header check or disable loopback check  in registry, Follow this article : http://support.microsoft.com/kb/896861 
3. Please ensure Anonymous and everyone users have access to the site

Please follow and share if this helps any and if you need any further information
0
 
LuisEstebanValenciaAuthor Commented:
I did the 3rd example which applies to sharepoint 2010

but when I log out, close the browser, and copy the url http://luis-pc/Nederlands/Paginas/Agendas/ICT-Event-of-the-year-2011.aspx

then I see the page as systemaccount

:(
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

 
chapmanjwCommented:
Your browser is auto-logging you in.  

I would try with a different browser (like FireFox) that doesn't automatically pass your Windows credentials to the site.
0
 
LuisEstebanValenciaAuthor Commented:
Already tried

 

but I still get the Unauthorized error.

I double checked and anonymous is enabled on the top site collection permissions. And it says Entire WebSite.

So I used google chrome, to try to navigate, but it still asks me for a username and password, if its really anonymous? why is still showing me the authentication window?

FYI

On central admin, it has also anonymous access enabled, but at the same time it has enabled windows authentication.

I am afraid that if I uncheck windows authentication, then I might lose the permissions to edit everything? because my local user is the farm administrator I am not inside a domain either.
0
 
ThatSharepointGuyCommented:
One thing you can do is use STSADM/PowerShell to add yourself back in to site permissions (ie - Full Control, Owner, etc) if you need to.  Just search on technet "Add user to site".

Just off the wall, have you tried going into IIS and ensuring that AA is enabled there?  Just a hunch, and I could be wrong, but I use that for Non-SharePoint servers when i want to allow everyone in.
0
 
LuisEstebanValenciaAuthor Commented:
I just checked IIS and anonymous access is enabled as well there.

dont know what else to do
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.