Solved

IIS7 configuration error with Framework 4.0

Posted on 2011-02-22
4
938 Views
Last Modified: 2012-05-11
Hi,
Our webserver, Windows 2008 Web SP2, has Microsoft .NET Framework 3.5, 4 Client Profile and 4 Extended installed.

All our websites with 3.5 framework works fine but not a new one with framework 4.0

On https://secure.joboffice.se/Service2011.asmx you see the error "Unrecognized attribute 'targetFramework'. Note that attribute names are case-sensitive."

Please help
Rgds Cynkan
0
Comment
Question by:cynkan
  • 2
4 Comments
 
LVL 5

Accepted Solution

by:
WebDOT earned 500 total points
ID: 34952559
have you configured an application pool to use .NET 4, and assigned the apps in question to use that app pool?

3.5 and 4 can't use the same app pool.
0
 

Author Closing Comment

by:cynkan
ID: 34952580
Ahh, totally forgot.
Now works fine ;)

Many thanks
0
 
LVL 29

Expert Comment

by:Paul Jackson
ID: 34952664
Have you associated the application with .net 4.0 in IIS ?

Have a look at the steps towards the bottom of the link :

http://msdn.microsoft.com/en-us/library/dd483478%28VS.100%29.aspx
0
 

Author Comment

by:cynkan
ID: 34953137
Ohh yes, we builds in VS2010, fw4 but not so often for the web ;)
Thanks for the link.
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, just open a new email message. In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now