Solved

Can't Get WordPress installed on Windows Server 2008 R2 64 Bit

Posted on 2011-02-22
24
941 Views
Last Modified: 2012-05-11
Trying to do the preparation to meet requirements of Wordpress.  Issue is that I can't get MySQL installed.

Installed PHP and it went OK
When installing MySQL ran into this issue http://bugs.mysql.com/bug.php?id=50122 in which the instance configuration wizard fails (not responding) if you check the 'install as a service' box.

I managed to install MYSql without errors by unchecking that box as per these instructions...

I have the "same problem" in windows xp x64 sp2
The wizard gets stuck while starting the service.

*delete innodb folder and reinstall mysql
*run the setup wizard as you use to do
*UNCHECK install as a windows service
*install mysql as a service from a win shell
*set user and password from phpmyadmin or your favorite app

near bottom of previous link.

My issue might be solved by a completely different approach but if the above will work, I am stuck on the last 2 steps.

Help!
0
Comment
Question by:MSProjectGeek
  • 13
  • 11
24 Comments
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34954142
The first thing I would do is install WAMP, then follow these instructions for WordPress:
http://www.simplehelp.net/2008/08/25/how-to-install-wordpress-on-your-windows-pc/
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34954304
Thanks,

I have a few questions...

1. Are you suggesting WAMP as an alternative to MySQL and PHP? If so then do I uninstall MySQL and PHP and start from scratch with WAMP?

2. Is WAMP OK to run on Windows Server 2008 R2?

3. Is WAMP OK for a production server environment?
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34954924
1) It isn't an alternative to MySQL and PHP, it is an auto installer for them.

2)Yes you can install it on Windows Server R2, see here:
    http://www.wampserver.com/phorum/read.php?2,66425

3) Yes it is OK for a production server as long as you don't have more than 4-5,000 visitors a month. You will also need to change the permissions settings via PHP MyAdmin. It is set to be completely open which would cause problems on a live site. You need to change the user permissions.
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34956268
I just finsihed installing WAMP and tried launching it but got this message.

Problem signature:
  Problem Event Name:      APPCRASH
  Application Name:      php-win.exe
  Application Version:      5.3.4.0
  Application Timestamp:      4d090aa8
  Fault Module Name:      php5ts.dll
  Fault Module Version:      5.3.4.0
  Fault Module Timestamp:      4d0904d8
  Exception Code:      c0000005
  Exception Offset:      0000000000127929
  OS Version:      6.1.7600.2.0.0.272.7
  Locale ID:      1033
  Additional Information 1:      ef24
  Additional Information 2:      ef241527dd16ec29d01de16ee39c0e7c
  Additional Information 3:      d7e6
  Additional Information 4:      d7e62900ce4451b64a0275d425de03df

Any idea what's causing this?
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34956420
Did you download the correct version:
64bit:
http://sourceforge.net/projects/wampserver/files/WampServer%202/WampServer%202.1/WampServer2.1d-x64.exe/download

32bit:
http://www.wampserver.com/en/dl32.php

Did you completely un-install the previous installation?

If none of the above apply to you try this solution:
Add this to the PHP section of your php.ini file:
#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:/PHP"
LoadFile "C:/PHP/libpq.dll"
LoadModule php5_module "C:/PHP/php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

Open in new window

SOURCE:
http://www.apachelounge.com/viewtopic.php?p=17369
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34961860
I did uninstall the previous version.  I did download and install the 64 bit version of WAMP.  I went through the whole thing again uninstall all WAMP and PHP stuff, then reinstall WAMP.

Then rebooted.  Then ran WampServer from the desktop shortcut; saw a brief hourglass and then nothing.

If I then try to 'Put Online' from the Wamp utility in the system tray, I get the Aestan error message below
 Aestan Error Message
If I click on localhost from the Wamp utility in the system tray, I get the IIS7 screen splash - correct I think.

If I click on phpmyadmin from the Wamp utility in the system tray, I get the error message below
 phpmyadmin error message
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34962158
I get exactly the same as above if I add the #Begin.... stuff into my PHP.ini file

One odd thing I noticed is that there was a PHP folder under Program Files (x86)

I uninstalled again.

Deleted all wamp and php folders

Deleted 'Microsoft PHP Installer xxx' from Programs and features (HOPE THIS WAS NOT A BIG MISTAKE)

Tried reinstall.

Exact same issues as above only now, there is NO PHP FOLDER ANYWHERE??????

Sorry this is dragging out :(
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34962240
Actually there is a PHP folder under C:\wamp\bin

From wamp utility in the system tray, i can open and read the php.ini file
0
 
LVL 23

Accepted Solution

by:
jeremyjared74 earned 500 total points
ID: 34962631
You might need to add an exception to your Firewall to allow it to run.

By default, the Windows Firewall blocks all access to all network ports on your system. To be able to connect to the Apache Web server, you'll need to unblock the application. Click the Unblock button in the message box to permanently allow connections to your Apache Web server. If you're running a third-party firewall software package, such as Symantec Firewall, you'll need to unblock the Apache application port (TCP port 80) manually. Various firewall applications work differently, so please consult your firewall documentation to unblock the Apache Web server port.
0
 
LVL 4

Assisted Solution

by:MSProjectGeek
MSProjectGeek earned 0 total points
ID: 34963277
OK, got it working now.  Problem was caused by having IIS running at the same time.  I thought that IIS was needed for the rest to run but according to this link http://www.wampserver.com/phorum/read.php?2,40722 IIS causes conflicts.

Anyway, all I did was stop IIS running and localhost brought up the Winamp server page and
phpmyadmin brought up the phpMyAdmin page.
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34963306
No objections
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34963336
I don't know why I didn't think of that. I had the same issue when I installed mine. I'm glad we were able to work through it.
0
Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34963702
Thought I was done.  I got messages saying that I could not see stuff because the root password for MySQL was blank.  FOund link telling me how to change from shell....

mysqladmin -u root password NEWPASSWORD

Which I did but now I don't get prompted for username and password as shown in instructions here http://www.simplehelp.net/2008/08/25/how-to-install-wordpress-on-your-windows-pc/

When I click on phpMyAdmin under Tools I get....

Error
MySQL said:  

#1045 - Access denied for user 'root'@'localhost' (using password: NO)

phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server

Sigh
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34963825
Did you shut down and re-start the WAMP server?
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34963849
I haven't seen this error, but I have found a possible similar problem/solution. It is a little bit lengthy, so I will look for a more simple solution. Here is what I have found on the subject:
 
yesterday I tried to fix the problem, but the only think that was missing is the first line in MySQL command:

UPDATE mysql.user

I was writing ( UPDATE mysql ) : so please follow the next steps if you want to resolve your problem with ( #1045 - Access denied for user 'root'@'localhost' (using password: NO):

1 : go to your WAMP icon on your PC desktop screen and LEFT CLICK to open the menu, you will see MYSQL folder, CLICK to see MYSQL CONSOLE, open it.

2: now you have DOS screen ( a black screen ) :

A: if you already set a password, type it
B: if you did not do this step yet, write the following red text
B1: use mysql; and click ENTER on your keyboard
3: now write the following red text and click ENTER :

UPDATE mysql.user
->SET Password=PASSWORD("*******")
->WHERE User="root";

don't worry about this sign ( -> ) , because for example when you write ( UPDATE mysql.user ) and you click ENTER on your keyboard, a new line appear with this sign ( -> ), your command will execute when you write this sign ( ; ) at the end of your text and click ENTER.

NOTE: replace the password ******* by your password.

4: now write the following red text and click ENTER :

FLUSH PRIVILEGES;

5: and to exit the black DOS screen now, write exit and click enter.

------------------------- we are finished from MySQL now --------------

6: go to WAMP folder ( open your My Computer, click on C driver, and you will see WAMP folder ), click on APPS folder, and than click on your PHPMYADMIN folder ( e.g my folder called phpmyadmin2.11.6 ) and find the config.inc.php

7: open config.inc.php and find the following orange text:

$cfg['Servers'][$i]['password'] = ''; // MySQL password (only needed

and add your password now that you used in step number 3 like that :

[COLOR="rgb(255, 140, 0)"]$cfg['Servers'][$i]['password'] = 'yourpasswordhere'; // MySQL password (only needed[/COLOR]

8: now save this modification, and close config.inc.php

9: go to your web browser and type the following link :

http://localhost/phpmyadmin/

and enjoy, this is what happened with me.

NB: I wrote all this explications, because I'm also learning PHP and I found a lot on this website helped me, so I'm trying also to help you.

Open in new window


HERE IS THE SOURCE:
http://www.sitepoint.com/forums/showthread.php?p=3936598#post3936598
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34963862
OK, worked through that one. you have to specify the password in the config.inc.php file for phpmyadmin under where it says password = ''
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34963881
And here is one more. You need to make sure your directories to the files mentioned here match yours. I think this is for an older version of WAMP.
http://it.megocollector.com/?p=146
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34963885
So all is working?
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34964135
Now I can get to the wordpress site when I'm on the server by typing 'http://localhost' but, presumably because I removed the IIS7 role, I can't get to it from the network.
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34965567
Well I've gone full circle.  I uninstalled everything. Reinstalled IIS7, then wamp and I'm back where I started from.

I know it can work with IIS7 so I'm going to research more and see what needs to be changed.  I have to say that wamp is basically not installing properly with Windows 2008 R2 64 bit - period.

I'll report back when I've got it working; meanwhile any suggestions would be much appreciated.
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34965752
Sorry about that. It must have something to do with your configuration, or leftover settings from previous installs of MySQL, or PHP. It is clearly stated on the WAMP website that is does support your server. I'm not sure I can assist further without actually being in front of the computer myself. Let me know if there is anything I may be able to help with.
0
 
LVL 4

Author Comment

by:MSProjectGeek
ID: 34969640
I think the issue is clearly related to IIS7 co-existing with wamp.  If I simply stop IIS7, then the myphpadmin  and wamp admin sites comes up.

Almost ready to give up here.  Thanks for your help anyway.
0
 
LVL 23

Expert Comment

by:jeremyjared74
ID: 34969878
Have you configured separate ports for them ?
http://support.microsoft.com/kb/149605
0
 
LVL 4

Author Closing Comment

by:MSProjectGeek
ID: 34995449
Given you the points for your help - thanks
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

If you are looking for plug-ins to add functions to your WordPress small business web site, take some time to read though this comprehensive list.  These are all the plugins I use for my customers WordPress web sites, as well as my own.  Be sure to …
Do you think that WordPress is just for blogs?  Think again!  WordPress is really a fantastic all around platform that you can use to develop websites on.  Integrated into its basic functionality is the ability to create pages using your choice of a…
The purpose of this video is to demonstrate how to set up an RSS Feed on a WordPress Website. This will be demonstrated using a Windows 8 PC. Feedburner will be used for this demonstration. Go to your WordPress login page. This will look like the…
The purpose of this video is to demonstrate how to set up the permalinks on a WordPress Website. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Go t…

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now